Jump to content
spidey123

Battery status no longer updating in High Sierra

Recommended Posts

Just wondering if anyone else has experienced this issue so far.  I know its only a few days since its full release so I'm sure others will also have the issue which is why I didn't place it in the Latitude forum.  

 

So anyhow my battery status will no longer update in High Sierra, it was working perfectly in Sierra.  I tried generating a new ssdt.aml but it's still the same.  I thought possibly the older ssdt used on Sierra had a working status but after some more testing I have found that to not be true.  So same issues with old or newly generated ssdt.  

 

I've just started reading on the issue but I haven't found much info yet.  If anyone has any suggestions please let me know.  Thanks guys.

Share this post


Link to post
Share on other sites

Ok after further testing I have discovered that the status does seem to work if you boot with the power cord.  As long as it boots without using the battery it works, even if you then remove the cord and run on power it still keeps track.  However if you boot with battery power only then it will not refresh unless you keep refreshing yourself by clicking in the top main menu battery icon and then untick and then re-click "Show percentage"  Of course that only updates for that time, few seconds later you will need to manually refresh again.  Again this only seems to be happening when you boot with battery power.  

Share this post


Link to post
Share on other sites

Ok so I found a temporary work around that I'm sure has been used by many other people.  Just using HwMonitor to show my battery status and that works perfectly.  Everythinig else seems ok after 3 days of testing.  

Share this post


Link to post
Share on other sites

So after doing some research I found that I needed to install the latest ACPIBatteryManager.kext into /library/extensions and then rebuild the cache as well as removing/disabling the trim patch from clover config.plist.  Battery status seems to be refreshing correctly now.

Share this post


Link to post
Share on other sites

×