Jump to content
KemalALKIN

[SUCCESS] DELL LATITUDE E5440 macOS Mojave 10.14 (Updated)

Recommended Posts

Okay, it works on osxAptioFix, there was some issues with Clover update and with files such as ACPI, Drivers64UEFI or even FixHeaders save. I have updated all kext's too, there is updated package of updated EFI folder under this comment.

 

EDIT: There are still problems with busy timeout[1], (60s): `IGPU` and I dont know how to fix it.
 

UPDATED_EFI.zip

Share this post


Link to post
Share on other sites

So, Built-in SD Card reader is not working, brightness is not working, sleep and wake-up is not working but cause system restart, HDMI and VGA is not working probably too (it wasn't last time when I checked).

 

DSDT and IOReg attached below:

ioregistry.ioreg

DSDT.zip

Share this post


Link to post
Share on other sites

It's an O2 SD card reader so please apply the well-known DSDT patch to the associated device that you'll have to identify in IOReg.

 

Hint: look for a device carrying PCI vendor id 1217 (pci1217,xxxx)...

Share this post


Link to post
Share on other sites

I finished my hackintosh with exceptions, for example: VGA output does not work, and I was told that it has to do a 'gambiarra' (I think English would be something like jerry-rig); The fn keys are not yet running 100%; Gestures on the touchpad do not work (they recognize the touchpad but not the gestures). Also remember that I am using AR9485 for wireless. I am sending my repository to you.

 

https://github.com/soejin/hackintosh-dell-e5440.git

Share this post


Link to post
Share on other sites

Ouh! 😱 That Clover EFI folder sure is incomplete but there's so much stuff in that kexts folder that should not even be there! And that Clover config file! 💩

 

That definitely never came from here... Did you just throw things in there as a cocktail experiment and just got lucky the Hack booted macOS?

 

Share this post


Link to post
Share on other sites

I'm sorry but I do not agree with you. I used as a base the own EFI folder of Olarias Mac OS 10.13.5, and added the kexts that were missing. I did not have 'luck', I worked hard to make all things work this project is constantly evolving. I'm adjusting some things in DSDT and checked some other details. And I honestly will not accept you coming and saying that my sweaty work sucks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×