Jump to content
inokenshi

[SOLVED] Sierra security update, now kernel panic on boot

Recommended Posts

Hey guys, thanks for all the help you've given me recently. I got my hackintosh to a completely useable and awesome state. But then a security update ruined it all and now I can't boot into the OS at all. I tried taking a look at what's going on, but all I could discern from it was something about Lilu. Any help would be appreciated, and thanks again for all of your help.

 

post-114526-0-86243800-1517167006_thumb.jpg

Share this post


Link to post
Share on other sites

Update lilu.kext to latest v1.2.2

You can boot to Clover, hit the space, select "Block Injected Kexts", look under Other or 10.13 and disable it. So now you could get into the Desktop, assuming you have it in /E/C/k/Other or 10.13

Otherwise, if it's in /L/E or /S/L/E, then boot into single user mode, delete it and rebuild cache

Then update it after you get back onto the desktop

Share this post


Link to post
Share on other sites

So I got into the desktop by disabling the lilu kext like you said but to be honest, I don't really know how to update the lilu kext. Do I just run something like Kext Utility and install the latest lilu that way? Thanks for helping me get this far.

Share this post


Link to post
Share on other sites

Download and place it in /EFI/Clover/kexts/Other, replacing the old.

Link is attached in my post #2

Use Clover Configurator or EFI Mounter or ESP Mounter to mount the EFI partition.

Share this post


Link to post
Share on other sites

Got it to work! Thanks for all the help you guys have given me! There are few small, nit picky problems that I still have though, but I can live with them. It seems like the boot time has gotten a little slower(takes a few seconds for the progress bar to show up), and now when it is booting the boot screen bugs out a little bit and the apple logo splits into several( I can post a picture if needed). Like I said, I can live with that but I guess it would be nice if I could resolve it too. Regardless, I can boot into the OS now so my main problem is fixed.

Share this post


Link to post
Share on other sites

Not sure what version of Clover you're on but you should upgrade to v4380 (latest)

And update or add IntelGraphicsFixup.kext to /E/C/k/Other

 

The boot glitch is common and might not be able to fully remove 100% even with IntelGraphicsFixup.kext

Share this post


Link to post
Share on other sites

Updated like you said, everything is working pretty much like it used to. The boot screen goes black for a second or so but comes back and the progress bar finishes(exactly like before). Boot time is about the same as it used to be before too. All in all it's back to normal. Thanks so much for your help!

Share this post


Link to post
Share on other sites

First off I wanted to say Thanks to everyone that keeps this site running. I did a security update to my Dell 3450 running Mac OS 10.12.6 and was getting the reboot issue. I updated lilu but that didn't resolve the issue. I had to update Intelgraphicsfixup and intelgraphicsDVMTfixup to get mine to boot normally. the security update also borked the wifi driver but I followed the directions that come with the driver with the exception of deleting the old corecapture and the corecapturesponder kexts in S/L/E and the I080211Family kext in the kexts\10.12 folder. I rebooted and everything is back to normal. 

Share this post


Link to post
Share on other sites

×