Jump to content
Rhyker2U

Copy/paste whitespace issue in High Sierra

Recommended Posts

Cannot recall I had this problem with prior versions of MacOS. Whenever I copy/paste text from one MacOS app to the other, everything gets preceded by a whitespace. Terribly annoying when coding something.

 

Clarification (in steps):

1) select / highlight text double click a word

2) cmd c

3) cmd v

 

gets preceded with whitespace :(  exempt: and here in the forum it doesn't happen :) but often does in other sites in Chrome. And it ain't a Chrome problem either, as in Dreamweaver I have the same thing happening. Doing the same on Windows 10? No problem whatsoever. So it must be a MacOS problem?

 

Thus how/where can I turn this preceding whitespace off? Couldn't find it in autocorrection, and have yet to find a tool that takes out the whitespace for me. Anyone has a suggestion? Been googling for days already. Every single time I give up, and then ... when coding again; argh! What am I overlooking ?

Edited by Rhyker
clarification / example

Share this post


Link to post
Share on other sites

I used to have issues with copy/paste when patching things like kexts' Info.plist where the regular/default quote character (") was replaced by an italic version. This would then screw the code of the plist file. I was due to Smart quotes or Smart dashes being enabled (by default) in apps such as TextEdit for instance.

Smart_options.png

 

There's another option called Smart copy/paste. Maybe this is the sort of things you ought to look into.

 

These can normally be disabled through the Keyboard PrefPane.

Keyboard_PrefPane.png

 

You may also check your coding app/editor substitutions settings (if available):

Substitutions.png

  • Like 1

Share this post


Link to post
Share on other sites

Thanks, already disabled all that indeed. Cannot find such things for whitespaces though. :(

Even disabled ALL spelling control temporary in all apps I use and ... no change. Unless ...

 

*edit* Ahaaa! Based on the 3rd screenshot in prior post, I found & disabled "view" -> "code view options" -> "Auto indent" (and some other things too) in DreamWeaver CC 2015. Progress! That leaves me with ... Chrome, but reproduced the issue in Safari too. *sigh*

 

*edit2* ah correction to my 1st post. It doesn't happen when selecting text; then it works! it only happens when double clicking a word. There seems to be a difference on an OS level how the last character is interpreted. Where its being assumed to replace \n by a whitespace of sorts. Sources:

no difference btw between copy/paste and 'smart' copy/paste (shift CMD v). Neither holding 1 or combination of keys when copying.

 

Therefore, currently digging into clipboard managers. 

Edited by Rhyker
dreamweaver solved

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×