Jump to content

I restored windows 10 NTFS partition disk image but not able to boot UEFI - Help


Recommended Posts

I was duel booting Windows 10 and High Sierra on E6540 just fine but sometimes I like to experiment and this time it fired back on me :). Keep in mind that I was actually able to do the same thing in the past with Windows 7 but I am not sure what I am doing wrong here.


I created a disk image of the Windows partition only I don't think I need any of the other partitions that windows create upon installation. I used to be able to boot Windows 7 partition using UEFI just with the windows partition, all other partitions were deleted.


The problem:

I restored the windows 10 image just fine to a second partition but when I modify the bios UEFI boot sequence to point to either

\EFI\Microsoft\boot\bootmgfw.efi ---> Error code:0xc000000e


\Windows\Boot\EFI\bootmgfw.efi ---> Invalid partition table


I also imaged the recovery 500MB partition just in case and restored it but I don't believe I need it to boot windows. I just like to know if its possible or not and if I am missing something.


Thank you.

Link to comment
Share on other sites

I will after tonight after work in about 8 hours but I suspect it won't work like that because if the windows installer repair section doesn't detect correctly created partitions it will just spit out an error. I think I know this from past experience but I will try it again anyway and report back.


In the mean time if there other suggestions would be good.

Link to comment
Share on other sites

I tried a few things yesterday specifically steps from this




When I type:-


bcdboot c:\Windows /l en-us /s <boot letter>: All


I get the following error:-


bcdboot Failure when attempting to copy boot files


Any ideas please?

Link to comment
Share on other sites

Thanks for response.


I initially created the disk partitions when I first formatted the disk as GPT under Mac OSx so the EFI 200 MB partition was HFS however I did format it as you suggest it as FAT 32 hoping it would work but it didn't.


I converted it like this:-


diskutil list

diskutil unmount /dev/disk0s1

newfs_msdos -F 32 -v EFI/dev/disk0s1

diskutil mount /dev/disk0s1


I have 3 partitions


1- EFI

2- OSX

3- Windows 


This is what I did:-


sel disk 0

sel par 3

assign letter=k:


bcdboot f:\windows /l en-us /s k:all


Failure when attempting to copy boot files


f: is the letter of the USB which contains Windows 10 Installation


Even though I've been unable to successfully copy the boot files, I still have the old boot files but I think I am a bit confused about the UEFI boot configuration in the bios, I tried to set it to point \EFI\Microsoft\bootmgfw.efi and select each of the different partitions so I created a number of different boot options to try but not working. one of them seems like it can boot but ends up saying:-


Invalid partition table.


I am able to boot into 10.13.3 using Clover just fine.


Link to comment
Share on other sites

  • Administrators

when you installed windows did you install as MBR or EFI I had issues with trying to convert an MBR install to UEFI boot. maybe you have to start the whole thing again so it generates new files as maybe the boot sector offsets are a bit off on alignment.


you can try on a test disk maybe first if you have one available. partition the disk in osx as guid partition map then with 2 partitions in hfs that should generate a proper fat efi because the issue may lay there. (osx will create a hybrid mbr if you do one partition hfs and another as fat. osx does this for bootcamp to function with older versions of windows) then boot your windows installer by selecting it from your bios boot selection menu. make sure it says it is uefi then I guess install the windows to the second partition by deleting it from advanced setup menu and installing windows to the new free space hopefully that generates the new Microsoft efi option for you. you can then either continue to clone your osx back and reinstall clover to your efi or try coping the new Microsoft efi folder to the disk you are having issues booting to.


here is another option that might work too https://www.intel.com/content/www/us/en/support/articles/000024558/memory-and-storage/intel-optane-memory.html


second option could be to use linux to double check your disk parameters with like disk utility or g-parted. making sure the partitions are defined and aligned properly.

Link to comment
Share on other sites

I never created an MBR installation it was always UEFI based on a GPT partition. I am still trying to get this fixed and will keep reporting here as I get to the bottom of this.


I reformatted the drive as GPT

created new mac os x partition,

Installed a fresh Windows copy after mac os x

This created an MSR partition and was able to boot from windows and mac again but not using my windows image which I need to boot from.

I restored the windows image again using Carbon Copy Cloner overwriting the existing working windows partition but leaving the MSR partition as it is

it won't boot again. (I am still trying to fix this)


This is another problem I would like to resolve

I have Tuxera NTFS installed but when I try to restore the windows image using Diskutility on 10.13.3 it gives me an error saying :-

Source image volume size is not an exact multiple of 1MiB.

Even when I made sure the partition I am restoring the image to is larger than the original image size.


Any ideas on this problem please?


Thank you.


Link to comment
Share on other sites

  • Administrators

this did not help? https://www.intel.com/content/www/us/en/support/articles/000024558/memory-and-storage/intel-optane-memory.html also I guess somehow your disk might still be out of alignment some how that might be that 1mb offset issue.

maybe this can help out https://www.partitionwizard.com/help/align-partition.html

Link to comment
Share on other sites


  • Create New...