Jump to content
liberobk

E7450 - Can't install High Sierra 10.13.3

Recommended Posts

Boot to Clover GUI, hit F4. Then compress and attach /EFI/Clover/ACPI/Origin here for patching.

What version of BIOS are you on?

Share this post


Link to post
Share on other sites

Hi Jake

 

In attach you can find the dump requested, currently my BIOS is the latest, the A19 version.

PS:before you ask me,  i've dropped the table MSDM.aml because contain windows license. ;)

 

Many thanks in advance

ACPI_Origin_E7450_A19.zip

Share this post


Link to post
Share on other sites

Hi Jake, exactly same error with your pack.

If I boot with slide=0 i can reach installer, the installation start but at the middle of setup the installer exit and restart the computer.

 

What can i try?

 

 

Share this post


Link to post
Share on other sites

That's perfectly fine. Reboot to installer and select the Install drive again to continue with installation, might have to do this 2 or 3 times.

Share this post


Link to post
Share on other sites

Ok Jake, i had understood the trick, reboots are required to complete installation process like in the Sierra wizard, now system is working but i've found some things that left me in doubt:

  1. Graphics: with Elcapitan when I use the docking station i can use all my 3 monitors (LVDS, VGA on docking, mDP onboard) but with HS i can use only LVDS and mDP. another strange things in graphics is about management of brightness where brightness slider can't match the with current backlight level (sometimes happen that system freeze 2 or 3 seconds when brightness changes)
  2.  Trackpad: with ElCapitan the middle button of trackpoint permits to use the scrolling feature of that device. It's possible the Smartscroll is the only solution to enable this feature in HS?(some parameter in the ApplePS2Controller...)
  3. WAN: on have you even test the WWAN module on HS?

Thank in advance

Share this post


Link to post
Share on other sites

1) Support for VGA probably has been dropped in HS

2) You could give this version (Alps) a try, remove or backup ApplePS2Controller (generic mouse movement only - no option for trackstick scrolling)

3) WWAN...sorry, don't have the hardware to test

Share this post


Link to post
Share on other sites

For WWAN, head over to WWAN forum section where you can open a dedicated thread if needed. Of course, you'll have to indicate the model and specs of the device because "the WWAN module" just won't do...

Share this post


Link to post
Share on other sites

Followed the jake's guide (Thanks Jake) for installing High Sierra 10.13.4 from scratch on Dell E7450. USB boot stops at panic with last lines mentioning about !aapic and last line with 'Please go to https://panic.apple.com .......' 

Copying the .aml files to CLOVER/ACPI/patched solved it. Just before the installation gui screen appears, the laptop screen goes dark/blank just after flashing the apple logo and loading bar. The trick to see the installation screen was connect an external monitor at this stage via hdmi. Then just continue the setup selecting language, etc. While rebooting laptop should not connect to external monitor. Once laptop screen goes blank then connect external monitor via hdmi.

After few reboots during setup, use clover to make the internal ssd bootable and then copy the usb EFI partition EFI folder to internal ssd EFI partition. Reboot without external monitor and High Sierra will be booted in to laptop screen.

[Use 'diskutil list' and 'diskutil mount disk0s1' (use your own disk number) to get the hidden EFI partition visible. This way no need EFI mounter.  ]

Share this post


Link to post
Share on other sites

×
×
  • Create New...