Jump to content
Sepster

[Solved] Fully working - Optiplex 3046 High Sierra "Waiting on boot-uuid-media"

Recommended Posts

Ok, add Lilu.kext & AppleALC.kext to /EFI/Clover/kexts/Other

I see you already have layout-id 13 in your Config file, so try with that. 

You could also try 3, 17,18 and 28 to see which works best

Share this post


Link to post
Share on other sites

Thanks, audio with above works, also added in config

                <dict>
                    <key>Comment</key>
                    <string>change _DSM to XDSM</string>
                    <key>Find</key>
                    <data>X0RTTQ==</data>
                    <key>Replace</key>
                    <data>WERTTQ==</data>
                </dict>

this machine uses H110 chipset so created ssdt-lpc (using MaciASL)

DefinitionBlock ("", "SSDT", 1, " ", "SSDT-LPC", 0x00003000)
{
    Method (_SB.PCI0.LPCB._DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
    {
        If (LEqual (Arg2, Zero))
        {
            Return (Buffer (One)
            {
                 0x03                                        
            })
        }

        Return (Package (0x02)
        {
            "compatible",
            "pci8086,9cc1"
        })
    }
}

, so AlppleLPC loads,

kextstat|grep -y acpiplat
kextstat|grep -y appleintelcpu
kextstat|grep -y applelpc

Adjusted USBs using [Guide] Creating a Custom SSDT for USBInjectAll.kext

 

All works as good as one could expect

Share this post


Link to post
Share on other sites

Awesome...perhaps update the 1st post with your files or write a guide to share your experience.

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×