Jump to content

Recommend a Metal compatible GPU for Dell Precision T3500?


dm4n
 Share

Recommended Posts

Hi All,

 

Can anyone recommend a Metal GPU for the Dell T3500 that would make it possible to install OS X Mojave?

 

Currently rocking an ATI Radeon HD5670.

 

Perhaps relevant is that T3400 owners have reported an issue where the newer AMD cards don't support the low-resolution Dell BIOS screen during boot, giving a 'Vesa 103' error.

 

Thanks for any assistance!

Link to comment
Share on other sites

I'm using a GeForce GTX650Ti in my T1650... full metal support is given on Mojave... Any GeFore 600 Series card (Kepler chipset) will work. Some of the GeForce 700 Series cards are also using a Kepler chipset and will work.

You can use Google/Wikipedia to look for a suitable card, any Kepler based card will work. Codename GKxxx.

Or, look at the official Apple Graphics Support Document ... --> https://support.apple.com/en-us/HT208898

Bildschirmfoto 2019-01-07 um 13.41.25.png

Link to comment
Share on other sites

  • Administrators

Yup, cheap Kepler cards (chipset GKxxx) like nVidia GT710, GT720 or GT730 will do perfectly and work OOB. Make sure you do not go for Fermi-based models of the 600/700 Series.

 

You may look here or here too. And of course, it'll all depend on the budget you're ready to spend.

 

  • Like 1
Link to comment
Share on other sites

  • Administrators

I tried a Asus GT640 on a Precision 9710 and it said metal supported so i lucked out on a GK model 640. only issue I had was that I believe the 9710 needs an UEFI flashed rom video card as I had no graphics at all until it was in OS. the factory NVS 310 gave me GUI interface because of UEFI bios but it is not metal supported.

Link to comment
Share on other sites

4 hours ago, Bronxteck said:

I tried a Asus GT640 on a Precision 9710 and it said metal supported. only issue I had was that I believe the 9710 needs an UEFI flashed rom video card as I had no graphics at all until it was in OS. the factory NVS 310 gave me GUI interface because of UEFI bios but it is not metal supported.

 

You need to enable "legacy boot roms" in the BIOS. This enables the UEFI-CSM. You'll have graphics output throughout the whole boot process.

 

My GTX650Ti has also no UEFI bios. ;)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...