Jump to content
ssprod

HP 8470P w/AMD Radeon GPU

Recommended Posts

Greetings..

HP 8470P 

i5 3360 CPU

Radeon HD 7650M GPU

I've managed to get almost everything running well with the exception of WIFI. Purchased a Broadcom 43224 card, as I've used this with another 8470P w/iNtel GPU.. however it's not working in this system. Any thoughts would be much appreciated. Thanks. 

OSX Latitude-ssprod8470P.zip

Share this post


Link to post
Share on other sites

Try patching DSDT with this

credits: Pokenguyen

Quote

into method label _DSM parent_label WNIC remove_entry;
into method label _DSM parent_label ARPT remove_entry;
into all label WNIC set_label begin ARPT end;
into device label ARPT insert
begin
Method (_DSM, 4, NotSerialized)\n
{\n
    If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) }\n
    Return (Package()\n
    {\n
        "AAPL,slot-name", "AirPort",\n
        "built-in", Buffer () {0x00},\n
        "device_type", "AirPort",\n
        "model", "Broadcom BCM4322x 802.11 a/b/g/n Wireless Network Controller",\n
        "name", "AirPort Extreme",\n
        "compatible","pci14e4,43a0"\n
    })\n
}\n
end;


 

Share this post


Link to post
Share on other sites

Thanks Jake, still no positive results. Incidentally, the intel wifi card that I replaced had 3 leads connected to it 1-3. I'm presently connecting 1+2 to the Broadcom card. 

Share this post


Link to post
Share on other sites

Hmm Broadcom 43224 is just DW1520. You just need FakePCIID.kext + FakePCIID_Broadcom_WiFi.kext

If stil not working, then add Lilu.kext + AirportBrcmFixup.kext

All can go in /EFI/Clover/kexts/Other

Share this post


Link to post
Share on other sites

Thanks again. I've re-installed High Sierra and still no change. The card is recognized in DPCI, but not showing up in OSX at all. These are my kexts currently in EFI/Clover/kexts/Other. 

Update: I reversed the leads on the wifi card, and it's working now with these kexts.  I'd be glad to post my EFI, however I seem to be limited to under 2megs for upload. Thanks Jake ! 

8470P-Radeon GPU.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×