Jump to content
Rafael Siqueira

[SOLVED] Dell 5480 - macOS Mojave (latest build)

Recommended Posts

Mojave requires a new way to patch FB, old patches from High Sierra and below won't work.

See here for more info

https://www.insanelymac.com/forum/topic/334899-intel-framebuffer-patching-using-whatevergreen/

 

There's no support to I2C touchpad currently in Mojave, that being said, here's beta version you could try.

Replace them into /EFI/Clover/kexts/Other

If it doesn't work, don't ask for support, you won't get it from the developer. Will have to wait until Mojave is out at least.

I2C_MojaveBeta.zip

Share this post


Link to post
Share on other sites

Hey, @Jake Lo! Thanks!

The trackpad is now working!!

 

For the display ports I have not tested yet. I'll give a try next weekend.

 

Do you have those patches already in a config.plist? I'm newbie customising this things.

 

Cheers.,

Rafael Siqueira 

Share this post


Link to post
Share on other sites

Hi @Jake Lo and @viking1304 !
 

I've successfully updated to the "released" version of Mojave, no changes in config.plist. I only had to update the IC2 kexts in order to make the trackpad work properly.

 

I'm still facing problems with the display ports. The HDMI and VGA ports don't work and the system freezes when you plug it in.

 

Find attached my EFI folder with "origin" populated as well as the debug files generated.

 

Cheers,

Rafael Siqueira

debug_27397.zip

EFI.zip

Share this post


Link to post
Share on other sites
4 hours ago, Rafael Siqueira said:

Superman! All working!

 

Thanks a lot.

 

Cheers,

Rafael Siqueira

Can you help me to tell me what is working on your system with Mojave and what's not working. I have i7-u6600 5480 and i want to try Mojave but frist i need to know some things. And maybe can you tell me where can i find a proper installation guide. Thank you very much for the answears. 

Share this post


Link to post
Share on other sites

Hi @utomi

 

Only the native wifi is not working due to its incompatibility with OSX. I'm using an external wifi dongle.


Everything else is working properly:
- Audio

- Bluetooth

- Ethernet

- Keyboard/Trackpad

- All USB ports
- USB-C port

- HDMI/VGA ports

You can use my EFI files shared in the above messages with the config file shared by JakeLo. Following the answers in this thread should help you get it working.

Let me know if you need any additional help.

Cheers,

Rafael Siqueira

Share this post


Link to post
Share on other sites

Hi @Jake Lo!

 

I'm already using the latest (2.1.4). Find the screenshot attached.

 

1501572669_ScreenShot2018-10-15at16_07_32.png.df09aa58fdaa5c2e994d236af6eb9c3e.png

 

I was using the beta version (2.0.3) before Mojave's final release. For the Mojave released version, the I2C beta didn't work.

 

Cheers!

Rafael Siqueira

Share this post


Link to post
Share on other sites

Ok, debug attachment above has version 2.0.3, so I assumed.

Could you try FBPatcher.app as well?

There's an option to create your own USBPort.kext so you could remove USBInjectAll + port limit patch.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×