Jump to content
Hattori

[SOLVED] Latitude 5480, Mojave 10.14

Recommended Posts

At Clover gui, press O to get to Options.

Go down to Graphics Injector and select it

Select FakeID or platform-id and change it to 0x12345678

Once kextcache is build you can boot normally

  • Like 1

Share this post


Link to post
Share on other sites

I used an EFI from this thread.

i can start direct from my ssd without usbkey.

 

bluetooth and wifi not working.

how can I fix that ?

 

I don't check yet ethernet, hdmi, etc...

sound and pad seems to work well.

 

 

thanks'

ioreg-export.ioreg

Share this post


Link to post
Share on other sites

what Wifi device does it have?

Intel is not supported and will need to be replaced.

See here

 

You IOReg file indeed shows it has an Intel wifi, replace it with my recommendation - DW1560 or DW1830

  • Like 1

Share this post


Link to post
Share on other sites

thank you @Jake Lo
how can I replace it ?

I followed the clover guide to setup my hackbook.

I didn't find the way to finish configuring all devices. Do you have another tutorial please ?

Thanks'

Share this post


Link to post
Share on other sites

How to replace it???

Well, you have to purchase a compatible card like DW1560 or DW1830.

Then you take the bottom cover out, remove the Intel card and put the new card in.

Then install necessary kexts like:

FakePCIID_Broadcom_WiFi.kext + FakePCIID.kext + AirportBrcmFixup.kext + Lilu.kext for Wifi

BrcmPatchRAM2.kext + BrcmFirmwareRepo.kext for Bluetooth

 

or you could purchase a compatible USB device, but I prefer internal device.

USB might prevent system sleep

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×