Jump to content
RamiTrainFan

Does Facetime or iMessage Work?

Recommended Posts

37 minutes ago, viking1304 said:

It is not important if you account have credit card attached or not, or if you made any purchase on AppStore. I tried two credit cards and bought cheap iPhone app, but that didn't help. Old account from my friend worked without added credit card worked.

Yup, it is true. I used Apple Gift card to buy lot of 99 cent apps very time ago. I don't have credit card when I was teenager. I logged my account on iMessage without issue.

Share this post


Link to post
Share on other sites

Just for the reference, when your account was created? I am trying to figure out how old account should be in order not to trigger "call support".

Share this post


Link to post
Share on other sites

Guys, I managed to get it working for me.

 

The key was i had skipped some clover settings (even though my Lan/Wifi are en0 and en1)

 

Basically, the only changes i made was a set the correct MLB and mac details inside clover and told clover to inject the system keys.

 

now iMessage works like perfectly.

 

make sure all is filled in properly.

 

i used the board serial number copied from the SMBIOS SCREEN.1698780437_Screenshot2018-10-27at18_24_18.thumb.png.e804a9713228b677c85cc69b12e2e091.png

Screenshot 2018-10-27 at 18.25.44.png

Share this post


Link to post
Share on other sites

Great. Can you please tell me when your account was created if you remember? Was it before 2017?

 

You do not need to enter MLB, valid Board Serial Number is enough. It will be automatically copied there. For ROM value you can use UseMacAdd0, but generate button should work too. Any real MAC address should also work. You can skip Custom UUID, but you should have Inject System ID checked.

 

You should also check your serial number. It should report error on Apple's support coverage check page. If you get a proper response, that means that you are using serial that exists on some real Mac. Please try to avoid that.


 

Share this post


Link to post
Share on other sites

well the story is i have not been able to get imessage to work on this hack for ages, and my serial number was initially invalid, but since i spoke to apple support and they remote logged into my system, now my serial number appears on the serial number checker, but asks me to tell them when i purchased it. weird huh?

 

my imessage account is very new. (2018)

Share this post


Link to post
Share on other sites

What was your issue with iMessage?

  1. "An error occurred during authentication." message
  2. "Your Apple ID "name@domain.com" can't be used to set up iMessage at this time." message
  3. "You cannot sign in to iMessage on this Mac at this time." message
  4. Something else

Some people reported that they accounts start working after contacting support. Some others says that it didn't help, even support told them that they fixed an issue.

 

Situation with your serial is actually expected in my opinion. They probably added your serial to their DB. Since purchase info is not available, it is expected to get a message like that.

 

 

Share this post


Link to post
Share on other sites

well sorry for the late reply.

 

well, I updated to mojave14.1

 

I message stopped working now and I cannot get it working again even with same serial uuid's inject ect.

 

perhaps something in 14.1 broke it?

 

no idea...

Share this post


Link to post
Share on other sites

As you can see iMessage fully works with 14.1 on Dell. When I say "fully works" I mean that you can sign-in, stay signed-in, send and receive messages. Everything else I consider as not working.

 

Sad fact is that some Apple ID's can be used on any machine and it's not important if that machine is a real mac or a hack. Unfortunately some accounts can only work or genuine Apple hardware. So, even if you did everything right there is a chance that your account will not work. Worst thing is that some other account might work on your system without any problem, but that one might not be yours.

 

Are you sure that your iMessage was fully working before? Have you send and received messages without any problem or your iMessage just looked like you were singed in? In few of my tests I have seen that iMessage looks like it is connected, but I was not able to send or receive any messages. Little later I got message to call support.

 

Have you tried to use iMessage with different MLB or ROM at same laptop after you used it with some other? If you did, that might trigger your problem, even if your iMessage was fully working.

 

Can you please tell me what message you are getting (please check my previous messages to you)?  

 

image.thumb.png.b12bdf015960de31e65eaf789429f03f.png

Share this post


Link to post
Share on other sites

Few days ago i reinstalled everything from scratch and I decided to try to make new config with completely new set of serials. For almost a year I used cloned values from real unused Mac. Finally I am able to use iMessage with generated values. Everything works perfectly.

 

Do not try to use your account with too many different serials in short period of time in desperate need to make iMessage work. This will probably just make things worse.

It's better to change all your serials than just one or two values. This way it will look like a completely new machine.

If it doesn't work, do not try again for at least 2-3 days. Then try with new serials. This is to avoid possible flagging of your account as "problematic" one.

 

If you want serials that are close to real ones and that will probably work, you can take this approach.

 

Select your model, and click on both Generate New buttons few times. Check Trust.

 

image.thumb.png.04e0fd034ef51192e33af22006afbcd4.png

 

Check you new serial with macserial app.

dragon:Downloads viking$ ./macserial -i C02Q90RFH1DP
       Country:  C02 - China (Quanta Computer)
          Year:    Q - 2015
          Week:    9 - 35 (27.08.2015-02.09.2015)
          Line:  0RF - 865 (copy 1)
         Model: H1DP - MacBookPro12,1
         Valid: Possibly

Lookup your model on EveryMac. Find into and disc dates (March 9, 2015 and June 5, 2017 in this case). Date decoded from your serial must be between those. Looks good.

 

Check if your serial is used by real mac here. You need to get an error here! We’re sorry, but this serial number isn’t valid. Please check your information and try again. If you get anything else, do not use that serial. Generate new set of serials instead.

 

Generate new ROM value, but do not use generate button from Clover. It might work, but it's totally wrong. On every real Mac that I checked ROM value is in MAC address format, that start with OUI (vendor) info that always belongs to Apple, but it doesn't match any real networking device. Also, it is not related to SmUUID. For some strange reason Clover takes last 6 numbers of SmUUID and add them to 6 randomly generated numbers. Proper way would be to use any Apple OUI and to add 6 random numbers at the end.

 

Take any of those, for example 4098AD and add 6 random valid HEX numbers (0-9 and A-F). You might use first 6 that Clover generated, for example 8A9C14. In this case new ROM value would be 4098AD8A9C15

 

image.thumb.png.d612c2b0be446c27a13cdd2afc9d5482.png

 

Do not generate Custom UUID, just select Inject System ID.

 

image.thumb.png.c46a5586d959443320ab6f87496688af.png

 

For installation I used same config that I am using now (with same model and serials).

 

People usually install OS with one set of serials and then use another later. Sometimes even with different model. I did this earlier. If you are doing this, do not log to iCloud nor try to use iMessage nor Facetime before changing serials to final ones.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×