Jump to content
Dan_Marshall

Lenovo Thinkpad T470s

Recommended Posts

Hi Jake (again)

 

Many thanks for your assistance on the Dell Latitude.

 

Hoping to get your assistance again on this machine - Lenovo T470S.

 

System is installed and fully operation however there are a few issues

 

Attached Debug files for review. Any ideas?

 

Dan

debug_11431.zip

Share this post


Link to post
Share on other sites

Hi Jake,

 

Thanks for replying - apologies for the vague description in original post.

 

Main issues are:

 

Slow boot time and can only successfully boot in verbose

 

Trackpad works using rehabmans voodooPS2 kext however is jumping - curser jumps erratically during use.

 

No battery indicator unless power plugged in. In energy saver sys prefs the show battery indicator button does not work (stay on) and battery charge shows 0%. When power is plugged in only shows 7% charge and looks like it is not charging (but is). This particular model of the Thinkpad has 2 batteries installed. 

 

Brightness buttons also not working

 

I installed High Sierra (10.13.6) quite easily on the machine using files and kexts from this guide: https://www.insanelymac.com/forum/topic/315451-guide-lenovo-t460-macos-with-clover/ 

There is a user there with the t470p model which is very similar however I did use custom kexts particular to this model (wifi card etc) and edited the config.plist best I can but do feel custom edits are required on the DSDT / SSDT to fine tune the system correctly (beyond my skillset unfortunately :) ) The DSDT and SSDT files in the debug files are original from my machine dumped from clover.

 

Thanks again Jake

Share this post


Link to post
Share on other sites

Hi Jake - the t470 files in the repo are the ones that were used for mine. But still the issues as described above.

 

ill take another look and see what I can find my end

Share this post


Link to post
Share on other sites

Hi Jake - tried a few of the files from the repo but ended up braking my system :) 

 

Got it back to original state from the install USB and clover folder from the debug files from a few posts back. Definitely believe it isrelated to a fine tune on the DSDT however its beyond my capabilities at this stage. If you could offer any advice or point me in the right direction I would be grateful

 

Thanks in advance

Dan

Share this post


Link to post
Share on other sites

I'm having issue with my T470, it has the Samsung NVMe PM981 which I believe is not supported. I'll need to get a replacement drive before trying again.

I'll update this post with any success hopefully soon.

  • Like 1

Share this post


Link to post
Share on other sites

`no worries Jake - As reference the model in my T470s is a: SAMSUNG MZVLW512HMJP-000L7 and original to the laptop. 

 

Thanks again pal - be happy to offer donation for this and all your guys efforts to this community if you let me know where to :)

Share this post


Link to post
Share on other sites

Hi Jake,

 

A little further progress on the t470s. Have attached debug files for review.

 

Mojave 10.14.2 however still issues on trackpad (jumpy and battery status shows 0%). Apart from that everything seems good.

 

Happy new year to you

 

Dan

 

 

debug_6724.zip

Share this post


Link to post
Share on other sites

Hi Jake,

 

Got quite bit further on the t470s - System is now fully functional, battery status, wifi, trackpad. System works solid.

 

Got some tips from the Max 1974 thread and a few other members of the community that you helped out - 

 

Only real issue I'm having would be battery life - battery drains really quickly from a full charge - approx 1 hour. Is there any tricks to get this better? I installed the intel power gadget and could not see any resources hog that would indicate as such. Hoping you could take a look at my debug files and offer any assistance (again) if you could.

 

Many thanks in advance

Dan

 

 

debug_30561.zip

 

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...