Jump to content
geekmac

[SOLVED] E7440 Intel HD 4600 and no audio detected

Recommended Posts

Appreciate if  any SME  can point me in the right direction:

 

Have an e7440 ; has everything running Mojave and Clover

 

Screen is bright with no brightness control in the "display" of system preferences

No audio detected 

 

Here is what I see on system info

 

===

Intel HD Graphics 4600:

 

  Chipset Model: Intel HD Graphics 4600

  Type: GPU

  Bus: Built-In

  VRAM (Total): 4 MB

  VRAM (Dynamic, Max):

  Vendor: Intel

  Device ID: 0x0a16

  Revision ID: 0x000b

  Kernel Extension Info: No Kext Loaded

  Displays:

Display:

  Resolution: 1366 x 768 (WSGA - Wide eXtended Graphics Array)

  UI Looks like: 1366 x 768

  Framebuffer Depth: 24-Bit Color (ARGB8888)

  Main Display: Yes

  Mirror: Off

  Online: Yes

  Automatically Adjust Brightness: No

====

 

Every thing else is working. 

 

Many thanks in advance.

Share this post


Link to post
Share on other sites

your Config file is corrupted, looks like you added a section incorrectly or using an unsupported text editor.

Replace it or restore the original

 

Hmm, looks like your bootpack is from a Broadwell system, you need the bootpack for E7440. Check out my E7440 guide and bootpack

Share this post


Link to post
Share on other sites

Just replaced the config.plist,  ACPI and kexts folders in the existing EFI from your EFI_7440Mojave.zip 

Works like a charm. Thanks again Jack.

 

If I may ask one last followup, boot up seems longer (may be there are some timeouts for which boot sequence is waiting, not sure), any way to troubleshoot the longer boot sequence? I can definitely live with 2 min boot time, though :) Good day.

Share this post


Link to post
Share on other sites

Many thanks, but I figured out that duplicate kexts in /L/E are the culprits. I took a backup and removed most of the kexts except the two in your EFI (copy to /L/E). Now it is super fast boot within 20 secs :) Good day.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×