Jump to content
MrJonesIII

Mojave on Dell Latitude E6530 - need help with bootpack, etc

Recommended Posts

Hi there, 

 

Used Jake Lo's guide from here - https://osxlatitude.com/forums/topic/8506-dell-latitude-inspiron-precision-vostro-xps-clover-guide/?tab=comments#comment-87342 

to create my bootloader, but can't seem to wade through the volumes of information out there to find my way to a bootloader, config.plist or list of kexts to get this thing to go. 

 

I stumbled across someone asking for a bootloader for a E6230 and Jake referred him to one that he did for someone else back in October 2018, and I tried that and got a lot further than ever before, but unfortunately after a few pages of console post logs on the screen, the screen goes black.

 

I tried connecting a HDMI screen to the port but there was nothing there. Also tried connecting a display to the SVGA port and again, nothing. Although, pressing the keys at random caused the automatic accessibility assistant to start talking me through what was on the screen, so I'm thinking that it booted far enough to get to the OS X install page, but just couldn't drive my Intel or nVidia display cards or display. 

 

I tried changing the graphics injection setting from the Intel to the nVidia and get the same result, including the Accessibility Assistant talking to me, so I know it's getting as far as the OS X install window, but the screen is still black. 

 

Hardware configuration can be viewed here - http://linux-hardware.org/?probe=906439ca69 

 

I have recorded video of the screen so that you can see if there are any logs that might help that pop up while it's doing its thing. I'll post a link to that when it's finished transcoding. 

 

Thanks in advance for all and any help, suggestions, comments, anything! 

 

Regards, 

 

MrJJ 

Share this post


Link to post
Share on other sites

I should also perhaps mention that the HDMI port is pretty important to me. I need to run two displays if I can. I have the dock with the dual DVI ports and was thinking of using that to get my dual displays if possible, otherwise, I could get away with using the laptop screen and the HDMI port. I'm guessing that this means I have to try and get the nVidia thing working. I've read that it drains the battery and stops sleep. Neither of these things worry me in the slightest. This laptop is always going to be plugged in to AC power and I don't need it to sleep. 

Share this post


Link to post
Share on other sites

It's long been stated that the Nvidia NVS5200M is not supported. It's a Fermi card and Mojave only supports nVidia Kepler GPUs. The NVS5200M was no longer supported in High Sierra. That kisses goodbye to HDMI output...

 

Please read the existing threads re: E6530 and Mojave/High Sierra/Sierra.

Share this post


Link to post
Share on other sites

Thanks, Hervé. I'm sorry I didn't find any posts that said that in my searches and wasn't quite sure how much of the stuff from the Sierra and High Sierra builds were applicable to Mojave, but I do know now. I'll see if I can swap this laptop for one with a Kepler based nVidia card instead. You've saved me hours of aimless hunting with that one post, so I really appreciate your help. 

Share this post


Link to post
Share on other sites

I hope I am writing to the good place, if no, sorry about it.

 

I have successfully installed Mojave on my e6530, but as on my e6330 when I plug a HDD into my optibay, it doesn't recognize it, about 2-3minutes the system says the drive cannot be used, then it appears on disk utility, and even if I choose to format, it can't do that.

 

But when I swap the HDD to a SSD, it works perfectly.

 

Share this post


Link to post
Share on other sites

Mr Herveé, 

 

I've been trying to find out as much as I can about this, and have successfully installed Mojave onto this computer. It's working perfectly, but there is no video output from the HDMI or DVI/DP ports on the docking station. 

 

Desperate for a miracle solution, I came across these posts that talk about the HD4000 on the Dell E6xxx platform having multiple output options that are assignable by editing a kext file called AppleIntelFramebufferCapri.kext 

 

These are the posts I'm referring to - 

https://osxlatitude.com/forums/topic/2945-guide-for-enabling-vga-dvi-dp-and-hdmi-in-intel-hd4000-gpu/

https://osxlatitude.com/forums/topic/9623-e6430s-2-external-monitors-output-with-pr03x/

 

Now, I used this guide to install Clover onto the Mojave installation USB stick - 

https://osxlatitude.com/forums/topic/8506-dell-latitude-inspiron-precision-vostro-xps-clover-guide/?tab=comments#comment-87342

 

Inserting the ACPI and Kext folders (replacing the existing ones) from Jake Lo's post here - 

https://osxlatitude.com/applications/core/interface/file/attachment.php?id=20830

 

I edited the config.plist file to create a unique and non-recognised serial number. I ran all the post-install instructions and all seems to be AOK. It's auto-booting into the OS from restart, it's turning off the display, BlueTooth is working, and I have a USB RealTek Wifi dongle that's also working fine. 

 

What I'd like to have confirmed is my suspicions that the posts referring to the modification of the AppleIntelFramebufferCapri.kext do not apply to this laptop with Mojave. Is this true or do I have a chance here to get that HDMI port being driven as a second display from the Intel HD4000 GPU, or does that HDMI port only work with the nVidia GPU? 

 

Thanks in advance. 

 

MJJ

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×