Jump to content
Owen Delaney

Trouble getting DW1820A to work

Recommended Posts

Your latest EFI folder looks better but:

  • ssdt-2.aml is still present
  • get rid of that ToledaARPT kext which is obsolete and unecessary
  • you've not injected any of the DW1820A properties in Clover config

 

You have the 08PKF4 model, no assurance that it'll work Ok but since you have it inserted, do try and set it up correctly before considering exchanging it with something else.

Share this post


Link to post
Share on other sites

Ok, since I was reading the wifi card support list and this wifi card is also supported with yosemite and el capitan, will wifi work in one of those versions of os x with yosemite io802.11.kext or not? If this also doesn't work, I will think about buying a new wifi card for this project.

Share this post


Link to post
Share on other sites

So I have an update to give: I redid my macOS Mojave usb and did a fresh install with a completely new clover setup and out of the blue, WIFI WORKS! I am happy but my dell latitude e5570 with an i5 6200u is running quite slow. I think that I read on this forum that this wifi card makes a laptop slower? I am making this up or is it true? Anyways, can't wait to figure out why it's running slower than usual!

Share this post


Link to post
Share on other sites

Yes, it work for 5 to 10 minutes as Jake Lo said and then it randomly stops working. I really want to give up but don't want to at the same time? What should I do?

Share this post


Link to post
Share on other sites

In the case of a 08PKF4 model you may try the following as detailed by midi1996 at Voldemort's place and suggested by @sniderjc:

  • Cache or inject AirportBrcmFixUp kext and add boot option brcmfx-driver=1 to force AirPrtBrcm4360 kext to load instead of AirPortBrcm-NIC
  • If required to connect to 5GHz networks, set your country code using boot option brcmfx-country=#a or brcmfx-country=XX (where XX = your locale Country Code; eg: FR for France)

-> To me, this is a simple alternative to the compatibility property injection.

 

After that, if you experience several system performance degradation/severe lagging, install the IO80211Family kexts from Yosemite 10.10.5 to /L/E, renumber them to, say, v999, repair persmissions and rebuild your cache. After that, add the old 5GHz binary patches detailed by Toleda to your Clover config:

kext: AirPortBrcm4360
Find:    4183fcff742c48
Replace: 66c7065553eb2b

Find:    6b100000750d
Replace: 6b1000009090

 

Imo, this is the trick by which midi1996 could only get his card to work and I must say I'm a little skeptic, especially as midi1996 clearly stated that the above results in occasional-to-regular KPs. Not surprising to be honest.

 

Another method consists of totalling removing the AirPortBrcm-NIC Plugin from the IO80211Family and inject PCi id 14e4:43a3 into AirPortBrcm4360 Plugin.

 

This being said, I've nothing further to offer so, if you're stuck in the corner, nothing to lose by trying but time...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...