Jump to content
ratsalad

DW1820A in Mojave not working

Recommended Posts

I have a Dell E5250 and purchased a DW1820A (21 version) and am trying to get it working in Mojave.

I have followed Herve's guide, but then the card goes from being recognized and not working to not being recognized at all.  I am using Jakes 5250 boot pack and everything else on the system seems to be working except the wireless card which will work under Linux,  but not Mojave.

 

Based the instructions provided, I found that my card is located at 1c,3 rather than 2 so I setup the configuration, but rather than helping to get the card working, it is instead no longer recognized by the system.  I have double checked to make sure that everything was configured properly and I don't see any problems.

 

The card is functional and not turned off in the bios, but it currently is not recognized with the modified config file.

The only thing I haven't done is to update the kexts to anything beyond what is provided in the boot pack and what installed by the system or clover. 

Share this post


Link to post
Share on other sites

Raw IOReg file is hard to read. Run this and attach the file

Also in Hervé's guide, you need to leave out FakePCIID.kext + FakePCIID_Broadcom_WiFi.kext

and in the Config file, remove FakeID Wifi 0x0431114E4, it's also in the wrong format. My bad.

Share this post


Link to post
Share on other sites

Removed the  FakePCIID files and removed the Fake ID 0x0431114E4. Anyone see anything else that might be causing a problem?

Share this post


Link to post
Share on other sites

:eek: May be your ought to have a much closer look at the properties you're injecting... <_<

Share this post


Link to post
Share on other sites

Oh.. I see that I was 1 off and now it is working.  :)

Unfortunately, now it just freezes after awhile.

 

 

wireless-card.png

Share this post


Link to post
Share on other sites

×
×
  • Create New...