Jump to content
muttonhead411

DW1820a - the general troubleshooting thread

Recommended Posts

Tried firmware v5974 but couldn't make it connect to my BT mouse even though it detects it Ok.

DW1820A_BT_FW_v5974.jpg

 

Now, I simply cannot connect to it at all when it previously used to work Ok and quite sustainably so as detailed on p5. I think I'll just stop on this DW1820A non-sense.

 

Share this post


Link to post
Share on other sites

Hello there,

 

I bought DW1820A with part number 0VW3T3 (same Mac address in label and in system info).

 

With 2.4 Ghz -> work normal without kext, only add devices properties in Clover.

With 5 Ghz -> can't scan any wifi 5 Ghz (i don't know why)

With bluetooth -> working (Airdrop, Handoff ....)

 

But with 5 Ghz band, how to fixed it ?

Share this post


Link to post
Share on other sites

Should work OOB or experiment with country code parameter as per detailed in the guide. I know of no specific issue with 5GHz networks for this card or of any specific mods on the matter. Just make sure both antennas wires are properly connected. Failing that, your card may just be defective...

 

Share this post


Link to post
Share on other sites

Hello Everyone, I get my dw1820 works great in Mojave but when I connect any device to bluetooth, the wifi connection stop working, don't disconnect just stop access any site... 

below my configurations: 

Screenshot at Oct 13 11-26-09.png

Screenshot at Oct 13 11-26-38.png

Screenshot at Oct 13 11-27-18.png

 

Share this post


Link to post
Share on other sites

Please post compressed copy of your Clover EFI folder + compressed saved output from SysInfo. Never heard or seen Wireless die when BT was in used..

Share this post


Link to post
Share on other sites

@nickhx, hello.
At present, I have a problem: dw1820a can be used normally with your compiled driver, then I would like to know what content is modified by your source code, or can you share your modified source code, if my request is offensive, please ignore me. Thank you! I hope to get your help.

Share this post


Link to post
Share on other sites

Final, i got dw1820A working both WLAN and Bluetooth without kernel panic (10.15)

 

1. I use DW1820A with OVW3T3 (I don't know this way work other DW1820A),

 

Tape pin with guide Naidis 

 

 

2. Remove Pci device + boot-args in clover config

 

<key>PciRoot(0x?)/Pci(0x?,0x0?)/Pci(0x0)</key>
        <dict>
            <key>AAPL,slot-name</key>
            <string>WLAN</string>
            <key>compatible</key>
            <string>pci14e4,4353</string>
            <key>device_type</key>
            <string>Airport Extreme</string>
            <key>model</key>
            <string>Dell DW1820 (BCM4350) 802.11ac wireless</string>
            <key>name</key>
            <string>Airport</string>
        </dict>
    </dict>

 

3. Remove kext BrcmAirportFix

4. Add FakePCIID + FakepciiD_Broadcom_WiFi.kext in C/K/O and L/E

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...