Jump to content
Sign in to follow this  
tluck

Dell Precision M4800 - macOS Mojave

Recommended Posts

Update - switched to use both gfx options - LCD on IGPU and External ports with ATI. 

 

I decided to take another look at using the AMD/ATI M5100 Graphics card on my M4800 since I wanted to use the display external ports.

 

Well I seemed to stumble onto a  solution:

Using Whatevegreen.kext without injection showed me the HMDI port was possible - but the other other LCD and DP ports were not working.

so i injected the Buri framebuffer set and with WEG's help, now the DP and HMDI port worked!

then i tried Ebi framebuffer - and this got the LCD and DP now but not HDMI.

so after trial and error, combining Ebi with Buri to make a buffer patch - i have all 3 working: LCD, DP, HDMI.

 

on Mohave 10.4.3beta

switchable graphics in BIOS

inject ATI true

set buffer to Buri

 

Note: for ATI only using Ebi framebuffer will connect to LCD - patching it one can blend Buri and Ebi to get all 3 LVDS, DP, HDMI.

 

but then discovered that using both Intel GFX+ATI works best

 

using these kexts:

as.vit9696.AppleALC (1.3.5)

as.vit9696.Lilu (1.3.1)

as.vit9696.WhateverGreen (1.2.7)

com.insanelymac.IntelMausiEthernet (2.5.0d0)

com.techsmith.TACC (1.0.3)

org.hwsensors.driver.ACPISensors (1443)

org.hwsensors.driver.CPUSensors (1443)

org.netkas.driver.FakeSMC (1443)

org.rehabman.driver.AppleSmartBatteryManager (1.90.1)

org.rehabman.driver.FakePCIID (1.3.6)

org.rehabman.driver.FakePCIID.XHCIMux (1.3.6)

org.rehabman.voodoo.driver.PS2Controller (6.0.0)

org.rehabman.voodoo.driver.PS2Keyboard (6.0.0)

org.rehabman.voodoo.driver.PS2Trackpad (6.0.0)

org.tw.CodecCommander (2.5.0)

 

Share this post


Link to post
Share on other sites

Hello. 

My m4800 everything works normally except sleep / wake.
Can you guide me how to sleep / wake.
My machine hardware configuration is:
i7 4810qm, 1920x1080, k1100 quadro, 16bg ram

Share this post


Link to post
Share on other sites

happy to share my config and DSDT.

i will create a repo on github. and you can see if it helps you. 

for about 2 years i used the intel HD gfx only.

but now can use switchable gfx. IGPU runs the LCD and ATI runs the DP or HDMI ports.

 

i presume similar approach will work for you with Nvidia?

 

Share this post


Link to post
Share on other sites

@Hervé

well yes i have/had the HPET fix in place...

 

but thank you! your post put me on the right track. now everything seem to work.

 

I removed FakePCIID_XHCIMux kexts and went with RehabMan's standard USBInjectAll.kext.

Then the "Bluetooth HCI" shows up (before and after sleep) in the USB list.

 

but was missing 3 SuperSpeed ports.

Bluetooth seems to show up HS10

 

so fixed up a custom Injector and have all the ports!

 

Now everything seems to work:

 

Display: LCD (with brightness), External DP and HDMI

Audio (speaker, mic) 

Intel Bluetooth

Wifi - with 2nd card - Atheros

Sleep/Wake

USB3 - 4 external ports.

 

tluck@Toms-Dell /Extra/OSX-build/Systems/Dell
$ ioreg -l|grep "\-o HS"
    | |   |   +-o HS01@14100000  <class AppleUSB20XHCIPort, id 0x10000029d, registered, matched, active, busy 0 (0 ms), retain 10>
    | |   |   +-o HS02@14200000  <class AppleUSB20XHCIPort, id 0x10000029e, registered, matched, active, busy 0 (8889 ms), retain 16>
    | |   |   +-o HS05@14300000  <class AppleUSB20XHCIPort, id 0x10000029f, registered, matched, active, busy 0 (0 ms), retain 10>
    | |   |   +-o HS06@14400000  <class AppleUSB20XHCIPort, id 0x1000002a0, registered, matched, active, busy 0 (0 ms), retain 10>
    | |   |   +-o HS10@14500000  <class AppleUSB20XHCIPort, id 0x1000002a1, registered, matched, active, busy 0 (268 ms), retain 15>

tluck@Toms-Dell /Extra/OSX-build/Systems/Dell
$ ioreg -l|grep "\-o SS"
    | |   |   +-o SSP1@14600000  <class AppleUSB30XHCIPort, id 0x1000002a2, registered, matched, active, busy 0 (0 ms), retain 13>
    | |   |   +-o SSP2@14700000  <class AppleUSB30XHCIPort, id 0x1000002a3, registered, matched, active, busy 0 (0 ms), retain 13>
    | |   |   +-o SSP5@14800000  <class AppleUSB30XHCIPort, id 0x1000002a4, registered, matched, active, busy 0 (421 ms), retain 18>
    | |   |   +-o SSP6@14900000  <class AppleUSB30XHCIPort, id 0x1000002a5, registered, matched, active, busy 0 (0 ms), retain 13>

posted EFI here:

https://github.com/tluck/Dell-M4800-Clover

  • Like 1

Share this post


Link to post
Share on other sites

@tluck First, many thanks to your workload & sharing. Its very helpful to me and some other has the same M4800 hardware like yours. 
I've followed by using clover and some kexts files in your Github and seem like almost everything working good on my M4800 (With AMD Firepro M5100 dGPU)
But still has some little issues: USB speed (On mine, all as USB 2.0) and audio jack 3.5 alway has noised when attached headphone into this.

<-- This cause when I've tried to use  VoodooPS2Controller-R6Bronxteck.kext. Come back to use VoodooPS2Alps.kext in Tluck's Github repo and it works well.
But I still want to known more information as what patches you've used in patched DSDT file. It'll be very helpful to me to make my own M4800 DSDT.

Thank you so much! 😀

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...