Jump to content

[BOOTPACK] E6330 Catalina 10.15.3

Recommended Posts



First off a big thank you to everybody contributing to these forums,  pretty much every single issue I ran into was discussed here including a solution. Thanks to the knowledge shared here I was able to get my Dell running Catalina very smoothly. So I'd like to share my E6330 (Ivy Bridge QM77, low-res, igp) Catalina bootpack with you. It has been tested on my E6330 Low-res model. Everything you'd expect to work works and it has been very stable in use.


Please use my previous guide for better instructions. In short you replace the EFI folder on your macOS installer with the one from the bootpack, install macOS, boot into macOS, install Clover and copy the EFI partition to the EFI partition of your internal disk. If you don't have an i3 don't forget to make your own SSDT file as described in my previous guide.


My E6330 has bios version A21, with the standard Dell bluetooth card made by Broadcom and a Broadcom 4322 for wifi. To make the Broadcom wifi work you'll need to get a copy of IO80211Family.kext and in some cases also IO80211FamilyV2.kext from  Mojave and place them in L/E. You need to mount / in r/w mode before copying them to L/E. Use Hackintool for that and also use it to rebuild the kext caches.


BIOS Settings used to dump/patch and create the dsdt used: load defaults and change data mode to ahci, the only other thing I change is disabling legacy boot. Changing anything else will most likely render the supplied dsdt useless.


If you don't have a Broadcom bluetooth card simply remove BrcmBluetoothInjector.kext, BrcmFirmwareData.kext and BrcmPatchRAM3.kext in the Clover kext folder and replace them with the ones you need. If you don't have Broadcom wifi you can skip the older IO80211Family kexts and place the kexts you do need to get wifi to work.


I suggest downloading Clover Configurator and Hackintool before installing and copying them to the install usb stick. It will make things like mounting EFI partitions and remounting / in r/w mode a bit easier. You might also need Hackintool to generate your own USBPorts.kext in case you have any issues with them (unlikely if you use an E6330 on the A21 bios). I also suggest install Karabiner Essentials, for me installing this makes the keyboard work like a Mac keyboard. F1/F2 change brightness and stuff like volume control also work with osd. I also use this to remap some keys, this is purely optional.


What works:

- Graphics, everything working very nicely including brightness slider in control panel and no glitches on boot or shutdown.

- Mini hdmi out works including audio.

- Audio, tested headphone and internal speakers. Internal microphone works too.

- Sleep and wake; opening and closing the lid, manual sleep and auto sleep all functioning as expected.

- Wifi works, most Broadcom cards should work (O80211Family kexts from Mojave).

- Bluetooth works, as above most Broadcom cards should work (BrcmPatchRAM3).

- All USB ports work as expected, if you have any issues create your own USBPorts.kext with Hackintool.

- E-sata port and optical bay sata port work as expected, including booting from them and hot-plugging (Thanks to Jake Lo).

- SD Card reader works if you have an O2 reader that's connected to the pci bus.

- Touchpad and tracking stick, even multi touch gestures work though they're not easy on this tiny touchpad lol.

- Volume keys on right side of keyboard work (volume up/down and mute).

- Battery.

- FileVault2.


Not working:

- Can't wake up the laptop from sleep with bluetooth devices, this can make clamshell mode tricky (don't think this can be fixed).

- You tell me! 



- FileVault2: On boot the password prompt might take a little while to show. For the best experience remove the verbose boot (-v) flag.

- If the sd card reader isn't working check if the pci address of it matches with the one in the devices section in the Clover config, more info here.

- Battery percentage might update too slowly (for my taste). You can use coconut battery to replace the Apple one the Menu Bar.

- Not all sensors and system info is available in VirtualSMC. Notably missing; fan stats and current cpu multipliers and such. This is both due to HWMonitor app not being fully compatible and VirtualSMC not being fully matured in the sensor department.Third party apps might do it better (iStat etc). FakeSMC has more sensors available but also an annoying bug where it doesn't detect power source. If you don't care about that bug you can replace VirtualSMC with FakeSMC after install easily with Clover configurator:


- Mount EFI

- Delete virtualsmc.efi in the "install driver" section and then select smchelper.efi from the list and click download

- Go to "kext installer" section and select the right EFI path and folder (Other) so the installed kexts populate the lower right box

- Delete all files starting SMC and virtualsmc.kext, then from the list above select FakeSMC and click install (select all the sensors kexts it will prompt for as well)

- Download this, unpack it and drag ACPIBatteryManager.kext from the release folder in the lower right box to install it


Untested (will test when I get the chance):

- Hand Off, not supported on my old DW380 bluetooth module. Should work, might require some Clover magic.

- Airdrop, same as above. Removing the DW380 and installing new wifi/bt card thats supported is the best solution (BCM94360CD + mini pcie adapter)


DSDT patches applied (source dump from A21 bios):


- Brightness fix HD3000/HD4000 (also fixes closing/opening lid for sleep/wake)

- *pnp/pnp lowercase error fix

- Rename _DSM methods to XDSM

- Fix _WAK Arg0 v2

- Fix Mutex with non-zero SyncLevel

- HPET Fix

- IRQ Fix

- OS Check Fixes

- RTC Fix


- 7-series/8-series USB
- USB3_PRW 0x0D

Sorry about the bad formatting and mark-up. I really suck at it 😅


Please let me know below if you have any questions or suggestions.


Starting from V4 the default VRAM is 384MB, you can change it with Clover Configurator easily. I added a bunch of options, you can disable them all to let macOS decide the VRAM size or set it yourself. I only have 4GB ram and don't really use anything graphically heavy. By default it stole 1.5GB from my ram for VRAM. A bit too much for me. 




I did some experimenting and 256MB still ran ok but Youtube was a bit choppy at time, it runs good with 384MB for me. But Like I said I barely play videos or do anything graphical intensive.



Share this post

Link to post
Share on other sites

V1: Initial pack, testing only.

V2: Initial 'release' had some silly errors.

V3: Fixed USBPorts.kext and removed my ACPI dump.

V4: Added sd card reader support and options to select VRAM size.

V5: Added fixes received here. Brightness fixed and added hot plug e-sata/caddy support.

V6: FileVault2 drivers added and tested, and switched to VirtualSMC.

V7: Had some issues with sleep, USB3_PRW 0x0D dsdt patch fixed it.

V8: Fixed sleep not working with a drive present in media bay/drive caddy. Clover + kexts updated.




Share this post

Link to post
Share on other sites

Ran into another weird bug, and silly I didn't notice it before. The battery indicator doesn't respond to being plugged in or out. It's always showing the power source as it was at boot. I have no idea how this happened or how to fix it.


(Not sure if related but I did try VirtualSMC and OpenCore but erased nvram and even tried resetting ec (remove battery and power and press power 30 seconds according to Dell forums). But it didn't sort it out. VirtualSMC ran ok but weird touchpad/keyboard glitches it seemed to cause and the lack of sensors made it not ready to replace FakeSMC yet. OpenCore looks promising but it requires a lot of work and it didn't work as smooth as Clover for me for now.)


I'm at a loss how this happened and how to fix it and its just my machines. I even did a clean install and reset the bios and patched DSDT again with a fresh dump. I hope be something really simple or silly I'm overlooking. Hope someone can shine a light on the cause. Thank you!


Share this post

Link to post
Share on other sites

Try add to boot arg

 bpr_probedelay=200 bpr_initialdelay=400 bpr_postresetdelay=400


More info here

Others seems to have more luck with older version. Issue has been around for a while now.

  • Like 1

Share this post

Link to post
Share on other sites

Thanks for the info.


I did some testing and older versions either exhibit the same issue or they cause a panic on boot. I don't think this will be fixed any time soon as FakeSMC is not under active development anymore so I've switched to VirtualSMC again. There the power source detection works and I don't get battery warnings but the percentage updates a lot slower than the actual drain, but that's easy to fix with coconut battery, which seem most accurate apart from the temperatures 😀 




Will do more testing. Somehow using those boot flags disabled the wifi led on the laptop 😅


Hopefully the VirtualSMC people will sort out the sensor stuff but I don't think Ivy Bridge platforms have much priority so I won't expect too much. Apart form this battery and sensors (missing fan rpm and cpu stuff) everything is pretty much perfect now. Haven't had a touchpad glitch in a while but I remember the same glitches happening on all Dells running VoodooPS2Controller-R6Bronxteck, its rare enough not to go and try other PS2 stuff as everything works so nicely with this kext.


Funny that I now have 3 different percentages depending on the app used lol.



Share this post

Link to post
Share on other sites

Ohh thats another good option to try, but then I have to move back to FakeSMC, regain some sensors but get worse/bad FileVault2 support right? The guides on this all say to use VirtualSMC for FileVault2. But I might try it and see how it goes. I quite like having all the sensors and stuff available even though it doesn't really matter of course.

Share this post

Link to post
Share on other sites

Just installed macOS Catalina 10.15.4 developer beta 2 (19E234g) without any issues. Updating to any future 10.15.x releases should also be ok. The only thing not working correctly as far as I can tell is the VRAM size. Most likely AppleIntelFramebufferCapri.kext has changed so the hex values need updating. Would be nice if we can set the VRAM size with a Lilu/WhateverGreen flag.


It did indeed change, to set 512MB VRAM in 10.15.3 I had this:

00000060 10070000 10070000 00000000 -> 00000020 10070000 10070000 00000000


10.15.4 beta 2 needs:

01020402 00000004 00000001 00000060 -> 01020402 00000004 00000001 00000020


Easy to generate a new hex kext patch if it changes again with Hackintool, sure makes life a lot easier.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...