Jump to content
PayPal donations: [email protected] ×
FJDR

MacBookPro8,3: issues with Sonix USB3.0 Express Card controller

Recommended Posts

With Catalina I have some issues:

 

The card is detected in PCI section as USB eXtensible Host Controller.

But in USB section not.
Appears in the Menu and Console told:

 

- 009088.394190 [email protected]: AppleUSBHostPort::interruptOccurred: overcurrent detected with port status 0x4000, localSimulatedInterrupts = 0x0

 

And

 

- GenericUSBXHCI::CreateRootHubDevice  Bus 14 already taken

 

What I must edit to give more detected USB Ports?

Share this post


Link to post
Share on other sites

It really depends on which generic USB3.0 kext you use but, yeah, not seeing the card listed as USB3.0 controller in SysInfo->USB section is to be expected in Catalina. However, that's not indicative of the EC controller not working. I've posted a copy of the kext I use in the other thread published in this section.

 

If you appear to have reached the limit of USB port numbers, apply the patch that lifts it.

 

Check what is listed in SysInfo->PCI and lookup your IOReg with IORegistryExplorer app. You may post a zipped copy of your saved IOReg. What computer are you using?

  • Like 1

Share this post


Link to post
Share on other sites

Hello Herve:

Thanks for answer. The Mac I use is a 2011 MacBook Pro 17. Upgraded all as I can. Change the RAM to 16 Gb, replace the HD to a 1Tb SSD and the Airport Card was replaced by a new one to get HandOff and Continuity. Now run Catalina and must tell is faster than High Sierra.

 

To reach a 3.0 USB support bought a NEC UPD720202 chipset. I can see as PCI and the menu icon. But have a conflict with the USB bus. Console shows BUS 14 already taken.

 

Console shows:

default    09:43:56.032603-0400    kernel    014692.897553 [email protected]: AppleUSBHostPort::interruptOccurred: overcurrent detected with port status 0x4000, localSimulatedInterrupts = 0x1
default    09:43:56.034359-0400    usbd    [Line 825 of /AppleInternal/BuildRoot/Library/Caches/com.apple.xbs/Sources/IOUSBFamily_executables/IOUSBFamily-987.120.1/USBAgentAndDaemon/Daemon/Classes/USBDaemon.m] -[USBDaemon portOverCurrent:]overcurrent at 0xfa140000
default    09:43:56.141275-0400    NotificationCenter    Queuing action present for app _SYSTEM_CENTER_:com.apple.USBAgent.
default    09:43:58.710639-0400    kernel    USBF:    14695.575
default    09:43:58.710652-0400    kernel    GenericUSBXHCI::CreateRootHubDevice  Bus 14 already taken
default    09:43:58.710654-0400    kernel    
default    09:44:01.135529-0400    kernel    014698.000629 [email protected]: AppleUSBHostPort::interruptOccurred: overcurrent detected with port status 0x0, localSimulatedInterrupts = 0x1
default    09:44:04.559865-0400    NotificationCenter    Queuing action removeAlert for app _SYSTEM_CENTER_:com.apple.USBAgent.
 

From System Inf:

 

ExpressCard:

  Type: USB eXtensible Host Controller

  Driver Installed: Yes

  MSI: Yes

  Bus: PCI

  Slot: ExpressCard

  Vendor ID: 0x1912

  Device ID: 0x0015

  Subsystem Vendor ID: 0xffff

  Subsystem ID: 0xffff

  Revision ID: 0x0002

  Link Width: x1

  Link Speed: 2.5 GT/s

 

Share this post


Link to post
Share on other sites

Not that I want to blow you away, but you come to a Hackintosh forum for a Mac problem...

 

Anyway, would I be right to assume that you have no success when connecting a USB device to the EC card? You've not said anything on that matter. The apparent conflict you report may not actually be a problem. In SysInfo, the EC card does properly register under the PCI section where I can clear ly see "Driver installed: Yes".

 

What about IOReg? I don't think we'll get anywhere without you posting a zipped saved output from the app I mentioned above.

Share this post


Link to post
Share on other sites

As I suspected, I don't see any IO or Bus conflict whatsoever on your SandyBridge HD3000/Radeon HD 6750M MacBookPro8,3 which has no built-in USB3.0 controller. Your card does register against the ExpressCard PCI bridge RP04 but it does so 12 x times! I guess this is where things are wrong.

 

IOReg#1.jpg

 

I can't say why this happens but maybe the old Hackintosh GenericUSBXHCI kext v1.2.11 is inappropriate for a real Mac. Or maybe it is improperly installed, you'll have to provide details on that front.

IOReg#2.jpg

 

Make sure that:

  1. you have a single instance of the kext installed
  2. the kext is installed in /Library/Extensions folder
  3. kext's permissions have been repaired
  4. cache was properly rebuilt

You must also take into consideration that you're obviously running a patched Catalina build on what is officially an unsupported Mac model though I'd be surprised if that caused the problem.

 

If the kext you use was properly installed, you should look for other kexts/alternatives to drive your EC USB3.0 controller. I suggest you consult Apple Mac forums like MacRumors.com on the matter rather than Hackintosh forums.

 

Here's what things look like in IOReg with my ExpressCard NEC Renesas USB3.0 controller (UPD720202) on my Sandy Bridge and Ivy Bridge Hackintosh laptops (respectively without and with built-in USB3.0 controller) under High Sierra/Mojave/Catalina, all running with Rehabman's GenericUSBXHCI kext v1.2.11 cached from /L/E:

IOReg#3.jpg

 

Here's what things look like when I attach an external SSD and a USB3.0 key:

IOReg#4.jpg

 

Share this post


Link to post
Share on other sites

Thanks a lot. I will check it again. The kext was installed OK and the permissions and caches was updated. Then I will check it out another way to do that.

 

Otherwise I will forget the expresscard/34 at all.

 

Regards

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...