Jump to content

Latitude 5510: unable to install macOS

Recommended Posts

  • Administrators

Anything is possible, but that does not really help, does it?

Did you check the info of the TrackPad driver for Latitude 5510 in the support section of Dell's web site?



Ok, here goes... PCI id 0488:121f

-> It's a Synaptics Touchpad.

Link to comment
Share on other sites

  • Replies 52
  • Created
  • Last Reply

Top Posters In This Topic

  • Administrators

Look up the documentation that goes with those Synaptics I2C kexts; usually there are PlugIns for the various brands and you'd need to remove Alps Plugins if you used those for instance. Can't say more, haven't done much experimentation since the Latitude 5490 that I no longer have and I never spent much time on it.

Link to comment
Share on other sites

  • Moderators


On my Precision 5510, it also has a Synaptics I2C touchpad and using VoodooI2C + VoodooI2CHID worked just fine.

You could try removing VoodooI2CHID and replace it with VoodooI2CSynaptics and see how it goes.

Link to comment
Share on other sites

Hi you all,

Finally, I have succeeded in an installation that is not yet 100% but almost. Shout out to @Jake Lo & @Hervé for your precious advices & technical helps.
The only thing that is still not working is the trackpad which is quite basic. As soon as I touch the trackpad, the pointer goes to the left. I have to use a second finger to select something and a second Tap to open something.
I tried various kexts (VoodooI2CHID & VoodooI2CSynaptics) but still no real working trackpad.
Maybe there are still errors in my config.plist. 
I think I'm about at the same point as @denkteich is with his configuration.

I'll keep looking on my side.
If you ever think of something while checking my files, I'm interested 😄



HackBook-Latitude-5510.ioreg config.plist.zip

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...