Jump to content
joe82

D620/GMA Mirror Display Fix

Recommended Posts

Correct me if I'm wrong, but it sounds that you just want your laptop LCD to turn off/turn on (i.e. display sleep) when lid is closed/re-opened, right? Or do you just want to close the lid without anything happening at all, i.e. no display sleep, no computer sleep?

 

Whatever it is, it differs from initial design, which is to sleep the computer when lid is closed. So you use 3rd party software (InsomniaX/Caffeine/Sleepless) to try and reach your goal. I don't know how it's done, but I guess those software somehow intercept the call for the code that puts computer to sleep. From your description, it also appears that those software do not put the display to sleep and that you have to use hot corner to do that, right?

When I close the lid, I want the display to sleep but NOT the laptop. There is an option for this in Windows and Linux. The only way to accomplish this is with InsomniaX/Caffeine/SleepLess in OS X.

 

That is exactly how these 3rd part softwares work. They intercept the call for sleep on clamshell close and disable it. And the display does sleep when you close the lid. But if you do not sleep the display before closing the lid, it will NOT wake back up. I'd even prefer if the display didn't go to sleep. Then I wouldn't have to dink around with hot corners for sleeping the display.

 

Or does closing the lid, with those software enabled, still put display to sleep but opening the lid failing to wake it?

 

Exactly! This is exactly what is happening!

 

However it is worse than that. Closing the lid with these softwares enabled will indeed sleep the display. (Like it should!) Except when I do this WITHOUT sleeping the display first via a hot corner (confusing, I know.) nothing I do will wake the display back up. This is not normal operation. If you use this software on a real Mac (I've used it on the MacBook Pro I used to have), the screen should sleep when you close the lid, and wake back up (without touching a single key or the touchpad) on its own when the lid is opened. That doesn't happen at all, on my D520. In order for me to close the lid properly, I have to sleep the display before I close the lid, and after I open the lid.

 

I'm failing to comprehend how a DSDT edit would help you here.

I never said it would, but thats where I think the problem lies. Nor did I say I wanted anyone to look into it, other than confirming their GMA 950 operates the same and that I'm not going bananas lol. I was merely commenting on the fact that its back to what I consider "normal" operation for OS X. ;)

 

I recently played around with hot corners on all my Latitudes. Works great, I can either put display to sleep or launch screensaver. With display sleep, I do not have to return to the specific hot corner to wake display, I simply press a key or move the mouse.

 

I too, can use the hot corner to sleep the display and press any key to wake the display. It even wakes up if I use the mouse. So, doesn't it seem strange to you that if I sleep the display with the hot corner, close the lid with any of these software enabled so that the machine won't go to sleep, open the lid, and the LCD display doesn't react to a key press or a mouse movement like it should? Why do I have to move the mouse BACK to the hot corner to wake the display? Why won't the display wake back up if I don't have a hot corner to sleep the display? (It literally won't. I have to reboot the machine to get the internal LCD display to work again.)

 

If that does not work anymore once your 3rd party software is installed, I'd say the problem comes from them. Don't you agree?

There is no way to test this, that I know of. There is no setting in OS X to disable clamshell sleep so that the machine wont sleep when I close the lid. So I have to have one of these softwares installed and running to test this. So whether or not it worked "before" is a moot point because there's just no way to tell if it operated this way before any of these softwares were installed.

Share this post


Link to post
Share on other sites

Ok, so I disabled sleep altogether. (Gotta love pmset!) When I close the lid, the display sleeps like it should. However, upon opening the lid, the internal LCD display does not wake back up like it should. No amount of touchpad movement or keyboard tapping will wake the display back up. 

 

A hot corner to "sleep" the display will wake it back up. 

 

This proves to me that its a problem with either my machine, my DSDT, or OS X. It is not the software that is causing this issue. 

 

I don't believe it is the D520 DSDT, because it happens with the DSDT from EDP on the D620 GMA as well. I don't believe it is a problem with OS X either, because on a normal Mac, it operates the way it should. That only leaves the LCD display as a culprit. As the LCD operates normally in Windows or Linux, I'm leaning towards the LCD display is just fine.

 

So, I just don't have a clue. I wish someone with a GMA 950 would attempt this, and see if theirs performs the same way. (If you need the terminal command to completely disable sleep, let me know. I'll provide it to you so you don't have to install any of the previously mentioned softwares.)

Share this post


Link to post
Share on other sites

It is not a sleep issue, Bronx. It is a !DISPLAY SLEEP! problem.

 

Clamshell sleep is disabled so that the machine WILL NOT sleep when I close the lid. The display should turn off when I close the lid (not the machine) and it does. The display should turn back on when I open the lid. (It does not.)

 

Here, I'll run the steps I took to make this happen....

 

1. Disable clamshell sleep in Terminal

2. Close the laptop display. (Machine wont sleep, just the display will turn off!)

3. Open lid

4. Do anything. Screen will not turn back on.

 

Here's how I MUST turn the display back on...

 

1. Disable clamshell sleep in Terminal

2. Open System Preferences/Mission Control/Hot Corners (Set hot corner to SLEEP DISPLAY)

3. Close lid (Machine will NOT sleep. Only the display should turn off.)

4. Open lid

5. Do anything. Screen will not turn back on

6. Move mouse towards hot corner and then away. Screen magically turns back on.

 

 

Keep in mind that I AM DISABLING CLAMSHELL SLEEP! The machine no longer has the ability to sleep when I close the lid. So when I close the lid, I do not want the machine to sleep. I only want the display to turn off. So this isn't a sleep problem.

 

In fact, I just put the machine to sleep via the Apple Menu and woke it up. Sleep performs normally. (The display turns back on.) But if I DO NOT sleep the machine and just close the lid (With clamshell sleep disabled so that it WILL NOT sleep when I close the lid) the display turns off like it should. When I open the lid back up, it will NOT turn back on.

 

This isn't normal operations. And I hope I explained this better.

Share this post


Link to post
Share on other sites

ok. d620 nvidia has a similar issue with display sleep. there used to be a solution that used sleepwatcher and it would trigger a script that briefly switched resolutions to turn on the display. maybe if you used something similar you can have it trigger what the hot corner does... but then again... it is only display sleep so idk how it would work out.

Share this post


Link to post
Share on other sites

Thanks, Bronx, for testing this out for me. I'm not losing my marbles! YAAAY!

 

Also, that is exactly the script that we used to use back in Tiger/Leopard to fix this issue. I couldn't remember the name of it, so thanks for that also. 

 

I will definitely give SleepWatcher a try. I haven't tried switching display resolution as a fix, but only because I cannot wake the screen up to switch resolution. (There is no hot key for it. I suppose I could try to set one with Ukelele though.) And once I get the display woken back up, it doesn't really matter lol.

 

Like I said, I'm not really looking for a fix. Just confirmation that I'm not the only one with this problem. (Also, it wouldn't be a problem for most. As far as I know, I'm the only one that closes my lid without having the machine go to sleep. I do this because it is a mobile computer shared between me, my girlfriend, and the television lol. I like to close the lid while I transfer it from point to point in the house.)

Share this post


Link to post
Share on other sites

hmm this cscreen is interesting..... i wonder if it would show what resolutions the screen has in mirror mode or force set a correct resolution?

 

 

$ cscreen
1 display found
Index Depth Width Height Refresh(Hz; LCD displays show 0)
1 32 2560 1440 0

$ cscreen -h
Usage: cscreen [-d ] [-x ] [-y ] [-r ] [-s ] [-v] [-m] [-f] [-l] [-h]
[-d ] : specifies the bit depth (bits per pixel)
[-x ] : specifies the width in pixels
[-y ] : specifies the height in pixels
[-r ] : specifies the refresh rate in Hz
[-s ] : specifies which display to use (defaults to main display)
use a as the option to -s to specify the action on all displays
[-v]: display valid modes (use -s to specify display or nothing for the default)
[-m] : require an exact match
[-f]: forces settings (ignores safety mechanisms; USE AT YOUR OWN RISK)
[-l]: lists the current displays and modes
[-p]: sets the requested display to be the primary display
[-h]: displays the usage

Share this post


Link to post
Share on other sites

Ok, I could see how that works. 

 

I gave SleepWatcher a shot. I used the following code:

 

#!/bin/sh
  
PMSET_NUMBER=107374183
PMSET=/usr/bin/pmset
GREP=/usr/bin/grep
AWK=/usr/bin/awk
SLEEP=/bin/sleep
    
$PMSET force -a displaysleep $PMSET_NUMBER
$SLEEP 1
$PMSET force -a displaysleep `$PMSET -g | $GREP displaysleep | $AWK '{print $2}'`
$SLEEP 1

 

It will sleep and wake the display fine. However, after closing the lid, it doesn't wake the display at all. I think it is because it is executing the display wake/sleep via PMSET instead of a hot corner. (I'm not sure how the hot corner forces the display to sleep. It may even be PMSET, however I'm not executing it the same way.)

 

I will look into cscreen though. If anything, it seems interesting in forcing my television to supported modes that OS X wont show. ;)

Share this post


Link to post
Share on other sites

"SleepLess" has an option to "Prevent sleep with lid closed, display's will NOT sleep". This means that neither the computer or the lid will sleep/turn off when I close the lid.

 

I enabled this setting. Then I closed the lid. Sure enough, the display was shut off, however the computer was still running. :(

 

So I used the hot corner to bring the display back to life. Then I opened a Terminal and fired up cscreen and fed it the correct parameters but did NOT push enter and left Terminal/cscreen the active app. Then I shut the lid, and opened the lid. The display was shut off like I expected, so I tapped the enter key so that Terminal/cscreen would execute my command. No juice. I changed the resolution to 800x600x32, however the display never woke up. So I used the hot corner to bring the display back to life, and low and behold, the resolution was at 800x600. So cscreen is working like it should, but it is not waking the display up like I had hoped. :(

 

It must have something to do with the lid close button in DSDT. There's a little lid close button/tab to the right of the power button that is pressed when you close the lid. (I'm attaching a picture of mine.) I think this is the causing the issue, to be honest. Remember, clamshell sleep is also tied to this button, and that works. So thats why I think this is a DSDT problem. Or it could just be the fact that I'm running OS X on a Dell. :P

 

(Picture of display close button)

post-856-0-30336100-1354915111_thumb.jpg

Sorry for such a terrible quality. I used my phone :(

 

I think this is something I just have to deal with. I may take the power button strip above the keyboard off and remove the lid close button altogether and just remember to sleep the display with a hot corner. The only reason I don't like this idea is because that will completely disable clamshell sleep, instead of me disabling it when I want via "SleepLess". (Clamshell sleep relies on that lid close button being pressed. Remove the button, remove the feature.)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...