Jump to content

ELAN, FocalTech and Synaptics (Smart Touchpad) Driver (Mac OS X)


Recommended Posts

  • Replies 1.5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Last update: 17 Sep 2017   UPDATE: 17 - 09 - 2017 Just wanted to clear few things about my commitments to community, and development on my projects which has been going slow due to my personal life

@EMlyDinEsH It's been more than 2 years since last update of the kext and about 1,5 year since last update of the first post. Can you finally release the source code, so someone could finally improve

macOS Sierra: some Fn keys do not work and trackpad work only as mouse. Please fix.

Posted Images

Hi,

This driver is made for PS2 devices, I have the kyb and trackpad USB connected for my device (as they are on the docking keyboard). I have a Ativ Tab 7 (Samsung) XE700T1C (whatever the model, it's still the same) and it got ELAN USB "Smart Keyboard" with a bundle of TrackPad and kyb as I mentioned before. How can I make this driver work with my device, as I don't have two finger scrolling or anything? (I should change some stuff on the info.plist or rebuild the whole thing or just give up?)

Thanks

Link to post
Share on other sites

Hello everybody!

 

Acer Aspire E1-572 (Elan, Hardware version 3 (Firmware version 0x454f00), driver v. 4.5):

Two fingers scrolling doesn't work, I use Edge Scrolling.

 

Sometime (not often) something strange happens with touch pad (or a driver):

any touches/movements/swipes stop work, I can see only random press/release events (looks like the right touch pad button is pressed/released).

Sleep/Wake solves this issue (I suppose some initialization is happened after wake) .

 

It would be nice if keyboard shortcut for enabling touch pad could reinitialize it.

 

Anyway, thank you for the possibility to use this touch pad!

Link to post
Share on other sites

Hi, @EMlyDinEsH

 

Thank you for your great work!

Everything works fine, but touchpad behavior is little strange. When I move finger straight from top to down (or from left to right), pointer doesn't goes straight. It moves like a sine with a small amplitude. On Ubuntu touchpad works fine: if I move finger straight, pointer moves straight too.

 

I have tried to change smoother samples count and resolution values, but it doesn't helps me anyhow.

 

And one more thing. On Ubuntu I can start dragging, leave one finger ANYWHERE on touchpad and continue dragging with other finger (it is very helpful when dragging on a long distances), but in OS X I can only drag with two fingers when one finger is on buttons zone. So, is there any way to get dragging work like on Ubuntu (and Windows)?

 

If it helps, my laptop is Asus UX32A (it has Elan v4 touchpad).

Link to post
Share on other sites

Upgraded from 4.2 to 4.5 Final X64:

 

Biggest issues are:

1. cannot drag with two fingers anymore as it triggers two finger press / "right mouse click". On MAC you can drag items very intuitively using three finger press and move! Wish that could be implemented.

2. change in scroll inertia handling - it used to be better.

 

Thanks for supporting Hackintosh!

 

Sorry for late reply. Two fingers drag is working, so i need to know more details about your gesture and might need debug logs. So please PM me to help me with beta test, so i can improve. Inertia handling has so many tweaks in plist compared to before, so try to play with plist option and see.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...