Jump to content
EMlyDinEsH

Fn HotKey and ALS sensor driver for Asus Notebooks

Recommended Posts

Without more details, we can't help you ;-).

 

Have you used the DSDT patch? :P

My PNLF:

            Device (PNLF)
                    {
                        Name (_HID, EisaId ("APP0002"))
                        Name (_CID, "backlight")
                        Name (_UID, 0x0A)
                        Name (_STA, 0x0B)
			            Method (_BCL, 0, NotSerialized)
			            {
			                Return (\_SB.PCI0.PEGR.GFX0.LCDD._BCL ())
			            }
			            Method (_BCM, 1, NotSerialized)
			            {
			                \_SB.PCI0.PEGR.GFX0.LCDD._BCM (Arg0)
			            }
			            Method (_BQC, 0, NotSerialized)
			            {
 			               Return (\_SB.PCI0.PEGR.GFX0.LCDD._BQC ())
			            }
			            Method (_DOS, 1, NotSerialized)
			            {
			                \_SB.PCI0.PEGR.GFX0._DOS (Arg0)
			            }
                    }

I patched my dsdt the instructions on the first page, throw kext on kext utility...

The sound is not regulated by the function keys. I use native kext for sound.

Share this post


Link to post
Share on other sites

There is new update coming for this driver so try that kext after i release it within a week

 

I appreciate the update, but can anyone at least confirm that the edits that I did to my DSDT are ok ? I would like to at least rule out this possibility..

 

Thank you,

 

Adi

Share this post


Link to post
Share on other sites

My PNLF:

            Device (PNLF)
                    {
                        Name (_HID, EisaId ("APP0002"))
                        Name (_CID, "backlight")
                        Name (_UID, 0x0A)
                        Name (_STA, 0x0B)
			            Method (_BCL, 0, NotSerialized)
			            {
			                Return (\_SB.PCI0.PEGR.GFX0.LCDD._BCL ())
			            }
			            Method (_BCM, 1, NotSerialized)
			            {
			                \_SB.PCI0.PEGR.GFX0.LCDD._BCM (Arg0)
			            }
			            Method (_BQC, 0, NotSerialized)
			            {
 			               Return (\_SB.PCI0.PEGR.GFX0.LCDD._BQC ())
			            }
			            Method (_DOS, 1, NotSerialized)
			            {
			                \_SB.PCI0.PEGR.GFX0._DOS (Arg0)
			            }
                    }
I patched my dsdt the instructions on the first page, throw kext on kext utility...

The sound is not regulated by the function keys. I use native kext for sound.

 

 

This edit is for backlight control, not for Fn keys. Let me know your specs and send me dsdt file so i can patch.

Share this post


Link to post
Share on other sites

I appreciate the update, but can anyone at least confirm that the edits that I did to my DSDT are ok ? I would like to at least rule out this possibility..

 

Thank you,

 

Adi

 

 

Your edits are fine for fn keys. All the keys i mentioned in the first aren't working? you said it worked first time, what did you later?

Share this post


Link to post
Share on other sites

Your edits are fine for fn keys. All the keys i mentioned in the first aren't working? you said it worked first time, what did you later?

 

Ya that's the weird part. I was using chimera (chameleon, stolen and rebranded) as a bootloader at that time and I just loaded up the kext for the UX series laptops and right away I noticed that the Mute, and volume Up and Down shortcuts were working great with the OS X animation !

 

I then changed the bootloader to Clover and edited my DSDT in order to get the other keys working and all of a sudden none of the FN key combinations work anymore.. Is there any way I can debug this ?

 

I mean DSDT edits or not, the Volume Fn shortcuts should still work, no ?

 

Thank you for your help,

 

Adi

Share this post


Link to post
Share on other sites

This edit is for backlight control, not for Fn keys. Let me know your specs and send me dsdt file so i can patch.

My dsdt: http://rghost.ru/45765752

Please insert right code in my dsdt and send me dsl file.

 

Asus N73SM i5 2450m 8Gb hd3000 (+GT630M 2GB) Intel Cougar Point PCH[b-3] alc269 AR9002WB-1NG AR8151 OCZ Solid3 ST9500423as

Share this post


Link to post
Share on other sites

Ya that's the weird part. I was using chimera (chameleon, stolen and rebranded) as a bootloader at that time and I just loaded up the kext for the UX series laptops and right away I noticed that the Mute, and volume Up and Down shortcuts were working great with the OS X animation !

 

I then changed the bootloader to Clover and edited my DSDT in order to get the other keys working and all of a sudden none of the FN key combinations work anymore.. Is there any way I can debug this ?

 

I mean DSDT edits or not, the Volume Fn shortcuts should still work, no ?

 

Thank you for your help,

 

Adi

 

 

DSDT edits are only for enabling Brightness control to Screen and Keyboard, whereas remaining keys should work without any edits in my driver. Send me your System log from Console app so i can check.

Share this post


Link to post
Share on other sites

My dsdt: http://rghost.ru/45765752

Please insert right code in my dsdt and send me dsl file.

 

Asus N73SM i5 2450m 8Gb hd3000 (+GT630M 2GB) Intel Cougar Point PCH[b-3] alc269 AR9002WB-1NG AR8151 OCZ Solid3 ST9500423as

 

 

Could you send me your dump based on this thread : https://osxlatitude.com/index.php?/topic/1945-dsdtssdt-patching/ from windows so i can add your model to our EDP support?

 

I'll let you know about the dsdt edit tomorrow since I'm trying to release an update for this driver as well.

Share this post


Link to post
Share on other sites

I have edited my DSDT Getting out of the windows with aida64. Once the camera is not working and some of the function keys. I disabled the Nvidia (method PINI). Work only fn +1 (sleep), fn + f5,6, 7 (backlight). All without animation. (Translated by Google)

Ioreg:

MacBook Pro - Kalmah.zip

Share this post


Link to post
Share on other sites

DSDT edits are only for enabling Brightness control to Screen and Keyboard, whereas remaining keys should work without any edits in my driver. Send me your System log from Console app so i can check.

Here is my System.log file. Please let me know if you need anything else.

 

Thank you,

 

Adi

 

EDIT : while searching for ASUS in my All Messages System Log Quesries in the Console, i found this message :

 

 

5/4/13 2:28:57.968 PM com.apple.kextd[12]: Kext id com.apple.AsusNBWMI not found; removing personalities from kernel.

 

 

Does that mean that the extension is not properly installed ?

system.log.zip

Edited by adisor19

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×