Jump to content
qwerty12

ASUS N55SL modified BIOS (no SLIC injection)

Recommended Posts

Disclaimer: I cannot take responsibility for any damages or impairments that may occur while using or flashing the modified BIOS. It's also a fair bet that your warranty has been rendered null by flashing this BIOS.

 

This is a modified version of the latest 204 BIOS available on ASUS' support site for the N55SL.

 

This does NOT have the following:

  • a modified SLIC table. It's still the original one.
  • an OS X-friendly DSDT. Let Chameleon handle all that.
What this BIOS does enable:
  • AES-NI. If I buy a laptop with an i7 in it, you bet I want to use its full capabilities, ASUS.
  • more options unlocked in the setup screen. Like with all modified AMI Aptio UEFI BIOSes, the Chipset tab remains hidden. If you need to change any of the values contained within, use AMIBCP to change the defaults in the BIOS image, flash the new BIOS and then reset the BIOS settings to default. If you choose to do this: DO NOT CHANGE THE VALUES OF THE FAILSAFE OPTIONS.
  • For the i7(-2670QM), CPU Microcode updated to 28 from 23 for the i7. I know Linux has a driver that will do this on every boot; however, Windows does not. I suspect OS X doesn't bother, also.
  • the Lock removed on MSR 0xe2. This is important as, unless you patch either the AppleIntelCPUPowerManagement.kext to remove the 0xe2 accesses or the BIOS, AppleIntelCPUPowerManagement will cause a kernel panic. Although the option to do this as a setting in the BIOS was unlocked, it does nothing...
READ THIS CAREFULLY: When flashing the 204 BIOS with WinFlash, it will erase and attempt to flash the new BIOS about six times and eventually give up, saying it failed. FOR ME, when I turned my laptop off and turned it on again the new BIOS was flashed OK. (I have a two-year warranty so why not?) This also occurs with the stock 204 BIOS image as provided by ASUS, so it's not because of what I've modified. I cannot say that this will be the case for everyone, but I have flashed the 204 BIOS about 8 times now and I've not had a problem.

 

If you're flashing with Easy Flash, ONLY FLASH FROM A USB STICK FORMATTED AS FAT32! Not your (NTFS) HDD. I do not know if this is the case for the N55SL, but people have bricked other ASUS laptops by flashing from (an) NTFS (HDD). I have only used WinFlash, personally, and it is that what I will be talking about below.

 

With WinFlash (install it from ASUS' support site for the N55SL if needed), use the /nodate parameter if you're already running 204. If you get a message complaining about your battery level despite it being >= 22% and the AC adapter plugged in, use the /force parameter (though, of course, when using it, try to avoid times where your power is being cut due to lightning and your battery is old so it runs down fast...). After flashing, shutdown, remove the AC adapter and turn on your computer again. If you press F2 and go to the Advanced section, you should see more options.

 

WARNING: DO NOT PLAY WITH THE ME FIRMWARE UPDATE SETTINGS.

 

Find the BIOS image attached.

 

---

 

If you need then, here are instructions on how to (hopefully) recover from a bad BIOS flash.

 

A huge thanks to BrodyBoy at the ROG ASUS forums for this information.

  • Format a USB stick to FAT32.
  • Grab BIOS 202 for the N55SL from ASUS' support site and put it on the root of your USB.
  • Duplicate the ROM and name the copies as follows:
AMiboot (chameleon, stolen and rebranded).ROM
N55SL.bin
N55SL.ROM
N55SLAS202.ROM
  • Put the USB stick in the top USB 2 port on the right of the laptop
  • While holding down Ctrl+Home, turn the laptop on
  • If successful, EzFlash will show up and start reflashing your BIOS from the USB stick. Good luck!
---

 

Updating USB firmware

 

Strictly speaking, this is optional; however, owners know that the USB 3.0 ports are, by default, useless as they don't really maintain a connection with anything. A firmware update will solve this. Only follow this procedure for updating your USB 3.0 firmware if you want a laptop that still works (I'm not joking)!

  • Prepare a MS-DOS bootable USB disk. I wholeheartedly recommend Rufus for this. Just be aware of its autoupdate policy before you decide to enable the option and also be aware that it will write a new partition table to the target device. You can use DriveDroid for Android if you don't have a spare USB stick nearby but a rooted Android phone.
  • Next, extract the files in ASM1042DOSFlash.zip to your bootable DOS USB stick.
  • Go here and download the latest firmware. Run the 7Zip self-extractable EXE file that was just downloaded and choose to save the files somewhere. DO NOT RUN ANY EXEs YOU FIND IN THIS FOLDER - THE WINDOWS ASM1042 FW UPDATER WILL NOT FLASH THE FIRMWARE CORRECTLY. You have been warned! Look for a file with a similar name to xHCI_v120816_02_02_6D.bin and place it on the USB stick with the name of 1222_0E.bin.
  • Boot from the USB stick using your USB 2.0 ports (duh) and run u. Turn off the laptop when done.
---

 

Optional: Updating ME firmware

 

EDIT: TimeWalker75a points out why it shouldn't be done here: http://www.insanelymac.com/forum/topic/257950-guide-dell-xps-15-l502x-early-2011-snow-leopard-install-possibly-l702x-too/page-122?do=findComment&comment=1936953 (in short: warranty)

 

This really, really is optional (I haven't noticed any benefits for Hackintoshes) and I only include it here for personal reference. This is absolutely not required for an OS X install. Again, I take no responsibility for anything that may go wrong. This can kill your laptop if done incorrectly.

 

Some things to note before doing it:

  • FWUpdLcl.exe -SAVE Backup.bin will save your current ME FW
  • As I understand it, only 1.5MB images may be flashed for the chipset we have.
  • Sadly, it's not possible to upgrade from firmware 7 to 8 without opening up the laptop, as far as I can tell.
If you wish to do it, inside Windows install the latest drivers for the Intel® Management Engine Interface (MEI/HECI) and run this in Windows. This will upgrade you from 7.0 to 7.1. Fully power off your laptop after it's done.

N55SLF1_SLIC.zip

N55SLASM1042DOSFlash.zip

  • Like 1

Share this post


Link to post
Share on other sites
Hi.

 

My laptop is ASUS N55SF, the BIOS can do?
 
My laptop configuration:
CPU: Intel ® Core ™ i7 2670QM graphics: NVIDIA ® GeForce ® GT 555M 2GB DDR3 memory 2.5 "SATA 750GB 7200

Share this post


Link to post
Share on other sites

is asmedia update for intel (8086) usb controllers, or only for asmedia?

 

I don't understand, because in the specsheet of the asus n55, stays there is an intel usb controller...

 

Cheers :-)

Share this post


Link to post
Share on other sites

guys, do not touch your USB.

before update the usb firmware, my laptop still manage to charge my phone at output of 1A.

after update the usb port just manage to charge my phone at USB2.0 output, around 0.4A-0.5A.

but for running USB3.0 pendrive, still not a problem. only the charging ampere dropped.

just don't touch the usb.

I upgraded the ME firmware also, err.... can't notice any changes...

--------------------------------------------------(add-on on 11/Apr/2015)------------------------------------------------------------
today I updated my N55SL ME firmware to the latest 1 that found in this thread.

work like charm :)

http://www.win-raid.com/t596f39-Intel-Management-Engine-Drivers-Firmware-amp-System-Tools.html

 

kx755X7.png

Share this post


Link to post
Share on other sites

Hi. After bios update with that mod bios file, I have mentioned that if I disable HyperThreading in bios, the notebook will not start without power supply plugged in. This is a bug? How can be solved?

Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×