Jump to content
crc-error404

[07/18/2011] - D630 BIOS rework

Recommended Posts

I found myself in the same situation needing to revert back bios and machine won't boot from flash. How did you create a bootable CD with the flash utility? I created bootable FreeDos 1.0 CD but couldn't get the flash utility onto the CD. Also, tried with booting and switching CD's. Where did you find A18 bios, as I only found A17 on Dell download site. Would apprepriate any help/pointers. Thanks.

 

Update:

I used information from the following site to create bootablel CD with the flash utility for A17 BIOS from Dell..

 

http://www.nu2.nu/bootcd/

Share this post


Link to post
Share on other sites

I had my system working on BIOS A17 of DELL.

I updated to the A17 from the Wiki page but it does not work my system will not start.

I get to option to select F2 or F12. When you enter one of the two it will state Preparing to Enter Setup.... or Prepairing one-time boot menu ....

But it never gets in there.

After the progression bar disappears there is only the blinking cursor at the left upper side.

 

Now I want to restore back to A17 of Dell and have downloaded the recovery file.

The recovery file for the D630 Nvidea is 2.1 Mb in size and a floppy can only hold 1.44 Mb.

 

How is this done?

 

When I put my DOS disk in the floppy drive and remove the battery and disconnect the power cord.

Hold the END button and plug in the power cord the battery light goos red.

When I release the END button within 2 seconds the system starts. The battery light goes red green red etc.

 

I hear the floppy drive start to work but then after 5 seconds the whole system stops and switches of.

 

 

When I hold the END button a bit longer and hit the power button and the system starts in "Diagnostics boot selected".

 

The A led at next to the volume lower blink's and after the boot screen goos away both the A and the ( led blink but again nothing happens. The floppy drive is not addressed.

 

I see people have had similar problems with the BIOS but how did they get there original back.

I hope on a answer soon as the unit is now worth noting. :blink:

 

 

What do I need to do to get back to A17 of Dell.

 

thanks,

 

UGH, just went through this. Ok, grab yourself a usb flash stick. download the A17 bios for your d630 from dell. open a command window and cd to where you saved the bios file. Once there type: d630_A17.exe -writehdrfile that command creates a .hdr file that dell uses to flash back to a17.

 

take out your battery, unplug the laptop. Holding the END key down plug the machine back in. LISTEN CLOSE. When the Battery light lights up red KEEP holding it in. WHEN IT TURNS GREEN release immediately. The machine should power up. Black screen. Don't worry. You should see the light flashing on your usb stick. Wait!! THe machine should power off and back on. When it comes back on, you should see your A17 screen.

 

Hope this helps.

 

Scott

Share this post


Link to post
Share on other sites

That was scary the OSX_BIOS for my D630 Nvidia did not work. The BIOS started well but got struck at the last part, just stuck. Had a lot of pain restoring the proposed restore file aka recover4.zip did not work for me.

Somehow I found a D630_A12.exe converted it in DOS to D630_A12.hdr and renamed it with dos command

 

rename D630_A12.hdr D630???.hdr

 

Formatted FAT a 256MB USB drive copied the above file wich was renamed D630_A1.hdr

 

Followed the instructions from redalerthan on mydigitallife forum:

 

http://forums.mydigitallife.info/threads/13605-About-Dell-BIOS-recovery

 

Thank's god that was really scary.

 

Could update to A18

:)

 

Actually reading it again I just saw that Scott above did just that.

Share this post


Link to post
Share on other sites

There's been no update or development work on this Custom BIOS matter for some time and there's nothing on the horizon either. It was not successful for the D630 (nVidia at least).

 

In addition, please note that BIOS A18 does not add much to A17, except signed firmware capabilities.

Share this post


Link to post
Share on other sites

Thanks for the reply. I guess I'll just flash A17. I'm getting in some kind weird loop installing. The installed Lion or ML will boot fine from the stick -> installed partition. But if I boot directly from the partition it hangs right after loading kernel bits and before it should load DSDT.aml, which it loads fine from USB. I've tried using the USB files to no avail. I hope the bios will fix the need for this DSDT stuff. Thanks again!

 

Edit: Flashing the Nvidia bios results in a fail after 3% of checking the new bios. I've downloaded the file 3 times. No idea whats wrong :(

 

Edit2: Downgrading to A16 via bios recovery seems to do the trick, though the modded A17 progress bar never passes by 80%. Went back to stock A18 and hope to be able to solve my troubles...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...