Jump to content
Alan ocs

Mountain Lion on A43E

Recommended Posts

Guys, 
 
I would like some help to build my hackintosh.
 
I have a ASUS A43E laptop with: 
 
Intel Sandy Bridge i7 2640M 2.80Ghz chipset HM65
Graphics Intel HD 3000 (GT2+) Maximum resolution 1366 x 768
Memory 8GB
HD SSD OCZ 120GB
Intel ® Express Chipset Mobile SATA AHCI Controller

Realtek ALC269 High Definition Audio

Ethernet Atheros AR8151 v2
Wireless Atheros AR9285
 
post-5215-0-75360800-1366490679_thumb.png
 
I also extract the dsdt with dsdt editor, and I applied the sand bridge patchs, but, I think this wont works, if possible, could you correct for me please?
 
post-5215-0-69522700-1366490900_thumb.png
 
A43E.rar = DSDT without patchs.
 
Well, At the system side, I have a vmware with 10.8.3 and a external drive partitioned to make a bootable installation. I'm using MyHack to build that. 
 
How can I do to create the installation partition most compatible possible? Whats kexts I need to use? (RTC, cmos prevent, powermnagmente, fakesmc, ...) Because I tried a several times with various kexts and I won't works fine.
 
the boot.plist I use the most simple possible, like a verbose, graphicsenabler, smbios and dsdt indication. that is correct for my laptop?
 
The bootloader, I don't know what is better for me, chimera (chameleon, stolen and rebranded) or chameleon.
 
In advance, I appreciate your attention and help.
 
 
 
 
 

Share this post


Link to post
Share on other sites

Hello,

 

We're happy to help you with your hackintosh. First, let us know about your status completely so far what you did?

 

Are you able to boot with myhack created USB installer? What flags you did use so far to boot from it? Did you finish installation? Do you wish to dual boot? Tell us exactly your issue plz since your details aren't enough about the installation above.

 

Get me a dump from windows according to this thread so i can patch your dsdt/ssdt files:https://osxlatitude.com/index.php?/topic/1945-dsdtssdt-patching/

  • Like 1

Share this post


Link to post
Share on other sites
Hello Emly Dinesh, thanks for your reply and help.
 
I had a lot of problems with the installation that I had. Then, I decided to delete everything I had and start from the beginning with 10.8.3.
 
Answering your questions:
 
My USB installation was modified by me. Including my dsdt, smbios MacBookPro8,1, and some kexts that I think necessary and did not work. I'll create another without modifications and will do I inform error and flags.
 
At this time, I only have a VMware with Mountain Lion and a External USB with four partitions (MyHack Installation, Clean Mountain Lion, Space for installation, Data and Apps) *GUID Table
 
No, I don't wish a dual boot.
 
Out tonight I'll send to you the dump. [updated: here the files as requested dsdt-ssdt-dump-report.rar]

 

 

 
Again, Thanks!
 

Regards,

 

Alan

Share this post


Link to post
Share on other sites
Hello Again,
 
Now I have these partitions:
 
  • Clean MyHack Installation.
  • M Lion with MyHack extra/fix (Installed by vmware using external drive as physical).
  • M Lion clean for backup.
 
the boot test:
 
First I tried to boot with the M Lion installation, and I got a Kernel Panic with ACPI. I'll try to patch or rollback the ACPI kext.
 
And, with MyHack installation, I tried to boot using some flags and I got installation  freezing at this line:
 
[iOBluetoothHCIController][start] -- completed
 
Flags used:
 
-x -v
 
-f -v
 
-x -v npci=0x2000 USBBusFix=yes
 
-x -v npci=0x3000
 
In this case, I'll search for a solution.

 

 

Again, Thanks.

 

Regards,

 

Alan

Share this post


Link to post
Share on other sites

Here are the patched dsdt/ssdt files.

 

 

Did you install Mountain Lion (or) still trying to install using myhack installer? I'm confused with your answers.

 

If you are still trying to install, then use the patched dsdt i sent to the USB Extra folder and remove the GraphicsEnabler flag from boot.plist if you have. And try to use these flags "-x -v" and let me know the error if you get.

 

Don't use the SSDT files yet. First, tell me whether you have installed Mountain Lion or not using myhack Installer?

DSDT_SSDT_Patched.zip

  • Like 1

Share this post


Link to post
Share on other sites

First of all, thanks for the patched dsdt/ssdt.

 

At this momento, yes, I'm still trying to install using myhack installer.

 

For better explanation, My current scenario is:

 

 

Internal HDD (MBR Partition Table) with Windows 8 using vmware to run a Mountain Lion system.

 

External HDD (Guid Partition Table) into VMware as physical. 

 

Using VMWare I made four HFS+ partitions:

 

  • Partition 1 - 10.8.3 installation created by MyHack withou modification and with Charmeleon.
  • Partition 2 - 10.8.3 System clean, installed by virtual Mac machine. Without vmware tools
  • Partition 3 - 10.8.3 clonne of the Partition 2 and I run; Generate Extra and Myfix by MyHack.
  • Partition 4 - Free space for installation.

 

this way, when I boot from external HD. I have two chances to boot.

 

 

Sorry for my english and thanks for your attention and help.

 

I'll test as soon as I can.

 

Regards,

 

Alan

Share this post


Link to post
Share on other sites

im not sure if my Hack plays nice with VM's

 

Bronxteck, I only uses VMWare to create a install boot disk.

 

 How is best way for me to do it?

Share this post


Link to post
Share on other sites

Here are the patched dsdt/ssdt files.

 

 

Did you install Mountain Lion (or) still trying to install using myhack installer? I'm confused with your answers.

 

If you are still trying to install, then use the patched dsdt i sent to the USB Extra folder and remove the GraphicsEnabler flag from boot.plist if you have. And try to use these flags "-x -v" and let me know the error if you get.

 

Don't use the SSDT files yet. First, tell me whether you have installed Mountain Lion or not using myhack Installer?

 

EMlyDinEsH,

 

 

I created USB boot with myhack and your dsdt. (Using vmware osx)
 
I Booted my A43E with this external drive and MyHack runs fine. I formatted a install area using diskutility and I run the install osx. At the end of install, OSX shows a error, informing that install failed.

 

I thought in I create a install USB disk manually. What the basic kexts I need to replace?

 

 

Again, Thanks.

 

Regards,

 

Alan

Share this post


Link to post
Share on other sites

×