Jump to content
crc-error404

[04/03/2011] - D520 BIOS rework

Recommended Posts

I apply sleep fix , after Reboot. Wake Up Blackscreen . No Wlan , no Ethernet !

 

com.apple.boot.plist

 

 

 

 

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">'>http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>EthernetBuiltIn</key>

<string>Yes</string>

<key>Kernel Flags</key>

<string>pmVersion=21</string>

<key>SystemType</key>

<string>2</string>

<key>Theme</key>

<string>Default</string>

<key>Timeout</key>

<string>2</string>

<key>arch</key>

<string>i386</string>

</dict>

</plist>

 

 

 

 

smbios.plist

 

 

 

 

 

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>SMbiosvendor</key>

<string>Apple Inc.</string>

<key>SMbiosversion</key>

<string>MBP51.007E.005</string>

<key>SMboardmanufacter</key>

<string>Dell Inc.</string>

<key>SMboardproduct</key>

<string>D520</string>

<key>SMfamily</key>

<string>MacBookPro</string>

<key>SMmemspeed</key>

<string>667</string>

<key>SMproductname</key>

<string>MacBookPro5,1</string>

<key>SMserial</key>

<string>53HX14JD520</string>

</dict>

</plist>

Share this post


Link to post
Share on other sites

well those look fine... did you add the system password in bios. without that you get no video when machine wakes from sleep

 

 

Hey,

 

 

i testet with system Pw . I apply Sleep, Laptop go to sleep , but the Desktop is showing ( freeze ) . No Wake up , nothing, No Wlan no Ethernet. I thinking about a D520 Bios flash. The best way i think, a modified a08 dsdt.aml. I dont know ^^..... Im despair !

 

 

Edit : I testet again, now Wakeup works , but a lot of grafikBugs ^^hmpf !

Share this post


Link to post
Share on other sites

- using EDP 1.7

 

- n Preferences Panel > Security > General check

 

check:

 

* Use secure virtual memory

 

Now open up a Terminal, and run:

 

sudo pmset hibernatemode 0

 

sudo touch /var/vm/sleepimage

 

sudo rm /var/vm/sleepimage

 

 

Systempasswort is aktiv !

 

 

 

 

dont work.

 

http://www.osxlatitude.com/groups/d4xosx/wiki/e36a2/DSDT_Collection.html

 

Model / Bios A01 A03 A05 A06 A09 A10 A13 A15 A17

 

D520 OK

 

 

edp 1.7 dont work under d520 A08 . Wlan, Lan and Sleep all crap ! 3 Ways to Fix. Mod dsdt.aml for A08 , Downgrade a08 to a05 or Bios Flash. right, wrong ??????

 

sry for my english

Share this post


Link to post
Share on other sites

Hey,

 

Sorry to jump in here.. can you quickly summarize your problems ?

 

I have had 2 D520 that work pretty well (except for lan)

Share this post


Link to post
Share on other sites

Hey,

 

Sorry to jump in here.. can you quickly summarize your problems ?

 

I have had 2 D520 that work pretty well (except for lan)

 

 

 

Hi,

 

d520 a08

 

I install 10.6.0 Retail with Snowleopard Diskutility Restore first start up with Preboot / then Comboupdate 10.6.7

 

Cham. Bootloader rc5rr665

 

EDP 1.7

 

/edptool.command

 

Fixes and Kext

 

Systempasswort aktiv

 

Sleep dont work , Wlan, Lan !

 

 

 

 

@Bronxteck

 

 

Bobdamnit post a DSDT.aml for d520 ao8

 

http://forum.osxlati...on/page__st__20

Share this post


Link to post
Share on other sites

Sleep works great on my D520.

 

Using EDP 1.7 with the DSDT.aml from BIOS A05 (supposedly. works great for me)

 

 

Sleep commands from wiki gave me sleep. (Any way to mod that white password screen?! That would be cool!) SleepEnabler gave me hibernate. (Edit) I'm finding that if I set a hot-corner to sleep the display and use InsomniaX to prevent sleep on lid close and sleep the display before I shut my lid, moving the trackpad will automatically wake the display back up.

 

BCM44xx works great in Snow Leopard for me. (LAN) And my WLAN works great after applying a few patches.

 

Losing tap-click on the trackpad after waking up from sleep is the only downside. I have to go into the trackpad prefpane and uncheck and recheck it for it to work again. Not deal breaking. More of a minor annoyance.

Share this post


Link to post
Share on other sites

Sleep works great on my D520.

 

Using EDP 1.7 with the DSDT.aml from BIOS A05 (supposedly. works great for me)

 

 

Sleep commands from wiki gave me sleep. (Any way to mod that white password screen?! That would be cool!) SleepEnabler gave me hibernate. (Edit) I'm finding that if I set a hot-corner to sleep the display and use InsomniaX to prevent sleep on lid close and sleep the display before I shut my lid, moving the trackpad will automatically wake the display back up.

 

BCM44xx works great in Snow Leopard for me. (LAN) And my WLAN works great after applying a few patches.

 

Losing tap-click on the trackpad after waking up from sleep is the only downside. I have to go into the trackpad prefpane and uncheck and recheck it for it to work again. Not deal breaking. More of a minor annoyance.

 

 

very well ...thx .

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...