Jump to content
crc-error404

[04/03/2011] - D830 BIOS rework

Recommended Posts

So guys... because of D430 Bios which really good works i was also modding the D830 Bios too.

 

!!! WARNING - THERE ARE DIFFERENT BIOSES FOR NVIDIA AND INTEL - BE SURE YOU FLASH THE RIGHT BIOS BEFORE SOMETHING GOES WRONG !!!

 

Recover must be afaik the same like D430

 

Please try the recover function before flashing a modded bios

 

 

 

Changelog:

 

-----------------------------------------------------------------------------------------------

 

v. 0.2

 

added new D830-GMA BIOS please test because of the AHCI errors

 

added new D830-NVIDIA BIOS please test because of the AHCI errors

 

-----------------------------------------------------------------------------------------------

 

v. 0.1

 

insert latest DSDT from 1.6 RC1 built

 

added D830-GMA BIOS

 

added D830-NVIDIA BIOS

 

changed splashscreen to new apple logo with black background

 

insert SLIC 2.1 for Windows 7 / Vista

 

changed Version from A15 to OSX :D

 

delete branding

 

-----------------------------------------------------------------------------------------------

 

 

DOWNLOAD BIOS FROM WIKI HERE

 

 

D830 still not tested - only attached version available !!!

recovery.zip

D830_OSX_GMA.zip

D830_OSX_NVIDIA.zip

Share this post


Link to post
Share on other sites

Hi,

just a short feedback: i tried the D830_OSX_GMA Bios.

update was ok (I started the update from a running win7 installation), dell logo is replaced by a fruit etc.

 

But when restarting win7 I get the windows error (bluescreen):

"The BIOS in this system is not fully ACPI compliant. Please contact your system vendor for an updated BIOS."

Starting with a dell win7 installation disk gives the same error.

 

The harddisk with osx 10.6.5 (and my dsdt.aml) started correctly.

Any ideas ?

 

Regards e.b

Share this post


Link to post
Share on other sites

Maybe u have to set hdd mode from ide to ahci within bios...

 

1) I used a ahci driver in win7 (in order not to change bios settings when switching the osx and win7 hdd)

2) I also toggled hdd mode, same result

 

regards

e.b

Share this post


Link to post
Share on other sites

Because of i have dont touched the sata mode section in bios i would prefere to flash back to oem bios in your case... Maybe if i have time i will look into bios next week im very busy atm...

 

so keep watching next week i'll release a new version.

 

cheers

Share this post


Link to post
Share on other sites

i had a blue screen with ACPI compliancy errors when booting win 7 using the nvidia A15 bios.

I reverted to the original one and no issues.

 

Could you make a howto on how to apply DSDT fixes and a changed logo to the A15 bios?

 

thank you for your work!

Share this post


Link to post
Share on other sites

i had a blue screen with ACPI compliancy errors when booting win 7 using the nvidia A15 bios.

I reverted to the original one and no issues.

 

Could you make a howto on how to apply DSDT fixes and a changed logo to the A15 bios?

 

thank you for your work!

 

sorry i will not make any tutorials because there are so many in the www. Btw changing the boot logo is a very difficult thing. Dont do that if u dont know how...

 

:D

 

Btw. added a new bios in first post. Try that one - but be warned - flashing at your own risk...

 

Tell me if it works. Thanks

 

Cheers

 

CRC

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...