Jump to content
lcsmdna

Someone please direct me to an appropriate guide...

Recommended Posts

I've been looking all day for a guide to installing Snow Leopard onto my d630.

I DO NOT HAVE NVIDIA, it is the intel graphics 1200x800 model d630 with Intel Core 2 Duo.

I also do not have access to another system with OSX already on it, so I haven't been able to follow the official guide on this site.

I have the Snow Leopard Retail disk, and I even tried using iboot (chameleon, stolen and rebranded) and following a guide on tonycrapx86. Nothing has worked....I have used countless bootflags, and none of them let me get to the install screen. My other computer has Windows 8 so I can't do any of the "Disk Utility" stuff.

Can someone please help me get OSX installed on my machine? Thanks. This is getting really frustrating.

 

 

Here's what happens with every install attempt:

- I put in iboot (chameleon, stolen and rebranded)
- I switch to the Snow Leopard Disk
- F5, Press enter, bam
- Apple logo (sometimes with the spinning loader on the bottom, sometimes not)
- After about 20 seconds, the computer screen either: Freezes, goes entirely black, or goes entirely white.

Any help would be hugely appreciated.

Edited by lcsmdna

Share this post


Link to post
Share on other sites

https://osxlatitude.com/index.php?/topic/2880-d420-video-issues-w-multiple-osx-versions-what-am-i-doing-wrong-here/&do=findComment&comment=22054

 

Links to ModCD are in a few posts up in that thread.

 

Once you're done, read-up the EDP pages of this web site and visit myHack's site too.

 

I burned ModCD to a CD and tried booting with mach_kernel (didn't work). Then I tried -v (gave errors then rebooted). Then I tried -x (went through all the kexts, then gave a description of what happened, then rebooted). Didn't even make it to the Apple logo this time.

Share this post


Link to post
Share on other sites

There's a pinned thread dedicated to BIOS settings at the very top of the D6xx section. -_-

 

Remember: you need a retail SL DVD (10.6.0 and10.6.3, possibly10.6.8), not a disc that came with a Mac or a recovery disc. Alternatively you can use a USB key/external HDD that has the installation image restored to it (but that would require a Mac or a Hack to achieve).

Share this post


Link to post
Share on other sites

This should be all over the place as we keep repeating it on and on, but Intel wireless cards are not supported and can cause Kernel Panics. As such, if you have one, disable it in BIOS or, better, remove it completely. Those cards have got to go and be replaced by Mac OS compatible cards (there's a non-exhaustive listed published in Research section of the forum).

Share this post


Link to post
Share on other sites

There's a pinned thread dedicated to BIOS settings at the very top of the D6xx section. -_-

 

Remember: you need a retail SL DVD (10.6.0 and10.6.3, possibly10.6.8), not a disc that came with a Mac or a recovery disc or a USB key/external HDD that has the installation image restored to it (but that would require a Mac or a Hack to achieve).

 

This is a retail 10.6.0 SL DVD.

 

Also, all my Bios setting match with the pinned post, so that wasn't the problem.

 

I tried booting by default, booting with -v, booting with -x, and booting with mach_kernel.

 

Results:

 

For each boot, it always says "Errors encountered while starting up the computer. Pausing 5 seconds". Then it gives a summary, and says "Press q to continue."

 

With mach_kernel, after I press q, it gets stuck at "AirPort: Link Down on en1. Reason 1 (Unspecified)."

 

If I boot with -x, after I press 'q', the laptop reboots. 

 

If I boot with -v, after I press 'q', the laptop reboots. 

 

If I boot by default without any boot flags, after I press 'q', the laptop reboots. 

 

Any ideas?  :(

Share this post


Link to post
Share on other sites

I'll try it later on on my own D630 Intel. But I can 100% confirm it works because that is how I started on the D630 all those moons ago. What wireless card do you have in that laptop?

Share this post


Link to post
Share on other sites

Ok, just did a fresh install with Nawcom's ModCD + retail 10.6.0.

 

You need:

  • ModCD on CD or DVD
  • Retail SL DVD or USB key with retail SL image restored to it
  • a small USB key (for the D630 intel LoRes bootpack)
  • an external screen with VGA cable (for 1st reboot)

 

Here's what to do:

  1. boot ModCD
  2. swap discs and press [F5]
  3. select Mac OS X Install DVD and press [ENTER] (this will boot with default legacy kernel, but it's Ok)
  4. select your desired language and click right arrow at the bottom
  5. at main install screen, click on language flag at top right corner and choose the appropriate input source that matches your keyboard
  6. Click on Utilities in top menu bar and select Disk Utility
  7. create your GUID/Mac OS Extended (journaled) partition on your HDD, then exit Disk Utility, click Continue, then Agree
  8. at main installation screen, click on your target SL HDD partition to select it, then click Customize button
  9. in the displayed list, unselect Printer Support/Additional Fonts/Addtional Languages (unless you want to add another one) and leave the rest unchanged. Then, click Ok.
  10. Click Install to proceed with installation on your target SL partition. This will take approximately 20minutes.

Once installation completes, you will be prompted to Restart (will do it automatically after 60s). Attach an external display, you're going to need it.

 

When reboot starts:

  1. force display output to the external screen by pressing [Fn-F8] key combination. If you do not do that, you'll always end-up with blackscreen when the Snow Leopard Welcome tune plays.
  2. interrupt bootstrap and specify boot option GraphicsEnabler=No (mandatory on D630 X3100 LoRes 1280x800 to avoid LCD garbage; not required at all on D630 X3100 HiRes 1440x900).

You'll see the boot process on the external screen, then, right at the time when the system switches to Mac OS X desktop, the display will automatically swap back to built-in LCD. The Welcome video will play accompanied by the Welcome tune. Then finish off 1st boot installation.

 

Basically, SL will boot to blackscreen without this trick due to lack of proper info about the built-in LCD in the BIOS DSDT. As such, you need to use our patched DSDT table:

  1. download our bootpack from a Windows PC and place it on a FAT-formatted USB key
  2. connect that key to your D630 running SL (i.e. once it has booted into SL as per above process)
  3. copy the DSDT file to /Extra

From there on, you will be able to reboot your D630 straight into Snow Leopard (with full graphics support) and without the external screen trick.

 

Next, you need to finalise your D630 installation (audio, network, BT, etc.) and probably update to SL 10.6.8:

  1. download the 10.6.8 Combo update off Apple's web site
  2. download myHack 3.1.2 off the Net
  3. download EDP package off EDP pages of OSXLatitude website

 

  • Delete VoodooHDA from /System/Library/Extensions. It was placed there by ModCD, but causes KP when booting 10.6.8
  • Run myHack 3.1.2 and:
  1. Install Extra->Use my own, pointing to our bootpack that you've previously placed on a USB key
  2. Install myHack utilities
  • If you have Internet connection, run EDP package to install it, then launch EDP and do a system build, using pre-selected options. If you don't have Internet connection, reboot and repeat this operation (with bootpack installed at previous step (myHack), you'll have your Ethernet connection working after reboot)
  • Run and apply 10.6.8 Combo Update

 

-> You may now reboot into SL 10.6.8 and enjoy full vanilla Snow Leopard!

 

NB: at that stage, you can make an image of your retail DVD. This can subsequently be restored to a USB key on which you can also apply ModUSB + our bootpack/DSDT. That then provides you with a single bootable USB key that allows you to install SL completely from scratch and a bit quicker too.

Share this post


Link to post
Share on other sites

Still not working...I tried my friend's 10.6.3 retail DVD (did NOT come with Mac), and it had the same result.

I'm not sure what the wireless card is, it is inside the laptop (integrated I think). Should I disable WiFi in Bios or not?

Before it gets to the ModCD screen where you switch to SL DVD, it says "Reading ramdisk image: /Extra/Preboot.dmgError parsing plist file.

Maybe this is the problem?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...