Jump to content
crc-error404

[03/03/2011] - D430 BIOS rework

Recommended Posts

I guess I should join the happy apple logo bios community to :)

I'm using the non dsdt version.

 

You are all safe to flash as long as you are using the Dell flasher included in first post.

Share this post


Link to post
Share on other sites

Hi guys,

if I want to run my D430 without DSDT, I presume the right BIOS is in the file D430_NO_DSDT.zip. Correct?

What is in D430_OSX-zip?

THX!

Share this post


Link to post
Share on other sites

No Bios with DSDT insert is BIOS_OSX with no DSDT in Bios is BIOS_NO_DSDT

 

So if u don't want have DSDT in EXTRA Folder flash BIOS_OSX

 

btw... DSDT is from EDP1.5 RC5 so not the latest... new BIOS comes with next stable release from EDP...

Share this post


Link to post
Share on other sites

OK, thanks CRC! Danke!

Should I wait for a new release? Or, in other words: what am I missing if I run BIOS with DSDT from EDP 1.5RC5 vs. 1.5RC6?

Also, if I replace my BIOS with your version, do I need to go back and use EDP1.5RC5 /Extra, kexts, plists and such? Or is safe to use those for EDP1.5RC6?

 

Sorry for so many questions, but I am kinda desperate to fix my D430 issues and don't want to add some new.

THX!

Share this post


Link to post
Share on other sites

Its safe u can use Extra from RC6 and DSDT from the Bios... There shouldn't be so much changes between this versions...

 

Btw. if u have a dsdt in Extra this DSDT will overrule the dsdt from Bios... So its only really helpful for first installation

 

Bitte :D

Share this post


Link to post
Share on other sites

OK, here an update:

- Replaced BIOS A09 with D430_OSX BIOS, no problem

- In BIOS checked all config items needed (internal graphics, USB wake "off" and such)

- boot from HD successful for the first time! (No KP - yes!!!)

 

Issues so far:

* internal keyboard and trackpad do not work (tried applePS2, voodooPS2 but no go)

* graphic resolution 1024x768 whatever I do. I do have correct resolution 1280x800x32 in my com.apple.boot.plist

(it appears correct when apple logo and the wheel (progress indicator) are on, but as soon as login appears resolution becomes 1024x768)

* no sound

* i still cannot change my hibernation setup for proper work of sleep

both, terminal command and edptool, option 2 - Fixes, then option 2, are showing "Error 0xe00002bc writing customized power profiles to disk"

 

I just took Leons D430 /Extra folder, removed DSDT and made an reboot. Apple logo (different than the one I usually see. (it's gray in 2D instead plastic 3D light gray look) stays on for ages and the wheel is moving slowly, but almost not moving at all. Booted verbose. It freezes at "WARNING - LPC device initialization failed: C-state power management not initialized". (I cannot attach screenshot. Apparently my account does not allow another upload).

 

Well, that's the status. Booting with files configured on my own machine - Issues above

Booting with Leon's D430 working config freezes.

 

OK, apparently in all cases there are issues. Somehow it seams to me that power management or parts of it are involved. That still does not explain why I cannot boot from HD, if I am using vanilla BIOS. With CRC's modified BIOS I can boot from disk but have no sound, wrong graphics resolution and sleep issues.

 

Any ideas?

THX

 

 

EDIT: I made an error. Prior booting with Leon's files, I forgot to rename /Extra.Leon into /Extra. So, boot was without /Extra folder. Hence, it freezes. Now I corrected this and Leon's /Extra gives me KP right on the start. CPU not recognized or such.

I run edptool in Leons /Extra folder and will reboot again. New config, all fixes and permission rebuild.

Share this post


Link to post
Share on other sites

Use the latest RC (5 or 6) leave the dsdt in Extra folder...

 

run edptool.command and do all your settings...

 

run tool again - but now go to fix option and do the touch thing...

 

reboot - takes a little bit longer...

 

should solve your problem

 

if it works delete/move dsdt and reboot again

Share this post


Link to post
Share on other sites

Use the latest RC (5 or 6) leave the dsdt in Extra folder...

 

run edptool.command and do all your settings...

 

run tool again - but now go to fix option and do the touch thing...

 

reboot - takes a little bit longer...

 

should solve your problem

 

if it works delete/move dsdt and reboot again

No luck. I did like you suggested a few times with different configurations but same result: booting from HD I have wrong resolution, no sound, no keyboard no trackpad. But at least I am a step further - I can boot from HD! Booting fully identical configs from the USB gives me no such issues. However, there are still some others (sleep and such).

 

CRC, I would like to kindly ask you to join this thread: https://osxlatitude.com/index.php?/topic/147-d430-1066/

It is the actual the thread I started when I run into my issues. I hijacked this thread only because I needed your D430_OSX BIOS.

It would make my life a bit easier: I would need to write all my posts regarding those issues just in one thread. So: please!

 

Vielen Dank für Deine Unterstützung!

 

THX!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...