Jump to content
yjbyf

DELL E6430 with Nvs 5200m - sleep problem

Recommended Posts

My spec:

Latitude E6430, BIOS A12 | i5-3320M 2.6GHz | 4GB DDR3 | nVidia NVS 5200M 1024 MB | Rebranded Dell DW1510 | Mavericks 10.9.1

 

I used the Extra-folder provided by Jake Lo to make it work except sleeping.

 

Everytime the laptop went to sleep, I couldn't wake it up by pressing the keyboard and mouse. The only way to make it work is to pressing the power button to restart my computer.

 

Is there any solution for my problem? Thanks a lot.

Share this post


Link to post
Share on other sites

My spec:

Latitude E6430, BIOS A12 | i5-3320M 2.6GHz | 4GB DDR3 | nVidia NVS 5200M 1024 MB | Rebranded Dell DW1510 | Mavericks 10.9.1

 

I used the Extra-folder provided by Jake Lo to make it work except sleeping.

 

Everytime the laptop went to sleep, I couldn't wake it up by pressing the keyboard and mouse. The only way to make it work is to pressing the power button to restart my computer.

 

Is there any solution for my problem? Thanks a lot.

Did you follow my guide with the nvidia optimus? It specifies that sleep won't work

Sleep does not work, so make sure to turn it off otherwise you'll have to hard shutdown/reboot system

Share this post


Link to post
Share on other sites

 

Did you follow my guide with the nvidia optimus? It specifies that sleep won't work

Sleep does not work, so make sure to turn it off otherwise you'll have to hard shutdown/reboot system

Yep, I turned off optimus in bios setting. 

 

BTW: Is it possilbe  to disable the nvidia videocard by editing the dsdt file? 

Share this post


Link to post
Share on other sites

 

 

Did you follow my guide with the nvidia optimus? It specifies that sleep won't work

Sleep does not work, so make sure to turn it off otherwise you'll have to hard shutdown/reboot system

Yep, I turned off optimus in bios setting. 

 

BTW: Is it possilbe  to disable the nvidia videocard by editing the dsdt file? 

 

Yes, I have a work-in-progress dsdt to disable nvidia for E6530/E6430 while Optimus is enabled. But after a reboot, Optimus gets disabled in BIOS and system won't boot. I have to go in the BIOS and re-enable Optimus again. This doesn't happen when I shutdown, then boot up again. With this DSDT, I'm able to get sleep with HD4000.

Share this post


Link to post
Share on other sites

Yes, I have a work-in-progress dsdt to disable nvidia for E6530/E6430 while Optimus is enabled. But after a reboot, Optimus gets disabled in BIOS and system won't boot. I have to go in the BIOS and re-enable Optimus again. This doesn't happen when I shutdown, then boot up again. With this DSDT, I'm able to get sleep to work with HD4000.

How did you edit your dsdt file?

I found the method of "_ON","_OFF" under  "Scope (\_SB.PCI0.PEG0.VID)" in file "SSDT-7.aml".

I also found  the method who call them are "_PS0" and "_PS3"  at the same place.

I suggest that I should copy these method to node of  "Scope (_SB.PCI0.PEG0.VID)" in file "DSDT.aml", then add calling of  "_PS0" and "_PS3" to "Method (_WAK, 1, Serialized)" and "Method (_INI, 0, NotSerialized)".

Is it a possible way out?

I'll try it when I have some time. 

Share this post


Link to post
Share on other sites

How did you edit your dsdt file?

I found the method of "_ON","_OFF" under  "Scope (\_SB.PCI0.PEG0.VID)" in file "SSDT-7.aml".

I also found  the method who call them are "_PS0" and "_PS3"  at the same place.

I suggest that I should copy these method to node of  "Scope (_SB.PCI0.PEG0.VID)" in file "DSDT.aml", then add calling of  "_PS0" and "_PS3" to "Method (_WAK, 1, Serialized)" and "Method (_INI, 0, NotSerialized)".

Is it a possible way out?

I'll try it when I have some time. 

Correct. Let us know how that goes.

Share this post


Link to post
Share on other sites

Correct. Let us know how that goes.

I didn't find the method of "_INI" but "_WAK", so I add "_OFF" at the start of method "_WAK" to disable nvs card.

Then I restarted with arguments "-f" and I read the log gotten by command "dmseg".

I found that the nvs card was detected by osx and the driver of it was loaded.

The battery status icon at the top of status bar also disappeared. 

Share this post


Link to post
Share on other sites

I didn't find the method of "_INI" but "_WAK", so I add "_OFF" at the start of method "_WAK" to disable nvs card.

Then I restarted with arguments "-f" and I read the log gotten by command "dmseg".

I found that the nvs card was detected by osx and the driver of it was loaded.

The battery status icon at the top of status bar also disappeared. 

Did you have Optimus enabled and able to boot? Did it load HD 4000?

Share this post


Link to post
Share on other sites

Here is my edited dsdt file.

I added a PINI method which calls \_SB.PCI0.PEG0.VID._OFF().

Then I added this method to both begin of Method (_WAK, 1, Serialized) and begin of Method (_INI, 0, NotSerialized).

 

The test result is following:

1.The optimus option is disabled: The boot screen with -v option will run into a black blank screen while the disk is still reading. It seems that nv card is really ignored by dsdt and the intel hd4000 video card is not recognized.

 

2.The optimus option is enabled: The boot screen with -v option will run into a panic screen where it says the intel cpu driver gets error in loading.

dsdt_nonv.aml.zip

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...