Jump to content
nnware

Audio (ALC292) sometimes works, sometimes doesn't work

Recommended Posts

My laptop's audio codec is ALC3232 in windows8.

it shows ALC292 in Ubuntu.

 

I'm using patched AppleHDA for ALC292.

It was downloaded from this topic.

https://osxlatitude.com/index.php?/topic/5857-e6540/

 

It almost works fine but it sometimes doesn't start working.

After restart, It randomly starts working or not.

After rebuild a kextcache and restart, It works.

But This problem happens again randomly.

 

How can I fix it?

 

And, When the audio is working, Internal Speakers and Mic work fine but Headphones out makes just white noise.

 

 

EDIT:

 

VooDooHDA 2.8.4(need to modify info.plist) is fully working with ALC292.

Also Headphone/Mic Combo Jack works fine.

 

EDIT2:

VoodooHDA 2.8.5 works without modified plist.

 

with VoodooHDA, Internal Speaker does not work after wakeup from sleep.

Headphone and mic work after wakeup.

 

with Patched AppleHDA, Internal Speaker works after wakeup from sleep.

but headphone doesn't work.

 

EDIT3:

Problem is solved.

https://osxlatitude.com/index.php?/topic/6269-t440s-cant-fix-dsdt/page-5&do=findComment&comment=38034

Share this post


Link to post
Share on other sites

Post your hardware settings as displayed by Terminal command lspci -nn (needs lspcidrv kext loaded) to confirm your exact specs.

Share this post


Link to post
Share on other sites

Thank you for reply.
 
After remove HDAEnabler, Audio Device almost works now.
But I still can't fix problem on Headphones out.

$ lspci -nn
pcilib: 0000:04:00.0 64-bit device address ignored.
pcilib: 0000:04:00.0 64-bit device address ignored.
pcilib: 0000:00:02.0 64-bit device address ignored.
00:00.0 Host bridge [0600]: Intel Corporation Unknown device [8086:0a04] (rev 0b)
00:02.0 VGA compatible controller [0300]: Intel Corporation Unknown device [8086:0a16] (rev 0b)
00:03.0 Audio device [0403]: Intel Corporation Unknown device [8086:0a0c] (rev 0b)
00:14.0 USB controller [0c03]: Intel Corporation Unknown device [8086:9c31] (rev 04)
00:16.0 Communication controller [0780]: Intel Corporation Unknown device [8086:9c3a] (rev 04)
00:16.3 Serial controller [0700]: Intel Corporation Unknown device [8086:9c3d] (rev 04)
00:19.0 Ethernet controller [0200]: Intel Corporation Unknown device [8086:155a] (rev 04)
00:1b.0 Audio device [0403]: Intel Corporation Unknown device [8086:9c20] (rev 04)
00:1c.0 PCI bridge [0604]: Intel Corporation Unknown device [8086:9c1a] (rev e4)
00:1c.1 PCI bridge [0604]: Intel Corporation Unknown device [8086:9c14] (rev e4)
00:1c.4 PCI bridge [0604]: Intel Corporation Unknown device [8086:9c18] (rev e4)
00:1d.0 USB controller [0c03]: Intel Corporation Unknown device [8086:9c26] (rev 04)
00:1f.0 ISA bridge [0601]: Intel Corporation Unknown device [8086:9c43] (rev 04)
00:1f.2 SATA controller [0106]: Intel Corporation Unknown device [8086:9c03] (rev 04)
00:1f.3 SMBus [0c05]: Intel Corporation Unknown device [8086:9c22] (rev 04)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Unknown device [10ec:5227] (rev 01)
03:00.0 Network controller [0280]: Intel Corporation Unknown device [8086:08b2] (rev 83)
04:00.0 VGA compatible controller [0300]: NVIDIA Corporation Unknown device [10de:1290] (rev a1)

Share this post


Link to post
Share on other sites

Woaw, never seen such a report with all hardware reported as "unknown device"... What system is this?

 

Haaa... Haswell platform...

 

You need to update your local pci database (sudo update-pciids).

Share this post


Link to post
Share on other sites

Yes, My laptop has Haswell i7 4600U. Model is Thinkpad T440s.
Is lspci not compatible with haswell platform?
 
And 'Headphones out' is Headphone/Mic combo jack.
It maybe cause of problem.
I'm looking for how to edit AppleHDA or DSDT for Headphone/Mic combo jack.

Share this post


Link to post
Share on other sites

Yes, My laptop has Haswell i7 4600U. Model is Thinkpad T440s.

Is lspci not compatible with haswell platform?

 

And 'Headphones out' is Headphone/Mic combo jack.

It maybe cause of problem.

I'm looking for how to edit AppleHDA or DSDT for Headphone/Mic combo jack.

upload your codec here, i can help you fix it.

Share this post


Link to post
Share on other sites

My laptop's audio codec is ALC3232 in windows8.

it shows ALC292 in Ubuntu.

 

I'm using patched AppleHDA for ALC292.

It was downloaded from this topic.

https://osxlatitude.com/index.php?/topic/5857-e6540/

 

It almost works fine but it sometimes doesn't start working.

After restart, It randomly starts working or not.

After rebuild a kextcache and restart, It works.

But This problem happens again randomly.

 

How can I fix it?

 

And, When the audio is working, Internal Speakers and Mic work fine but Headphones out makes just white noise.

 

 

EDIT:

 

VooDooHDA 2.8.4(need to modify info.plist) is fully working with ALC292.

Also Headphone/Mic Combo Jack works fine.

 

I have the same card.  Could you please explain how you edited the info.plist or post the working kext?  Thanks

Share this post


Link to post
Share on other sites

I have the same card.  Could you please explain how you edited the info.plist or post the working kext?  Thanks

 

I changed two lines below.

 
<key>IOPCIClassMatch</key>
<string>0x04030000&0xffff0000</string>
 
to
 
<key>IOPCIPrimaryMatch</key>
<string>0x9C208086</string>
 
In my case, Device ID is 9C20. Vender ID is 8086.
You should check your device ID and vender ID by lspci or DPCIManager.app.
And remove or disable AppleHDA.kext.

Share this post


Link to post
Share on other sites

 

I changed two lines below.

 
<key>IOPCIClassMatch</key>
<string>0x04030000&0xffff0000</string>
 
to
 
<key>IOPCIPrimaryMatch</key>
<string>0x9C208086</string>
 
In my case, Device ID is 9C20. Vender ID is 8086.
You should check your device ID and vender ID by lspci or DPCIManager.app.
And remove or disable AppleHDA.kext.

 

 

Thank you for your reply.  I will give it a try.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...