Jump to content

Yosemite 10.10.0 E6530 Help from Someone who has already done


Analyzer
 Share

Recommended Posts

Hi,

 

I understand Yosemite is still in beta but I would like to know please if someone has successfully created an OSX86 on E6530        or similar laptop. I have created the installer using some of the tutorials online but I am unable to boot the installer I am loading the kexts but getting errors I have not encountered before like

 

it sort of crashes here:

..... service only ran for 0 seconds. pushing respawn out by 10 seconds

 

Can someone please guide me also please share any kexts.zip that you think might help.

 

Thank you

Link to comment
Share on other sites

Hi Jake and Cew
 
Thanks for the response. My apology, I fixed my signature I am currently running 10.9.4 on my E6530
 
Here are the exact steps I did.  vt-D option is already disabled. I am using Chameleon and I need to use Chameleon not Clover for a specific reason:
1-I have just downloaded "Install OS X Yosemite Beta" This is beta 3 for the App Store and was installed in my Applications folder.
2- I had to rename it to "Install OS X 10.10 Developer Preview" in order for "Boot USB OS X Yosemite(Chameleon r2380).pkg" to work.
 
I sort of followed this: http://www.hackintoshosx.com/files/file/4093-boot-efi-os-x-yosemite-chameleon-r2380/
 
I believe now its about the kexts that I have in my /Extra/Extentions they make a big deal and I just need to get the right ones with the right combination to get it to boot. At the moment there are so much errors during the boot time that is going fast then it gets stuck at the end.
 
Where do I find the boot log so I can show you. I think if you can share the Extentions for the E6530 it might help me out I hope.
 
Please let me know if I should try something else, I use this machine for development and I'll need to keep investigating it until I get it to work for Yosemite.
 
Thank you.

Link to comment
Share on other sites

  • Moderators

That's an old guide, you don't need mach_kernel anymore, using default /system/library/kernels/kernel

Try this new guide here by same member.

Ok, after creating the installer, use attached bootpack replacing /Extra in the installer

Use kexwizard.app to install FakeSMC, AppleIntelFramebufferCapri, AppleHDA, and VoodooPS2Controller from /Extra/Extension to /S/L/E of the installer

 

Ok, I see you have a discrete card nvidia nfs 5200m as I do, so the question is, do you want to use the nvidia or the Intel HD 4000? 

Only one or the other, not both. 

I defaulted the file to nvidia, so in the BIOS, make sure to disable Optimus under video.

If you prefer the Intel, then enable Optimus in the BIOS. Change the org.chameleon.boot.plist to point the DSDT to /Extra/dsdt-off.aml

This should get you started.

 

/!\ files are for Yosemite Public Beta 3, might not work for anything else.

 

Extra.zip

Link to comment
Share on other sites

Thanks Jake and pokenguyen.

 

Thats right I need to use Chameleon unless I can use Clover without using EFI!. 

 

Ok I didn't know what to respond with for couple of days cuz I was going crazy as I was getting too many errors during the boot process even though I was doing everything right. There was too many things not loaded at all part of the OS and going really fast.

 

The problem was not the Extra files nor the fact that I was using Chameleon vs Clover.

 

I resolved my major booting issue by pure accident and serious persistence as I came to this site http://www.niresh.co/hackintosh-downloads/category/6-kernel/ downloaded the kernel for Mach_Kernel Beta 3 14A361P and replaced the vanilla one. 

 

Actually I had initially used the files from the link you sent me here  not the one I initially posted. I still used Boot USB OS X Yosemite(Chameleon r2380).pkg to create the bootable partition which is pretty good. Then ofcourse I replaced the kernel.

 

1- Please kindly explain to me why I needed to download a patched kernel !! this was so frustrating, I didn't need to do this for 10.9.x and I thought with newer hardware we can go with a vanilla mac kernel !.

 

2- My problem is still not over I am almost there, for some reason the screen goes black after loading all kexts and when its about to get into the OS right after I see:

NVDAStartup: Official

....................................

NVDAGF100HAL loaded and registered <---- where is this coming from !

DSMOS has arrived...

 

It will work fine if I enable Optimus which I don't want to do, I need to use NVidia as usual.

 

3- Finally https://osxlatitude.com/index.php?/topic/6372-dell-latitude-5x30-6x30-clover-install-guide/  is a good link too. However can I use Clover without booting from EFI, can I use Clover with MBR like Chameleon

 

Please kindly help me with the black screen issue, I tried a lot of things,  I have already tried all sorts of boot flags like GraphicsEnabler=Yes. Perhaps there are kexts that I need to delete? 

 

Thanks you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...