Jump to content
nicksilverstein

Dell Optiplex 755 Graphics Card Issue?

Recommended Posts

I have a Dell Optiplex 755. I have a Nvidia Geforce GT 630. I also have a Nvidia Geforce 8400 GS lying around.

 

I go and make the install with myHack. Then I go and try to boot up it on my dell Optiplex 755 with the NV 630, and I shows the gray apple screen then my display says no signal.

 

What should I do?

Share this post


Link to post
Share on other sites

1st of all, I'd check the graphics option in BIOS (built-in or PEG) and use Chameleon option GraphicsEnabler=Yes. If you keep getting black screen, boot in safe mode and you should reach desktop.

 

Then, I strongly recommend you verify the default value of your PCI root (on several Dell systems, I've noticed it was not set to 0 or 1 but to 4 for instance). This can usually be obtained though Terminal command: ioreg -l | grep -15 "AppleACPIPCI\ " | grep UID.

 

Lastly, try and boot without any DSDT file to be able to extract your raw table from BIOS (default PCI root value can be found there under Device (PCI0) section by the way) + save a raw IOReg output; this would allow to patch your DSDT table with all the right data re: graphics card.

Share this post


Link to post
Share on other sites

It still says DVI no signal. I tried PCIRoot=4, PCIRootUID=4, and GraphicsEnabler=Yes.

 

I have try every combination of the above.

 

I have tried it with the 8400 GS and the GT 630. Both have the same problem. But, it works with Windows fine. So, the Graphics Card is not defective.

 

The only way I could get the Graphics to display on the screen was by deleting NVStartup.kext from S/L/E. But there is no QE/CI. And that is a Problem.

 

What can I try? I am open to anything. I would be great if I could get Mac OS X working with is DELL.

Share this post


Link to post
Share on other sites

PCIRootUID would be same as PciRoot option but the Chameleon options are case sensitive, so no PCIRoot and I've never used PCIRootUID. Type a ? at Chameleon bootloader and you'll see the list of options...

 

Try and boot in safe mode or without NVStartup kext to attempt DSDT extraction (or do it from Windows) and obtain a saved IOReg output too. This way, we can try and patch your DSDT. This means you must boot OS X without any existing DSDT file.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...