Jump to content
peluko

E6420 - El Capitan - Can't boot from HDD

Recommended Posts

Hello.

 

I've managed to install El Capitan on my E6420 (i5-2520M, HD3000, 1600x900). For now what I've done is to follow the Clover guide on this forum (https://osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-el-capitan-clover-guide/&do=findComment&comment=54621). I've used E6220 settings, and to support 1600x900 panel I've modified DSDT to enable DualLink, and for audio I've had to install VoodooHDA.

By now it's working fine, but with a problem: I can't manage to boot Clover from the internal HDD, I have to boot from the installer USB. The installer USB is MBR formatted, and the internal HDD is GUID (it has to be GUID to install OSX). I've tried to:

 

- Install Clover in legacy mode

- Install Clover in UEFI

- Create a UEFI entry in the BIOS

 

And I can't boot. When it says 'attempted to boot UEFI volume from legacy mode' I try to boot UEFI (creating an entry in the BIOS) but then it says that can't find a boot device. And if I use F12 to select the UEFI entry, it goes black and never boots.

 

Any hints?

 

Thanks.

Share this post


Link to post
Share on other sites

Install Clover with the following settings:

  • Install Clover in the ESP
  • Bootloader/Install boot0af in MBR
  • CloverEFI/CloverEFI 64-bits SATA

Share this post


Link to post
Share on other sites

Hello Jake. I've done so, as this is what you say on your guide. But it can't boot, the disk is not detected as bootable. When I do this installation I get an empty EFI partition and an EFI folder on the OSX hd root.

 

It's driving me crazy. I've been looking if BIOS has some settings that protects MBR or something so, but I don't find anything useful.

Share this post


Link to post
Share on other sites

Hello again Jake. BIOS is set to Legacy and AHCI (I can boot El Capitan on SSD using the install USB). I can't find anything about Secure Boot on my BIOS. More ideas?

 

Thanks.

Share this post


Link to post
Share on other sites

Hello again. I've found the solution. My disk was formatted using CoreStorage (it seems to be the default, for supporting FusionDrive), and it has to be disabled in order to boot in Legacy mode.

The solution was to revert it:

 

diskutil corestorage revert /dev/disk1

 

/dev/disk1 is a virtual disk created for corestorage, the physical disk is /dev/disk0.

 

Thanks anyway!! Now I have to activate bluetooth, let's go!

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...