Jump to content
offficial_florin

macOS on Latitude 7370

Recommended Posts

Just out of curiosity: Has anyone of you ever tried to install macOS on a Dell Latitude 7370?

 

I want to buy it and replace my E7450 with it but before I want to be sure if macOS works on it because on my E7450 it works better than on a MacBook Pro!

Share this post


Link to post
Share on other sites

I don't think there's graphics support (HD 515)for Core M processor, you might want to go for the E7270 with the "I" processor (HD520) if you prefer the smaller size laptop.

Share this post


Link to post
Share on other sites

'should be supported because that's what the MacBook 2016 models are based on: Core m3/m5/m7 with integrated Intel HD Graphics 515.

 

It's a pretty slick machine IMO, especially with the HiRes option but I guess performance won't be that great with those little Core m CPUs...

Share this post


Link to post
Share on other sites

My apologies for not doing a better research. Thanks Hervé. It would be interesting to see how well it'll run MacOS on it. 

Share this post


Link to post
Share on other sites

Hey folks, I've been tinkering with one of these for a while. I have OS X running on it without working graphics or wifi. I've purchased a BCM94352Z, but haven't made progress to making it work. I've been working on the graphics though, and I cannot get it working! It is driving me up the wall! I have the DVMT preallocated at 64MB and everything! The HD515 graphics are finicky I guess. Does anyone have any suggestions? Thanks!

Share this post


Link to post
Share on other sites

Yes: 

FakeID kexts + 0x19020001:  rebooted
FakeID kexts + 0x19120000:  â€œFailed to initialize graphics firmware†+ reboot
FakeID kexts + 0x19120001:  rebooted
FakeID kexts + 0x19130001:  Booted fine, without QE (with core image though!)
FakeID kexts + 0x19160000:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
FakeID kexts + 0x19160002:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
FakeID kexts + 0x19170001:  rebooted
FakeID kexts + 0x191b0000:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
FakeID kexts + 0x191E0000:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
FakeID kexts + 0x191E0003:  rebooted
FakeID kexts + 0x19260000:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
FakeID kexts + 0x19260002:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
FakeID kexts + 0x19260004:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
FakeID kexts + 0x193b0000:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
FakeID kexts + 0x193b0005:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
FakeID kexts + 0x193b0006:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo

0x19020001:  â€œwill fallback to host side scheduling if gr†+ freeze 
0x19120000:  â€œFailed to initialize graphics firmware†+ reboot
0x19120001:  IOPCIFamily KP / rebooted
0x19160000:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
0x19160002:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
0x19170001:  IOPCIFamily KP / rebooted
0x191b0000:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
0x191E0000:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
0x191E0003:  rebooted
0x19260000:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
0x19260002:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
0x19260004:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
0x19320001:  IOPCIFamily KP / rebooted
0x193b0000:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
0x193b0005:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo
0x193b0006:  â€œFailed to initialize graphics firmware†+ glitchy screen without Apple logo

I have not injected any IntelGFX ids tho

Share this post


Link to post
Share on other sites

MacBookPro11,1
 
config:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>ACPI</key>
<dict>
<key>DSDT</key>
<dict>
<key>Debug</key>
<false/>
<key>DropOEM_DSM</key>
<false/>
<key>Fixes</key>
<dict>
<key>FixRegions_10000000</key>
<true/>
<key>NewWay_80000000</key>
<true/>
</dict>
<key>Name</key>
<string>DSDT.aml</string>
<key>Patches</key>
<array>
<dict>
<key>Comment</key>
<string>change EHC1 to EH01</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
RUhDMQ==
</data>
<key>Replace</key>
<data>
RUgwMQ==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change EHC2 to EH02</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
RUhDMg==
</data>
<key>Replace</key>
<data>
RUgwMg==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change EHC1 to EH01</string>
<key>Find</key>
<data>
RUhDMQ==
</data>
<key>Replace</key>
<data>
RUgwMQ==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change MEI to IMEI</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
TUVJXw==
</data>
<key>Replace</key>
<data>
SU1FSQ==
</data>
</dict>
</array>
<key>ReuseFFFF</key>
<false/>
</dict>
<key>DropTables</key>
<array>
<dict>
<key>Signature</key>
<string>DMAR</string>
</dict>
<dict>
<key>Signature</key>
<string>MCFG</string>
</dict>
</array>
<key>HaltEnabler</key>
<true/>
<key>SSDT</key>
<dict>
<key>DropOem</key>
<true/>
<key>Generate</key>
<false/>
<key>PluginType</key>
<string>1</string>
</dict>
<key>SortedOrder</key>
<array>
<string>SSDT.aml</string>
<string>SSDT-0.aml</string>
<string>SSDT-1.aml</string>
<string>SSDT-2.aml</string>
<string>SSDT-3.aml</string>
<string>SSDT-4.aml</string>
<string>SSDT-5.aml</string>
<string>SSDT-13.aml</string>
</array>
</dict>
<key>Boot</key>
<dict>
<key>Arguments</key>
<string>slide=0 dart=0 nv_disable=1 kext-dev-mode=1 -v</string>
<key>Debug</key>
<false/>
<key>DefaultVolume</key>
<string>ElCapitan</string>
<key>Legacy</key>
<string>PBR</string>
<key>Secure</key>
<false/>
<key>Timeout</key>
<integer>2</integer>
<key>UseKernelCache</key>
<false/>
<key>XMPDetection</key>
<false/>
</dict>
<key>Devices</key>
<dict>
<key>Audio</key>
<dict>
<key>Inject</key>
<string>1</string>
</dict>
<key>USB</key>
<dict>
<key>AddClockID</key>
<true/>
<key>FixOwnership</key>
<true/>
<key>Inject</key>
<true/>
</dict>
</dict>
<key>DisableDrivers</key>
<array>
<string>Nothing</string>
</array>
<key>GUI</key>
<dict>
<key>Hide</key>
<array>
<string>\EFI\BOOT\BOOTX64.EFI</string>
<string>Windows</string>
</array>
<key>Language</key>
<string>en:0</string>
<key>Mouse</key>
<dict>
<key>DoubleClick</key>
<integer>500</integer>
<key>Enabled</key>
<true/>
<key>Mirror</key>
<false/>
<key>Speed</key>
<integer>8</integer>
</dict>
<key>Scan</key>
<dict>
<key>Entries</key>
<true/>
<key>Legacy</key>
<false/>
<key>Tool</key>
<true/>
</dict>
<key>ScreenResolution</key>
<string>1920x1080</string>
<key>Theme</key>
<string>Latitude</string>
</dict>
<key>Graphics</key>
<dict>
<key>Inject</key>
<dict>
<key>ATI</key>
<false/>
<key>Intel</key>
<true/>
<key>NVidia</key>
<false/>
</dict>
<key>NvidiaSingle</key>
<false/>
<key>ig-platform-id</key>
<string>0x191e0000</string>
</dict>
<key>KernelAndKextPatches</key>
<dict>
<key>AppleRTC</key>
<true/>
<key>AsusAICPUPM</key>
<true/>
<key>Debug</key>
<false/>
<key>ForceKextsToLoad</key>
<array>
<string>\System\Library\Extensions\IONVMeFamily.kext</string>
</array>
<key>KernelCpu</key>
<false/>
<key>KernelHaswellE</key>
<false/>
<key>KernelLapic</key>
<false/>
<key>KernelPm</key>
<true/>
<key>KextsToPatch</key>
<array>
<dict>
<key>Comment</key>
<string>HD 520 HDMI</string>
<key>Find</key>
<data>
AgQKAAAEAAA=
</data>
<key>Name</key>
<string>AppleIntelSKLGraphicsFramebuffer</string>
<key>Replace</key>
<data>
AgQKAAAIAAA=
</data>
</dict>
<dict>
<key>Comment</key>
<string>Enable Trim on SSD</string>
<key>Find</key>
<data>
QVBQTEUgU1NE
</data>
<key>Name</key>
<string>IOAHCIBlockStorage</string>
<key>Replace</key>
<data>
AAAAAAAAAAAA
</data>
</dict>
<dict>
<key>Comment</key>
<string>AppleHDA ALC 293 #3</string>
<key>Find</key>
<data>
hQjsEA==
</data>
<key>Name</key>
<string>AppleHDA</string>
<key>Replace</key>
<data>
AAAAAA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>Hand-off (10.11)</string>
<key>Find</key>
<data>
SIX/dEdIiwc=
</data>
<key>Name</key>
<string>IOBluetoothFamily</string>
<key>Replace</key>
<data>
Qb4PAAAA60Q=
</data>
</dict>
<dict>
<key>Comment</key>
<string>AppleHDA ALC 293 #1</string>
<key>Find</key>
<data>
hBnUEQ==
</data>
<key>Name</key>
<string>AppleHDA</string>
<key>Replace</key>
<data>
kwLsEA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change 15 port limit to 30 in AppleUSBXHCIPCI</string>
<key>Find</key>
<data>
g72M/v//EA==
</data>
<key>Name</key>
<string>AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>
g72M/v//Hw==
</data>
</dict>
<dict>
<key>Comment</key>
<string>External icons patch</string>
<key>Find</key>
<data>
RXh0ZXJuYWw=
</data>
<key>Name</key>
<string>AppleAHCIPort</string>
<key>Replace</key>
<data>
SW50ZXJuYWw=
</data>
</dict>
<dict>
<key>Comment</key>
<string>AppleHDA ALC 293 #2</string>
<key>Find</key>
<data>
hAjsEA==
</data>
<key>Name</key>
<string>AppleHDA</string>
<key>Replace</key>
<data>
AAAAAA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>Broadcom 5Ghz US</string>
<key>Find</key>
<data>
QYP8/3QsSA==
</data>
<key>Name</key>
<string>AirPortBrcm4360</string>
<key>Replace</key>
<data>
ZscGVVPrKw==
</data>
</dict>
<dict>
<key>Comment</key>
<string>AppleHDA #4</string>
<key>Find</key>
<data>
gxnUEQ==
</data>
<key>Name</key>
<string>AppleHDA</string>
<key>Replace</key>
<data>
AAAAAA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>HD 520 HDMI # 2</string>
<key>Find</key>
<data>
AQUJAAAEAAA=
</data>
<key>Name</key>
<string>AppleIntelSKLGraphicsFramebuffer</string>
<key>Replace</key>
<data>
AQUJAAAIAAA=
</data>
</dict>
<dict>
<key>Comment</key>
<string>SecondStagePatch 10.11</string>
<key>Find</key>
<data>
AQAAdRc=
</data>
<key>Name</key>
<string>IOGraphicsFamily</string>
<key>Replace</key>
<data>
AQAAdBc=
</data>
</dict>
<dict>
<key>Comment</key>
<string>SecondStagePatch 10.12</string>
<key>Find</key>
<data>
AQAAdSU=
</data>
<key>Name</key>
<string>disabled:IOGraphicsFamily</string>
<key>Replace</key>
<data>
AQAA6yU=
</data>
</dict>
</array>
</dict>
<key>RtVariables</key>
<dict>
<key>BooterConfig</key>
<string>0x28</string>
<key>CsrActiveConfig</key>
<string>0x67</string>
</dict>
<key>SMBIOS</key>
<dict>
<key>BiosReleaseDate</key>
<string>10/18/13</string>
<key>BiosVendor</key>
<string>Apple Inc.</string>
<key>BiosVersion</key>
<string>MBP112.88Z.0138.B02.1310181745</string>
<key>Board-ID</key>
<string>Mac-3CBD00234E554E41</string>
<key>BoardManufacturer</key>
<string>Apple Inc.</string>
<key>BoardType</key>
<integer>10</integer>
<key>ChassisAssetTag</key>
<string>MacBook-Aluminum</string>
<key>ChassisManufacturer</key>
<string>Apple Inc.</string>
<key>ChassisType</key>
<string>08</string>
<key>Family</key>
<string>MacBook Pro</string>
<key>Manufacturer</key>
<string>Apple Inc.</string>
<key>Mobile</key>
<true/>
<key>ProductName</key>
<string>MacBookPro11,1</string>
<key>SerialNumber</key>
<string>C02KRULYFD56</string>
<key>Trust</key>
<false/>
<key>Version</key>
<string>1.0</string>
</dict>
<key>SystemParameters</key>
<dict>
<key>InjectKexts</key>
<string>Yes</string>
<key>InjectSystemID</key>
<true/>
<key>NoCaches</key>
<true/>
</dict>
</dict>
</plist>

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...