Jump to content
Tricchi

Handoff in only one direction

Recommended Posts

Ok, now it works again. Maybe something was wrong. I rebuilt the cache with Dcpimanager. It always works only in one direction, but it works! 

Share this post


Link to post
Share on other sites

Avoid these tools to rebuild the cache because they probably do not report errors on failed rebuilds.
 
It's written all over the forum if you bothered searching but you manually rebuild the cache in Sierra with the following commands:

sudo touch -f /S*/L*/E*
sudo kextcache -Boot -U /

Re-enter the command if you get and error 77 something. Ok with 17.
 
Alternatively use:

sudo touch -f /S*/L*/E*
sudo kextcache -system-prelinked-kernel

`

What makes you say Handoff only works in 1 direction?

Share this post


Link to post
Share on other sites

For example, if I open Safari on iPhone I should see the icon on the left of the Mac dock (hack) and does not appear. And so with all the other compatible applications. As if I do the same thing starting from the hack on the iPhone icon appears by double-clicking the home button.

Share this post


Link to post
Share on other sites

Hmm, it works fine between my E6230 (Sierra + Apple BCM94360CD card) and my iPhone 6s for compatible apps such as Safari or Maps for instance.

 

Assuming:

  • both devices are on the same wireless network (watch between 2.4/5GHz networks with same SSID, they're different networks)
  • both devices are connected on iCloud with same id
  • both devices have BT enabled
  • both devices have handoff enabled

you should be Ok.

http://appleinsider.com/articles/15/04/18/how-to-enable-apples-handoff-feature-between-your-ios-devices-and-mac

 

Which SMBIOS are you using on your E6530? Should be MBA5,2/MBP9,2 or similar. Seems more like a configuration issue somewhere imo.

Share this post


Link to post
Share on other sites

My SMBIOS is MBP9,1. My router has wifi 2.4 and 5 GHz. But I checked that for example at the moment is the hack that the iphone is a 5 GHz, but does not work anyway. Currently I have enabled the initial patch IoBluetoothFamily (the one I sent you in the config earlier this topic). Do You think it's better to put another patch that I have shown you https://osxlatitude.com/index.php?/topic/9523-handoff-in-only-one-direction/?p=66673?In this case it is best to first rebuild the cache with the commands that you have shown me?

Share this post


Link to post
Share on other sites

I inserted the patch indicated by Jake. Now handoff from a hack to iphone works well as before (always after switching off and reactivated handoff and bluetooth), whereas from iPhone to hack  appears for example Safari's icon but when I click it does not continue in the loading page. The same thing happens with all the other compatible applications.

Share this post


Link to post
Share on other sites

Well, it seems you got closer since the app icon with the little phone appears on your Hack now. Check your Config.plist and/or set of kexts for any rogue entry/driver.

Share this post


Link to post
Share on other sites

×