Jump to content

Search the Community

Showing results for tags '10.14.4'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • OSXLatitude
    • Announcements & News
    • Feedback
    • The Archive
    • Team blogs
  • OS X Installation Guides
    • Asus
    • Acer
    • Dell
    • HP
    • Samsung
    • Lenovo
    • Gigabyte
    • Toshiba
  • Help and Support
    • FAQs & Tutorials
    • Dell Systems
    • Acer Systems
    • Asus Systems
    • HP Systems
    • Lenovo systems
    • Samsung Systems
    • Toshiba systems
    • Intel-based Systems
    • AMD-based Systems
    • Software matters or issues
    • macOS previews (dev & public beta)
  • Technical Information, Projects and other Research & Development,
    • Hardware technical information
    • Projects
    • Other Research
    • Compatibility Query
  • Linux & ChromeOS
    • ChromeOS
  • E.D.P
    • About EDP
    • Issues and bugs
    • Models under research for EDP
    • EDP Development

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Twitter


FaceBook


GitHub


Location


Interests

Found 1 result

  1. Acer Aspire V15 V5-591G - Mojave 10.14.4 (Note: mine is 55TU version, but the bootpack will work fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.) Specifications: - Motherboard: USOPP_SLS (Skylake-H PCH) - BIOS: Insyde Corp. v 1.15 - CPU: Intel Core i5-6300HQ 2.3 GHz (Skylake) - GPU: NVIDIA GeForce GTX 950M 2 GB (Optimus) & Intel HD Graphics 530 - RAM: SK hynix 4 GB DDR4 (Later I bought + KINGSTON 4 GB) 2133 MHz - WiFi + Bluetooth: Qualcomm Atheros QCNFA344A 5 GHz (Later -> Broadcom BRCM94352Z M.2 5 GHz WiFi + 4.0 Bluetooth) - Audio: Realtek HD Audio: ALC 255 - Ethernet: Realtek RTL8168/8111 - Card Reader: Realtek USB 2.0 Card Reader (USB2.0-CRW) - Webcam: HD Webcam - HDD: TOSHIBA MQ01ACF032 320 GB HDD - SSD: SPCC M.2 230 GB SSD - Display: 1366x768 (15.6", Matte) - Battery: 6 cell 56Wh / 5040mAh - Connectors: 1x SD Card Reader 2x USB 3.0 (1x USB Charging), 1x USB 2.0 1x VGA 1x HDMI 1x 3.5mm microphone/audio combined jack connector 1x Ethernet (Rj-45) - Keyboard & Touchpad: Multi-Touch & Multi-gestures ELAN 501 Touchpad, Backlight Keyboard. Working: - Wi-Fi (with BCM94352Z) - Bluetooth hand-off (With BCM94352Z) - Full Graphics enabled on HD 530: ig-platform-id: 0x191b0000 (HD 530 Mobile) - Display: if default colour profile is corrupted (blue is not actual blue but purplish) Use "Rec. ITU-R BT. 709-5" Color Profile (System Pref. -> Displays -> Color) - HDMI & VGA Outputs: AppleGraphicsDevicePolicy.kext Clover patch - Audio (ALC 255): (Internal Speakers, Internal Microphone, Headphone jack with AppleALC, ALCPlugFix -> layout-id=17) - Ethernet Realtek 8168/8111: RealtekRTL8111.kext - App Store, Messages, FaceTime, Siri, iCloud (native) - Integrated webcam (native) - 3.0 USB (native) - Touchpad and Keyboard (ELAN501): Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn-> To fix this try Karabiner (VoodoPS2Controller.kext), - for gestures try SmartTouchpad drivers - Battery info: Install ACPIBatteryManager.kext with Kext Utility or other installer. - Sleep Mode - SSD with TRIM enabled (to enable trim, open Terminal and write "sudo trimforce enable") Not working: - Original Wi-Fi (Qualcomm Atheros QCNFA344A): unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle. - NVIDIA GeForce GTX 950M: Optimus not supported. - Card Reader: Unsupported -> Can't really fix because I don't have any SD Card at the moment, maybe can be fixed by adding Prod & Ven IDs to AppleStorageDevices.kext, I never used it anyway. name: "USB2.0-CRW" Prod ID: "0x0129" Ven ID: "0x0bda (Realtek Semiconductor Corp.)" For Wi-Fi: - 1st method: You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it - 2nd and I think the best method: Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, they're all in my attached zip). You could buy this card from ebay, aliexpress, or amazon Issues: - None BIOS Settings: - BIOS version 1.15 (irrelevant) - Secure Boot: Disabled - Touchpad: Advanced - Boot mode: UEFI Getting ready for Installation: - Download the install zip (bootpack & postinstall): Click here -> acer_aspire_v591g_installfiles.zip Installation: - Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager) - Copy my Clover folder to the USB's EFI folder - Boot with the Installer USB - If you stuck in boot, reboot and in the Clover bootloader select "config_debug.cfg" -> you'll have more informations about the freeze Please open the README.rtf in my install zip for more informations about the USB Installer & Post installation! If you have a single RAM and getting panic at boot, then you need to edit the "config.plist" with these (SMBIOS->after "Version 1.0"): ->Edit "Frequency" and "Size" to match your RAM values <key>Version</key> <string>1.0</string> <key>Memory</key> <dict> <key>Channels</key> <integer>1</integer> <key>SlotCount</key> <integer>1</integer> <key>Modules</key> <array> <dict> <key>Slot</key> <integer>0</integer> <key>Size</key> <integer>8192</integer> <key>Frequency</key> <integer>2133</integer> <key>Type</key> <string>DDR4</string> </dict> </array> </dict> </dict> PowerManagement fix: Set HWPEnable=YES in Clover (already set), CPUFloor to "700", Frequency to "2300" and "3200"(Normal and Turbo, if you have i7-6700HQ version then it should be "2600", "3500") and "FrequencyVectors" from "0x0d000000" to "0x07000000" in "S/L/E/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-A5C67F76ED83108C.plist", MSR _xcpm_idle Patch to KernelToPatch in Clover (If you have High Sierra, change "MatchOS" to 10.13): <key>KernelToPatch</key> <array> <dict> <key>Comment</key> <string>MSR 0xE2 _xcpm_idle instant reboot(c) Pike R. Alpha</string> <key>Disabled</key> <false/> <key>Find</key> <data> ILniAAAADzA= </data> <key>MatchOS</key> <string>10.14</string> <key>Replace</key> <data> ILniAAAAkJA= </data> </dict> </array> Reboot, and it's 800MHz in idle state, same on Windows. Elan SmartTouchpad I only use scrolling, one-, double- & tripletap If you want to try other gestures go to this link for more informations, options (v4.7 beta 5) -> DETAILS ABOUT THE SMART TOUCHPAD DRIVER FEATURES Fn Brightness keys not working with this, tried several things without success. With VoodoPS2Controller it's working, but you'll have no gestures (neither scrolling). Before updating to a new version of Mojave please update kexts (and clover if necessary) to newer versions to avoid kernel panics. Generate a serial number with Clover Configurator.app (open up your config.plist with CC then -> SMBIOS -> Serial Number -> Generate New) Mojave & Windows 10 Dual-Boot: Dual-boot clean install (on one drive), UEFI Only: Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac), Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart, Boot into your Win installer, Format the partition you created for Win, install. Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type: bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi 5. You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition). Dual-boot with Windows installed first (on one drive), UEFI Only: If you already have Windows and you don't want to lose all your data there is a hope: I created a video from this restore method: [Hackintosh] Dual-Boot High Sierra & Windows - when Windows already installed - no data waste - UEFI You need bootable Mac Installer and a full system restore image (link is in my video's description). (You may see errors if your EFI partition is not 200 MB) Boot into your Windows, resize your partition or create one for Mac. Boot into your Mac installer and in Disk Utility format the partition you created. Restore from image: select your full system restore image. When it's finished restoring you just need to restart, then boot to the system with your usb. When you successfully booted to Mac desktop, mount your EFI partition (use terminal or an EFI mounter app), open EFI, you will see there is a Microsoft folder already (don't touch that!). Copy my CLOVER folder to the EFI folder then Restart. Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type: bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi 7. You're done! You can select your old Windows and your new macOS! (Only tried with Windows 8/8.1/10. I don't know Windows 7,etc.) IF YOU GETTING ERRORS DURING MAC RESTORE: - Make sure you have partitions in GPT - Windows using 100 MB EFI and will annoy the Mac restore. Don't worry, just ignore the errors. IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc): - Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB) IF YOU USED RESTORE METHOD THEN CAN'T MOUNT YOUR EFI PARTITION (No EFI partition found): - It's because your EFI is not 200 MB or not an "Apple" original EFI, but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem) - You also could "mount" the EFI from Windows: 1st method: open cmd in administrator mode and type: diskpart list vol (Now select the "System" volume,(FAT 32) For example I select 4) sel vol 4 list part (Select System type partition, for example 2) sel part 2 assign letter=b (This will "mount" your EFI partition) Open Explorer++ or TotalCommander in administrator mode to manage EFI remove letter=b (This will "unmount" your EFI) 2nd method: open cmd in administrator mode and type: mountvol b: /s (This will mount your EFI) Open Explorer++ or TotalCommander in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI) Thanks to all OSXLatitude members for helping me out! (Jake Lo, Hervé, Bronxteck, black.dragon74)! Notes: 2019.04.25: Optimized touchpad scrolling -> updated install files 2019.03.30: Fixed USB 3.0 ports, fixed Bluetooth crashes after sleep -> updated bootpack 2019.03.28: Updated to 10.14.4. Unexpected crashes while updating to 10.14.4 -> fixed by updating Clover to the latest (v4910) version. Bluetooth crashes appeared -> fixed by downgraded Brcm*.kexts. Updated bootpack. 2019.02.24: Bluetooth crashes after sleep -> fixed, updated bootpack. 2019.02.22: Updated to 10.14.3. Fixed HDMI Audio by installing "FakePCIID_Intel_HDMI_Audio.kext" -> fixed freezing during boot. Fixed brightness levels by installing "AppleBacklightFixup.kext". Also updated bootpack & postinstall zip down in attachments. 2019.01.21: Removed FakeSMC.kext, SMCHelper-64.efi, replaced by VirtualSMC.kext, VirtualSMC.efi because I got random freezes when booting system (kextd stall[0], (120s): 'AppleACPICPU' -> CPU is at 100%, fans are spinning fast), also updated bootpack in the attachments "acer_aspire_v591g-55tu_clover.zip" -> Freeze continued, brought back FakeSMC, deleted VirtualSMC (caused BT crashes). 2019.01.18: HDMI Audio is fixed, I didn't do anything HDMI Audio is not fixed, sometimes it worked but most likely not. (no idea why) 2018.12.09: Updated to 10.14.2 -> did without any complication 2018.11.28: Fixed combo-jack garbage sound output by installing ALCPlugFix and CodecCommander.kext 2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14. 2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working
×
×
  • Create New...