Jump to content
vaccinemedia

[SOLVED] E6440 Mojave 10.14.4 No Audio

Recommended Posts

I've done a clean install of Mojave 10.14.4 on a Dell Latitude E6440 with 4300M, 8GB RAM, 250GB SSD and Intel HD 4600 Graphics. I created the installer using the command line:

sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/"Untitled" --applicationpath /Applications/Install\ macOS\ Mojave.app --nointeraction

 

Then installed the latest Clover and added the bare minimum drivers and kexts in order to run the installation.

 

The installation went perfectly. It even felt like I was installing onto a real MacBook! Post install I installed Clover onto the main HD and copied over the EFI folder from the USB stick over the one installed by Clover. Using FixHPET in clover config I have managed to enable all USB and Bluetooth. The final issue is with audio. I have installed the latest AppleALC.kext and Lilu.kext and have used the option in Devices > Audio > Inject = 12 as per what I've found using a search. After rebooting, no audio. I've also tried using the AppleHDA_ALC292.kext and CodecCommander.kext in /Library/Extensions after removing AppleALC.kext and rebuilding kext caches and setting the inject to 1 and rebooting - no audio.

 

I'm not sure what else to try as either method is so simple. I have not patched / used a dsdt and using Clover to handle all of the hot patching.

 

Any advice would be well received! I've attached my current EFI folder as the laptop does not have an internet connection (no wifi as it's intel) so can't use the linked to tool.

current E6440 efi.zip

Share this post


Link to post
Share on other sites

I finally managed to get audio working!

 

It's probably that the latest versions of the Lilu and AppleALC kexts don't accept the legacy injection for the layout-id anymore. I found the following information

Quote

It should be noted that it's quite likely that Lilu will drop the legacy method of reading the value of "layout-id" from "Clover/Devices/Audio/Inject" at some point in the future, so you may be better of using the second method which uses Device Properties and brings AppleALC configuration in-line with other Lilu plug-in's such as WhatEverGreen.

 

I used Hackintool in order to generate the necessary code to copy and paste into the existing config.plist (removing the placeholders with hashes which were in there from Rehabman's config.plist) and I now have audio!

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...