Jump to content
mcandre

[VMware Workstation Player] High Sierra boot loop?

Recommended Posts

Hey yall! I'm trying to setup High Sierra in a virtual machine in order to reduce the number of reboots I need in order to build applications for different environments (Mac, Windows, Linux, FreeBSD, OpenBSD, ...) So virtual machines are really helpful for getting my applications out to market!

 

I managed to get macOS 10.13 High Sierra running as a guest VM with VMware Fusion 10 on macOS 13.13 High Sierra host, without too much trouble. Here's my VMX for macOS hosts:

https://gist.github.com/mcandre/48f90963d9a24315024319cd62142f6a

However, I would like to be able to use High Sierra from Windows 10 hosts (e.g. Boot Camp'ed on Apple hardware). I'm following a dozen online tutorials for this, and can work around most glitches like ensuring that

smc.version = "0"

and patching VMware with the unlocker, and ensuring that the drive interfaces are SATA. However, I am not able to boot up the full macOS SetupAssistant installer. From a Windows host, I just get boot looping between the Apple logo and the VMware logo. Any tips for fixing this?

Screenshots

https://imgur.com/a/tHJ94

Share this post


Link to post
Share on other sites

Installing on windows is not that easy. Use this to have a working macOS VM on windows https://techsviewer.com/install-macos-high-sierra-vmware-windows/

 

Hmm, I'm following similar instructions, but am unable to get to the welcome screen. Instead, the Apple loading screen loops back to VMware boot.

 

For what it's worth, I am patching VMware with an unlocker. Rather than use a premade vmdk, I'm using an ISO that I generated from Install macOS High Sierra.app's createinstallmedia tool.

Share this post


Link to post
Share on other sites

×