Jump to content
asergey63

Dell XPS 2720 Sierra 10.12.6

Recommended Posts

I've an XPS 2720 All-In-One computer and successfully installed macOS Sierra 10.12.6 with Clover.
post-4953-0-29498600-1512657519_thumb.jpg post-4953-0-52266200-1512657582_thumb.jpg
 
post-116014-0-81769200-1512654154_thumb.jpeg
post-116014-0-63094800-1512654163_thumb.jpeg
 
Fully native graphics support on 2560x1440 built-in 27" screen. Touchscreen works too.
Fully working Ethernet, WiFi, Bluetooth, Audio (patched AppleHDA), Internal Web Cam.
 
Kexts used:

  • CoreDisplayFixup.kext
  • IntelGrpahicsFixup.kext
  • FakePCIID_HD4600_HD4400.kext
  • FakePCIID.kext
  • Lilu.kext
  • LiluFriend.kext
  • RealtekRTL8111.kext

Kexts_XPS2720_SIERRA_10_12_6.zip

IntelGraphicsFixup_1.2.1.kext.zip

 

Config.plist:

  • IntelGFX 0x04128086
  • ig-platform-id 0x0D220003

config.plist.zip
 
Ask me if you have questions.

  • Like 2
  • Haha 1

Share this post


Link to post
Share on other sites

Several times noticed the freezing when I turn on iTunes clip.

 

On the advice of Bronxteck (who suggested I tried adding intelgraphicsfixup and shiki lilu plugins), I put the IntelGraphicsFixup.kext into /EFI/CLOVER/KEXTS/OTHER (with lilu.kext) and reboot ! No Feezing in iTunes clip at all! Geniously!

 

I added intelGraphicsFixup.kext (zip) in first post.

Share this post


Link to post
Share on other sites

Use any DSDT or SSDT patches for this config ? Or any special settings in BIOS ? I Install Sierra 10.12.6  with all attachted kexts and config .plist  but NO HD 4600 acceleration ... I get full resolution 2560x1440  but no graphic accelerated so scrolling is very slow. My Dell XPS 2720 with i7-4770S .

What version of clover ? Even try three bios version up to A15 but no progress.  

Share this post


Link to post
Share on other sites

@piters35 @asergey63 I am trying on BIOS A13 now after no success with A15, and I cannot get Clover to start installing with either, it starts up into Clover but once I start the install it pauses for a little bit then restarts to the Dell splash screen.  What Clover Settings are you using to get the install completed and booting?

 

thanks!

 

 

Share this post


Link to post
Share on other sites

@Jake Lo I've tried all 4 of the AMImem fixes, and each one it just stops at all ++++++++ in verbose mode, which causes a reboot. I'm using Sierra using terminal install method and Clover 4700 (most recent), which uefi64 files should be in the clover folder?  thanks!  

 

I've also switched out VFS for HFS+ and neither work.

 

Can someone upload there working clover zip so i can try it on mine?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...