Jump to content

D630 (Nvidia, A18) 10.6.8 – Almost Success (No Wireless, No Sleep)


psypics
 Share

Recommended Posts

Hello everyone.

 

It's been two days I'm trying to get everything work on my Dell Latitude D630.

So I'll try to share my experience and I hope you'll find it useful.

(Sorry for my English. It is not my native language.)

 

So. First of all you'll need extra USB Keyboard and USB Mouse.

 

1. Please make sure you have A17 or A18 BIOS installed.

(I've tried to use custom BIOS from this link:

http://www.osxlatitude.com/custom-bios-update-with-slic-apple-logo-and-edps-dsdt/

But I got KPs during SL installation all the time.)

 

2. Create a USB pen with OSX installation.

(You can find on wiki how to do that)

Collect some important files that you'll need after the installation and copy them to USB flash drive.

Those important files for me were:

1. The latest EDP for SL. You can find it here:

http://www.osxlatitude.com/edp/

2. The latest Chameleon bootloader

http://www.osxlatitude.com/files/Chameleon.pkg

3. 10.6.8 Combo Update

http://support.apple.com/kb/DL1399

4. tonycrapx86 Update Helper

http://tonycrapx86.blogspot.com/2011/07/get-ready-for-os-x-lion-update-to-1068.html

5. tonycrapx68 multifail for SL

http://tonycrapx86.blogspot.com/2010/02/multifail-ultimate-post-installation.html

 

3. Install Mac Os X 10.6.0

4. Install EDP.

My config was:

Model selected: D630-nvidia

Mouse/Keyboard driver: 1

Battery driver: VoodooBattery.kext

Install NullCPUPowerManagement: n

Install SleepEnabler:

Emulated speedstep: n

 

5. Install Chameleon.

 

> Reboot.

Everything seems fine. No KPs. Sound is ok. The only minor bug is that Volume +- and Mute buttons didn't work.

Touchpad is ok... Ooops. Keyboard is not working.

 

(It is time to plug our external USB Keyboard and mouse.

Have to say that I've tried all the 4 options for the PS/2 controller kexts but none of them worked for me.

Keyboard was still dead.)

 

So. It is time to install multifail.

Delete VoodooHDA.kext and ApplePS2Controller.kext from /.../Extra/Extensions.

Rebuild caches.

Run multifail. Please see the picture for the details:

post-903-025842200 1329671924.png

 

Reboot... Okay. No KPs. Sound is OK. Volume and Mute buttons are working. Touchpad is working. Keyboard is working too! Great!

 

Now let's try to update our 10.6.0 SL to 10.6.8... There were no problems at all when I used 10.6.7 combo.

But with 10.6.8 I got KP every time I reboot after the installation.

So I tried to use Update Helper from tonycrapx86 and it worked!

Do not forget to run Update Helper before installing 10.6.8 Combo.

Then run combo and wait. ) That's it.

 

 

The only things I can't make to work are the Sleep function and wireless.

I'll appreciate your help guys with fixing these problems.

 

Thanks.

Link to comment
Share on other sites

 Share

×
×
  • Create New...