Jump to content

D620 Kernel Panic on boot after installing EDP 1.9 - Snow Leopard


Recommended Posts

Trying to get Snow Leopard on my D620 and I am having all sorts of Kernel Panic issues on boot.


I can successfully install Snow Leopard with the USB PEN method as outlined on this site. However, after installing and running EDP 1.9.2 I can't reboot without kernel panics.


What I am doing:


1) create USB pen from SL Retail DVD

2) Install SL

3) Boot to SL for the first time, do the registration stuff then I run EDP 1.9.2

4) After I do EDP I set it up for my D620

5) I try to install chameleon after that and it crashes every time

6) I reboot and then I get kernel panics


I have tried other methods and the furthest I have gotten so far is running myhack from the USB stick to install chameleon and extras from there. If I do that, I can reboot and it works. But as soon as I install EDP I'll get the kernel panics.


The first time I installed Snow Leopard I used EDP 2.2 ,and I know that's for LION, but it seemed to work great - I could reboot. But then all of a sudden I couldn't boot without a kernel panic.


I also tried installing the 10.6.8 combo update then EDP, then ran MYFIX and still get kernel panics on reboot.


What am I doing wrong? Any ideas?

Link to comment
Share on other sites

Any news ? - Did you get it working in the end DK ?


I did get it working! What did it for me was installing chameleon from the edp installer option.


Haven't used the latitude too much, waiting for my wifi card. Will report back.


Sleep is an issue for sure. Did the tutorial on this site and did the bios password. Can wake without a kernel panic but the mouse cursor is broken.

Link to comment
Share on other sites

  • Create New...