Jump to content

Display and Thunderbolt issues in Latitude 7390 Catalina


amthb0
 Share

Recommended Posts

With the successful hackintosh in Latitude 7490, I decide to install Catalina on Latitude 7390, as the 7390 is much portable. 

Using the Clover pack of 7490 from https://osxlatitude.com/forums/topic/11410-dell-latitude-7490-with-i7-8650u-intel-uhd-620-and-1920x1080-lcd-mojavecatalina/ .

(Could't find other specialized pack for 7390.)

 

Latitude 7390 Specs:

- i7-8650U, Motherboard with Thunderbolt

- 16GB RAM

- TOSHIBA 256GB KXG50ZNV256G NVMe 

- DW1820A (VW3T3)

 

Not working well:

- Built in display:

The color is too much blue and purple, I have to choose another profile, like sRGB, but I still feel the color is a bit abnormal. Is there anyway to make the default profile works normal?

 

- Thunderbolt: 

Thunderbolt is enabled in BIOS, but not listed in macOS. 

I have to connect devices to the Type C(Thunderbolt) port before booting, otherwise they will not work, like USB-C flash drive, USB ethernet and USB audio device in WD15. 

But the DP through Type C can work, as my U2414H connected to WD15, and the color is OK. 

 

-Bluetooth: (same issue in 7490)

The bluetooth device is listed under USB, and it is drivered. It can find other bluetooth devices, such as pods, speaker, and smart phone, but can't connect. 

I have tried 2.2.10-2.2.12-2.5.0-2.5.1 drivers, all the same, no go. 

 

If more details need to be provided for tweak, please tell me how to capture.

Thanks for your help. 

Screen Shot 2019-12-28 at 11.11.12 AM.png

Screen Shot 2019-12-28 at 11.12.26 AM.png

Link to comment
Share on other sites

 Share

×
×
  • Create New...