Jump to content

GA- H81m-DS2, i5 4570, Radeon RX570 High Sierra


Recommended Posts

Hi Everyone,


I thought I would post details of my successful High Sierra build.


Thanks goes to Syonagar for posting about his build using the same motherboard and uploading the Clover folder.


System Specs:

  • Core i5 4570
  • Gigabyte H81m-DS2
  • Klevv SSD Neo N510+ 480gb Primary
  • Samsung SSD 850 EVO 500gb Backup while getting everything working.
  • Toshiba HDW120 2 TB HDD for storage.
  • WD Blue 500gb 7,200rpm storage
  • Sapphire Radeon RX570 8gb Works OOTB
  • 16gb Corsair Vengeance LP 1600mhz DDR3 (2 X 8G DIMMS)
  • Firewire card
  • 2k 34" monitor


USB installer creation.


I created a USB installer on my aging 08 MBP using creatinstallmedia in terminal using the following command


sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume


Clover installed using default for UEFI.

UEFI Drivers:

  • ApfsDriverLoader.efi
  • AudioDxe.efi
  • FSInject.efi
  • OsxAptioFixDrv.efi
  • PartitionDxe.efi
  • SMCHelper.efi
  • VBoxHF.efi



  • Lilu.kext
  • RealtekRTL811.kext For my lan
  • SMCProcessor.kext
  • SMCSuperIO.kext
  • VirtualSMC.kext
  • WhateverGreen.kext


OS installed to Klevv SSD (file system APFS) without issues during installation and first boot. RX570 recognised out of the box and runs at up to 2k 144hz.


After install and initial setup:

  • System backed up to Samsung SSD using Carbon Copy Cloner. This was incase I screwed up the primary install.


Post install:

  • Install Clover on SSD EFI partition.
  • Replace the new Clover folder with Syonagar's Clover folder for Catalina.
  • Reboot


Reboot without install USB was successful.


First issue was no audio through the HDMI.

This was solved buy adding AppleALC.kext and removing VoodooHDA.Kext but this meant I had no onboard audio.
At the time I wasn't fuss as I use HDMI audio through my monitor.


Clover folder update with the following.

UEFI Drivers:

  • ApfsDriverLoader.efi
  • AudioDxe.efi
  • DataHubDxe.efi
  • Fat.efi
  • FSInject.efi
  • NTFS.efi
  • OsxAptioFix3Drv.efi
  • SMCHelper.efi
  • VBoxExt2.efi
  • VBoxExt4.efi
  • VBoxHfs.efi
  • VirtualSmc.efi



Installed into other folder

  • AppleALC.kext This was so I could have audio via HDMI. Because I removed VoodooHDA.kext I had no onboard audio and AppleALC.kext required a fix to enable onboard audio.
  • Lilu.kext
  • RealtekRTL8111.Kext For Lan
  • SMCProcessor.kext
  • SMCSuperIO.kext
  • VirtualSMC.kext
  • Whatevergreen.Kext



HDMI audio working.


Working EFI folder backed up to Samsung EFI partition as well as a zip file on the a separate HDD.


Onboard audio fix using Clover Configurator.


I found the fix at another site but it is also show by Shaon at


I have used ID 13.

I now have working onboard audio through the front panel as well as rear output.

I have to check to see if this has enabled the line in and mic in as well.

A complete list of supported codecs can be found at https://github.com/acidanthera/AppleALC/wiki/Supported-codecs

Backup EFI folder.


Next Issue was the firewire card causing the system to reboot on shutdown.

The card did work without issue in a system using an Asus B85M-G board that I had installed HS and Mojave on. This board started acting flakey which is why I purchase the H81m-DS2. I was fortunate enough to find it brand new at a local retailer.


After some trial and error, including testing on a 1st gen i7 with Mavericks installs to confirm the card still worked, I cleaned out the EFI partition and reinstalled clover.

I installed the firewire card and then updated all drivers and kexts manually using those that I have listed and selected fix shutdown in Clover Configurator under ACPI-Fixes.


Reboot to confirm system still works.

Connect portable HDD via Firewire. Firewire works


Shutdown to confirm system shuts down.




Lastly I enabled trim which appears to have made the boot time increase by about 15-20 seconds.

I have searched online and it appears to be common. I have also searched to see if trim enabled is needed with APFS and have read mixed opinions.

Any thoughts?


Installed Security Update 2020-003 10.13.6 as well as iTunes 12.8.2, iTunes Device Support Update and Safari 13.1.1


Backup system and EFI.


I have installed Adobe Production Premium CS5.5 because I am capturing old VHS tapes and the player has firewire out.

Premiere Pro works but does tend to crash when I quit as does Photoshop. Unfortunately Di Vinci Resolve doesn't support firewire.

Currently search for a solution but I may use the i7 Mavericks system if it becomes a problem because it's only a short term unpaid project and I already own the software.





  • Like 1
Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...