Jump to content

Dell DW5808 (MC7355) in Catalina & disabling low power mode in sierra WWAN


Recommended Posts

Hello everyone.

 

I'm facing the same low power issue mentioned here with a Dell DW5808 module (sierra MC7355) on Catalina. I've set the usbcomp to 8 (tried 14 but windows drivers had troubles with it) and used the latest Legacy_Sierra_QMI.kext. Device is shown corrently in system information usb & wwan, but when trying to connect I get the same PPP error and at!gstatus shows low power mode.

 

One thing I noticed is that the module from viking1304 uses a software (firmware?) with a slightly older version than the one from wojciech679, which is the same as mine. From this thread:

Could the newer software set default mode to low power? Also tried to set SIMLPM to 0, but this didn't seem to help (I think).

 

By the way, an easy way to verify & change USBCOMP from windows 10 (and use other AT commands) is with this Java super tool - I highly recommend it!

https://m2msupport.net/m2msupport/software-and-at-commands-for-m2m-modules/

 

 

Link to comment
Share on other sites

Disable low power update!

 

So, after searching on sierra forum I managed to disable the low power mode as described here https://forum.sierrawireless.com/t/em7455-deactivate-low-power-mode/8620.

The AT command that worked for me was AT!PCFCCAUTH but to get it runing you need to enter

the engineering mode using AT!OPENLOCK?. This command will give a challenge (16-bit hex number, say XXXXXXXXXXXXXXXX)

that should be input in a python generator script to get the response code (say YYYYYYYYYYYYYYYY). The script can be found

here https://github.com/bkerler/SierraWirelessGen

I used an older version from here https://github.com/valiant1x/SierraWirelessGen that worked.

After installing python and the required pyserial script, run from cmd:

<directory of the script>/sierrakeygen.py -l XXXXXXXXXXXXXXXX -d MDM9x15

 

Then use AT!OPENLOCK="YYYYYYYYYYYYYYYY" to enter engineering mode

after that set AT!PCFCCAUTH=0 and reset the device (AT!RESET)

 

Optionally you can disable fast enumeration (AT!CUSTOM="FASTENUMEN",2) and ignore W_Disable (AT!PCOFFEN=2)

After device reset restart macOS without caches (-f option) and check connection.

This worked for me and the WWAN turned in online mode and connected me to the internet.

 

The procedure looks similar for other sierra WWAN devices too and the updated script supports these as well,

so I guess if these are stuck in low power mode is a good one to try.

 

Thank you everyone

 

Credits:

bkerler, Barton, Skvo, Hervé, wojciech679, M2MSupport.net

 

 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...