Jump to content

MSI Z77A GD 65 based i7-3770K Hackint0sh Build


Recommended Posts

Hi all,


The Story: This is the story which may be boring to some and you can skip to the meat of myhack after this if you do not want to read.


Finally the long wait is over I registered on Friday 22, February and got the approval for the forum today. To begin with I am a complete Noob when it comes to iMac/Hackint0sh never used one. Obviously it was a challange for me to build a Hackint0sh. I was replacing my 6 year old PC and was excited about the idea of Hackintosh. Hence, I started the Google search for building a Hackint0sh. I came accross many forums, tutorials and videos to install Mountain Lion. I was planning to build the Hackint0sh around the new Ivy Bridge processor intel i73770K. I had to make a decision which path to follow and I chose myHack and I am glad that I did. For the sake of Disclaimer, (i) I never even tried the TonyCrap method (ii) I live in India and 1 in 500 people owns a Mac of any kind. It was real difficult to get hold of someone to download 4+ GB worth of OS from the AppStore on crappy internet speeds.


My Build:

MotherBoard: MSI Z77A GD 65

Processor: Intel i7 3770K

Memory: 8Gbx2 1600Mhz Corsair Vengence

O/S Drive: Samsung 840 SSD 120 Gb

Storage 1: WD Black 1 TB 7200 rpm 64Mb Cache

Storage 2: WD Caviar Green 1 TB 5400 rpm 64mb Cache


Chasis: Corsair 500r

PSU: Cooler Master Bronze 650W (Non-Modular)

CPU Cooler: Cooler Master EVO Hyper 212

Graphics Card: None (Ran out of money) using the integrated HD 4000

Keyboard/Mouse: Microsoft Wired 200


(For information: I did the whole installation with my Dell IN2030M with VGA connector)



Nothing to say here I just followed the steps in the guide available using Myhack Guide and I was able to boot and install OSX 10.8 on my SSD.


Almost all the things that worked out of the Box except the intel integrated HD 4000 Graphics, ALC898 Audio and ehternet.

I am not aware what Apple Power managment does and hence I won't comment on that.


The fist thing I did was to donate a small amount to Conti with the resolve to donate more after the completion of my Hackintosh Project.


Post installation: First I addressed the Ethernet


The Motherboard uses 82579V ethernet and reading across forums and the internet I found out AppleIntelE1000e.kext is required to get my ethernet working. The problem I faced was that I dont know how to install a kext. I found a programme called Kext Wizard and installed the kext ran myfix and voilla I have my internet working.


The second thing I addressed is the Audio. MSI Z77A GD 65 uses ALC898 Codec and I had to find the relevent Kext for it. I again researched the whole internet world (Primarily because I didn't have a forum access to ask questions and to be honest I never wanted to go to TonyCrap). I found that AppleHDA.Kext and HDAEnabler898.kext shall get my Audio all Hunky Dory. I installed both the kext in S/L/E and ran Myfix again and restarted. Now I have my audio running. Even the audio jack of the front panel of Corsair 500r was working beautifully. The second hurdle crossed.


The third was to address the Graphics. As I ran out of money to buy the latest GPU (I am thinking of GTX 670) I thought in the meantime I'll use the integrated graphics HD 4000. To be honest it took quite a while to figure out how to activate it. There was no kext for it to activate, and information regarding enabling HD 4000 was lying around in bits and pieces. Finally, I settled with the EFI string injection method in the org.Boot.plist in the Extra Folder. I'll put a detailed post on how I did this in my other Post. The pre-condition to enabling HD 4000 is is to connect the Monitor through DVI to DVI Cable.


Now My sytem is working fine. I can also access the Apple iTunes. The known issues with the Hack are as follows:

1. My 3.0 ports are working fine. However, My USB 3.0 Port, (back and front panel both) won't detect a USB 2.0 flash drive or external USB 2.0 hard drive. .

2. I still have no idea what AppleCPUPowermanagment.Kext does and I want to understand it and then install it on my system.

3. The SATA Connection to the DVD R/W drive is showing a speed of 6Gbps but it also shows a negotiated speed of 1.5gbps. I guess this is Okay.

4. The Sata connection to SSD shows a negotiated speed of 6Gbps but say Unknown for the SATA controller. MY SSD is connected to a 6Gbps sata cable connection to the Mothebroad.

5. Not able to buy Mountain Lion. The Buy option in the Appstore says this computer is not compatible with Mountain Lion OSX.

6. The system goes in sleep mode but Mouse enabled wake up is not happening.

7. Control Key (on the keyboard) is not working. I cannot do Ctrl+S and similar shortcuts as of now. I later came to know that Mac keyboard is different from a PC so I need to work that bit out to get my Keyboard running


Further Research:

I shall further research on HDEF and HPET (whatever they are) and shall install them if I need them. I have not touched the DSDT file though I have already extracted it.

If I did a mistake in the above installation please guide me .. and help me in its rectification.


Enjoy! Hackintoshing with myHack



New Delhi India

Link to comment
Share on other sites

My Build:

MotherBoard: MSI Z77A GD 65 Military Class3

Processor: Intel i7 3770

Memory: 2x 4gb 1600Mhz Corsair Vengence

O/S Drive: Sandisk Readycache 32gb SSD

Storage 1: 256Mb Samsung SM841 SSD

Storage 2: 256Gb sata Seagate HD


Chasis: Nvidia

PSU: Huntkey X7 900w Modular

CPU Cooler: Cooler Master EVO Hyper 212

Graphics Card: HD 4000 and Msi 7950 OC 3gb

Keyboard/Mouse: Logitech wireless bundle





I desperately need help, I've tried everything I can but nothing seems to want to

Work I'm even so surprised you managed to get this board to work!


I'm using the latest myhack right and it seems to be great at having hardware to work oob

My hd4000 and Msi 7950 work beautifully oob but unfortunately this is all in safe mode.

when I try to boot installer I just get white page with cursor so I have to boot in safe mode

As we'll then after install and everything the system won't boot circle just keeps spinning but when

I boot in safe mode it logs in perfectly and full res on either card. But I've taken out the 7950 for now

Just to troubleshoot.


After installing my hack i used chimera (chameleon, stolen and rebranded) standalone 2.2.1 that's all


I've also previously tried different options and versions of multifail but nothing helps.



I have flashed the bios already. So I don't know what's missing. Do I need a dsdt or what.

I've also read another forum that you need the Extra folder from ML in the install USB

And in the had aswell after install. please please help me I've lost hope on this board and I need

To get working right away.


FYI - The boot stops at IOBluetoothhcicontroller .......missing Bluetooth controller


thanks a lot.

Link to comment
Share on other sites

  • Create New...