Jump to content

Thinkpad X61: Chameleon issue (myHack 3.3.1 + Lion)


flyingfishfinger
 Share

Recommended Posts

Hi,

Been trying to install Lion (10.7) to my Thinkpad X61 with (limited) success. I'm also aware there's no EDP package for this combination at the moment. Rough specs: 
 

- Core 2 Duo 2.4Ghz

- 8GB Elipda DDR2 RAM

- Intel Wireless (I know it won't work, it's still installed but I turned it off)

- X3100 GPU

 

Installation issues:

- I used the "Install Lion" app and myHack 3.3.1 with the Extra directory Herve suggested in this post to create the installer inside a 10.9 VM. This seems to work fine, with the observation that the "Install Chameleon" step (done either separately or as part of the installer creation) seems to do nothing, no progress bars or anything and finishes instantly.

- I cannot boot this USB alone. I used Super Grub 2 disk, which supports booting a Mac install. That gets me into the myHack USB, where I can then install OS X.

- The first time I tried, the installer froze at the "less than one minute remaining" point where myHack takes over. The second time I tried, myHack prompted me for a few things, then also froze at roughly the same place

 

Booting issues:

- Chameleon does not seem to be installed. Despite the install freeze, I can boot to HDD (using the same Super Grub disk hack to load the new HDD install)

- Booting process hangs for a very long time (several minutes) at "Waiting for DSMOS" but eventually passes.

 

There are some other issues as well (Keyboard works, trackpoint mouse doesn't. Using a USB mouse), but these are currently the main problems. Running "Install Chameleon" from a booted system does nothing, and completes instantly as before.

 

I've attached my extras directory, and a verbose boot log.

 

UPDATE: I installed Chameleon via this procedure, which lets me boot from HDD without Super Grub Disk, but it takes several minutes to get past the "Waiting for DSMOS".

 

Sound doesn't work, neither does graphics acceleration. I've made a post in the "Post Install" section for these, but I'd still like to figure out why myHack itself and the installation both lacked Chameleon...

 

 

R

 

bootlog_verbose.txt

Extra.zip

Link to comment
Share on other sites

 Share

×
×
  • Create New...